After login, monitor still acts funky

Fam,

I was foolish enough to try another garuda-update and my monitor started doing funky things again, literally the same thing as before.

Described a little better, it goes like this. I reboot on either zen or lts kernel, and i'm presented with the login screen on both monitors. I login, and immediately the ASUS monitor (my primary) reads No Signal regardless of if i'm using HDMI or DisplayPort. I go into Display Settings and try to activate it. It doesn't read an input.

What I did last time to fix it is not working.

Last edit:
works with HDMI alone, does not work with both HDMI and DP plugged in. DP alone also does not work. I'd like to use the monitor with DP because it's the only input that does 165hz.

garuda-inxi
╭─[email protected] in ~ via  v11.0.17 took 4ms
╰─λ garuda-inxi                                                                                       (base)
System:
Kernel: 5.15.75-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=f6cccf9c-8580-435e-8f33-927e3e31bb2d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=2e9cba84-8fd3-4884-995e-6ac1c54716ad loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F34
date: 06/10/2021
Battery:
ID-1: hidpp_battery_0 charge: 54% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
CPU:
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3665 high: 4562 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3803 2: 3593
3: 4117 4: 3591 5: 4159 6: 3592 7: 3592 8: 3592 9: 3747 10: 3592 11: 3588
12: 3591 13: 3593 14: 3588 15: 3593 16: 3594 17: 3595 18: 3581 19: 3778
20: 3593 21: 3586 22: 3592 23: 3375 24: 4562 25: 3590 26: 3586 27: 3593
28: 3593 29: 3592 30: 3594 31: 3585 32: 3584 bogomips: 223581
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 0a:00.0 chip-ID: 10de:1e84
class-ID: 0300
Device-2: Focusrite-Novation Scarlett 2i2 Camera type: USB
driver: snd-usb-audio bus-ID: 7-2:2 chip-ID: 1235:8210 class-ID: 0102
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 5119x1440 s-dpi: 107 s-size: 1215x342mm (47.83x13.46")
s-diag: 1262mm (49.69")
Monitor-1: DP-0 pos: primary res: 2560x1440 dpi: 109
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
Monitor-2: DP-2 size-res: N/A modes: N/A
Monitor-3: HDMI-0 size-res: N/A modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: YUAN High-Tech Development vendor: Corsair Memory driver: N/A
pcie: bus-ID: 7-2:2 gen: 1 chip-ID: 1235:8210 speed: 2.5 GT/s
class-ID: 0102 serial: <filter> lanes: 1 bus-ID: 06:00.0
chip-ID: 12ab:0380 class-ID: 0480
Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:10f8 class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-4: Focusrite-Novation Scarlett 2i2 Camera type: USB
driver: snd-usb-audio
Sound API: ALSA v: k5.15.75-1-lts running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
bus-ID: 7-4:4 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 4.57 TiB used: 917.18 GiB (19.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: SanDisk model: ADATA SX6000PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s85
temp: 37.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1XHE-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614600WD temp: 43.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EARX-00ZUDB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 896.73 GiB size: 896.73 GiB (100.00%) used: 430.93 GiB
(48.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 592 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 896.73 GiB size: 896.73 GiB (100.00%) used: 430.93
GiB (48.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 896.73 GiB size: 896.73 GiB (100.00%) used: 430.93
GiB (48.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 896.73 GiB size: 896.73 GiB (100.00%) used: 430.93
GiB (48.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.49 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 44.4 C mobo: 32.0 C gpu: nvidia temp: 38 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 24%
Info:
Processes: 508 Uptime: 5m wakeups: 2 Memory: 31.29 GiB used: 4.79 GiB
(15.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: pm: pacman
pkgs: 2542 libs: 566 tools: octopi,pamac,paru Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-01-22
Last full system update: 2022-10-28
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            systemd-guest-user.service

journalctl -xe
dmesg

Cross-posted to KDE forums.

1 Like
2 Likes

I sadly don't have any ideas to contribute as I'm not experienced with this type of issues, but I certainly appreciate the effort put into these threads :slight_smile: hope someone has an idea :blush:

2 Likes

Lol! i don't have a choice unfortunately. I need 3 monitors to do what i'm doing for research, and i have exactly 1 hdmi output that i now have to use for my main monitor instead of my annotation tablet.

Sad day. :frowning:

Thanks for your support anyhow! :slight_smile:

3 Likes

Try switching to Wayland and see if you have better luck.

...Wait a second...

...Déjà vu, anyone? :joy:

After fully updating:

sudo pacman -S plasma-wayland-session

You will have to add the modesetting kernel parameter (Nvidia :roll_eyes:).

sudo micro /etc/default/grub

On the GRUB_CMDLINE_LINUX_DEFAULT= line, add nvidia-drm.modeset=1 to the other kernel parameters on the line. Save and exit, then:

sudo update-grub

Reboot, and find the cog wheel on the login screen to change to a Wayland session.

2 Likes

Willing to try anything at this point, will report back! THANK YOU!

Now i'm getting some weird compositor issues that i didn't have before, and my mouseover tooltips are appearing on the side of the screen.

And discord won't even show... I need that for my study group. I will have to go back to X11.

EDIT: switching back to x11 made it mysteriously work again... i'm sure this isn't the last i've seen of DP bug.

I found out that Wayland is great at one thing on nvidia machines. THe issue happened again today, so i logged out, logged back in on Wayland, adjusted monitor settings, then logged back in on X11.

I want to see this happen a few more times and ensure this is a fix before i call it a solution/workaround.

3 Likes

:thinking: Hmm, I don't think that is the intended use of Wayland. :rofl:

I'm glad it's helping, even if it is in an odd, very hacky way. I'm curious what is happening on the back end that seems to jostle the display back into working.

1 Like

This has to be a hardware, or a driver issue. I definitely don't know enough about any of that to even begin to troubleshoot it. It exists on multiple kernels if so...

I haven't tried other window managers outside of VMs though. Maybe that's the next step. I don't really have time to "agile" this though, move fast and break stuff.

Happened again after my computer autolocked my screen. Absolutely wayland works as a workaround for this bug.