After garuda installation the system won't boot without installation USB stick


I was trying to resolve my problem on my own, but ran out of ideas. Just after installation the fresh garuda system hangs on loading initial ramdisk. When I leave the installation USB drive the startup goes smoothly.

Do you have any idea how USB drive could be linked with the startup (grub)? The grub config points to UUID of my hard disk and there is no indication that the USB drive would be used for anything during the startup. At some point I re-created the grub.cfg using chroot with linux started from the USB drive. Could that generate my issue? The grub-mkconfig made at that point looked like this one:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-10-26 11:54:03 | @/.snapshots/30/snapshot | post | emacs libotf libxaw m17n-db m17n-lib tree-sitter vim vim-runtime |
Found snapshot: 2023-10-26 11:54:01 | @/.snapshots/29/snapshot | pre  | pacman -S vim emacs                                              |
Found snapshot: 2023-10-26 11:50:51 | @/.snapshots/28/snapshot | post | elixir erlang libmspack wxwidgets-common wxwidgets-gtk3          |
Found snapshot: 2023-10-26 11:50:49 | @/.snapshots/27/snapshot | pre  | pacman -S erlang elixir                                          |
Found snapshot: 2023-10-26 01:05:36 | @/.snapshots/26/snapshot | post | lib32-acl lib32-gettext lib32-libnl lib32-libpcap wine           |
Found snapshot: 2023-10-26 01:05:33 | @/.snapshots/25/snapshot | pre  | pacman -S multilib/wine                                          |
Found snapshot: 2023-10-26 00:56:16 | @/.snapshots/24/snapshot | post | gamemode                                                         |
Found snapshot: 2023-10-26 00:56:15 | @/.snapshots/23/snapshot | pre  | pacman -S extra/gamemode                                         |
Found snapshot: 2023-10-25 22:57:12 | @/.snapshots/22/snapshot | post | mesa-utils                                                       |
Found snapshot: 2023-10-25 22:57:11 | @/.snapshots/21/snapshot | pre  | pacman -S extra/mesa-utils                                       |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.mYSYreDpar .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin

Garuda inxi:

sudo garuda-inxi
  Kernel: 6.5.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=064f5cda-0c29-42f7-abdd-20d3903825ef rw rootflags=subvol=@ ibt=off nomodeset
    i915.modeset=0 nouveau.modeset=0 rcutree.rcu_idle_gp_delay=1 rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 ibt=off
  Console: pty pts/1 DM: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP ZBook 15 v: A3009CD10002 serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Hewlett-Packard model: 1909 v: KBC Version 94.50 serial: <filter> UEFI: Hewlett-Packard
    v: L70 Ver. 01.07 date: 01/10/2014
  ID-1: BAT0 charge: 55.8 Wh (97.0%) condition: 57.5/57.5 Wh (100.0%) volts: 16.6 min: 14.4
    model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: not charging
  Info: model: Intel Core i7-4800MQ socket: LGA1150 (U3E1) note: check bits: 64 type: MT MCP
    arch: Haswell gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2095 high: 3700 min/max: 800/3700 base/boost: 2700/2700 scaling:
    driver: intel_cpufreq governor: schedutil volts: 0.9 V ext-clock: 100 MHz cores: 1: 800 2: 3700
    3: 2961 4: 800 5: 1600 6: 3700 7: 2400 8: 800 bogomips: 43099
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GK107GLM [Quadro K1100M] vendor: Hewlett-Packard ZBook 15 driver: nvidia
    v: 390.157 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx process: TSMC 28nm built: 2012-18
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:0ff6 class-ID: 0300
  Device-2: Lite-On HP HD Webcam driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 3-7:7 chip-ID: 04ca:7025 class-ID: 0e02
  Display: x11 server: v: compositor: Picom v: git-b700a driver: X:
    loaded: nvidia gpu: nvidia tty: 312x60
  Monitor-1: Unknown-1 size-res: N/A in console modes: 1920x1080
  API: EGL v: 1.5 platforms: gbm: drv: kms_swrast surfaceless: drv: swrast inactive: wayland,x11
  API: OpenGL v: 4.5 vendor: mesa v: 23.2.1-arch1.2 note: console (EGL sourced)
    renderer: llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: discrete-gpu name: Quadro K1100M driver: N/A
    device-ID: 10de:0ff6 surfaces: N/A device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits)
    driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: N/A
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard ZBook 15
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Hewlett-Packard ZBook 15 driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  API: ALSA v: k6.5.8-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.83 status: n/a (root, process) with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack
    type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I217-LM vendor: Hewlett-Packard ZBook 15 driver: e1000e v: kernel
    port: 6040 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 5c:00.0 chip-ID: 8086:088e class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel Centrino Bluetooth Wireless Transceiver driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-12:10 chip-ID: 8087:07da class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.0 lmp-v: 6 status:
    discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 454.46 GiB used: 27.2 GiB (6.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 054
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: DataTraveler 3.0 size: 7.32 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: PMAP scheme: MBR
  ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%) used: 27.2 GiB (6.1%) fs: btrfs
    block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    block-size: 512 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%) used: 27.2 GiB (6.1%) fs: btrfs
    block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%) used: 27.2 GiB (6.1%) fs: btrfs
    block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%) used: 27.2 GiB (6.1%) fs: btrfs
    block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 23.25 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 243 Uptime: 52m wakeups: 1 Memory: total: 24 GiB available: 23.25 GiB
  used: 1.39 GiB (6.0%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: pm: pacman pkgs: 1276 libs: 385 tools: octopi,paru
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: pty pts/1 (SSH) inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-10-25
  Last full system update: 2023-10-26
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

There /dev/sdb (my USB drive) is mentioned here, I’m not sure how that impacts the grub configuration.


Check your SATA controller is set to AHCI mode in your device’s setup utility aka UEFI/BIOS menu.

Also always post your garuda-inxi output as mentioned in the template. You can do that from the live ISO as well.

1 Like

I’ve updated my original post with garuda-inxi output. I used other distributions on this computer (a previous one was a plain arch linux) and haven’t this kind of issue, so I guess my BIOS/UEFI is set correctly.

Checked also BIOS/UEFI, I have AHCI set for the SATA controller.

Hmm :thinking: just a guess but could this be a kernel issue? Have you tried the LTS kernel? If not here is how you can try it out,


garuda-chroot -a

To chroot into the system, in case this fails (happens if you have ventoy on your USB stick) you can look at this post to manually chroot into your system → How to chroot Garuda Linux The post goes on to explain how to reinstall grub you can try that as well but here is what you need to do to install linux-lts.

Once inside the chroot env.,

pacman -S linux-lts linux-lts-headers

then exit the chroot env, reboot and from grub’s advanced menu select linux-lts. See if having a different kernel makes any difference?

Do I have to boot from the USB stick and chroot? My system boots nicely on its own. All I have to do is to stick USB stick to have it up and running.

Hmm? I guess I didn’t understand the problem correctly. So having your USB stick in your system you can reach and use the actual installation (and not the Live ISO env. again the biggest noticeable difference between the two being the stark change in grub menu’s theme) but pulling it out makes you stay stuck at loading initial ramdisk message?

Have you looked at your fstab file to ensure that this usb stick is not set to automount in there?

Yes, that’s exactly my issue. The /etc/fstab file points to my main hard drive only - no references to USB stick:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=E9F1-0CC7                            /boot/efi      vfat    defaults,noatime 0 2
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=064f5cda-0c29-42f7-abdd-20d3903825ef /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

HI, I had a similar issue on a recent install. It was a kernel panic in my case. I upgraded the BIOS on my system and I then could boot without the USB stick


Edit: what maverickchris says makes sense your UEFI is from 2014. Checking vendor’s site for any critical updates would be a good idea.

This is quite the weird dilemma.

Have you tried to simply pull out the usb stick (or safely eject it) before reproducing grub config again?

sudo update-grub

update-grub is a small preinstalled shell script that runs grub-mkconfig. So no difference in using this or the actual command directly.

The /dev/sdb1 is my USB stick. I found elsewhere that this entry shall not be an issue. I guess this entry just indicate that grub won’t be able to generate dual-boot entries for this drive.

I was trying also to find the way to generate/update, but there is no grub-mkdevicemap command available any longer.

How to safely eject usb stick? I can try that.

I used sudo eject /dev/sdb, then regenerated grub with grub-update, no entries about /dev/sdb this time, but it hangs as it did before. When I put USB stick it starts.

In this case trying what maverickchris suggested seems to be a good choice. Your UEFI is from 2014 it’s quite old. Check vendor’s site for any updates.

My laptop seems to be smarter than me. The BIOS updated on its own when I connected the network cable. Now the BIOS has newest available version and the llinux booted without USB stick.

Thanks for help. I would never thought about touching the BIOS version.


That’s quite magical honestly. I never knew BIOS could self update itself. Well welcome to the garuda community :+1:


I moved the Solution back to @maverickchris , since they gave the hint to update the BIOS… :wink:
Welcome to both, by-the-way!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.