(after 5.11.1-zen upgrade): dkms failed to build modules for nvidia-390xx

Another related favor I have to ask: can a Linux guru browse through my journalctl -xb logs and give them a brief sanity check? If so, I have some related questions about how to discover modified EFI bootloaders, driver issues, etc, in addition to some fairly easy-to-notice ACPI/etc issues. Thanks! I'll post the relevant logs as soon as I can.

memavaild.service problems during boot

i've encountered this problem before and i can't remember how I resolved it.

some specifics on my system:

  • My 2013 MacbookPro11,1 has an i7 with a GeForce GT 750M -- this chipset only supports nvidia-390xx-* at the latest.

  • Unfortately, while the GeForce GTX 750 chipset supports the Nvidia 455xx drivers & featureset, its mobile counterpart GeForce GT 750M does not :frowning:

  • I'm running KDE on Garuda Linux with some Garuda metapackages missing. Not exactly a standard set of Garuda packages.

  • In the past, I have removed some of these metapackages from my system to get around certain GUI App & userland depedency issues (like installing Zoom and trying to run a Wayland-first system). I'm running Wayland, a Wayland Firefox AUR build (which requires Pipewire).

Are my nvidia driver problems caused by a memavaild.service failure?

Lacking this service could some problems later in boot when loading the nvidia driver modules. the result is that I quickly get a frozen boot image.

fortunately, i can edit the boot entry to remove the "splash" directive, giving me console output during boot and input-focus on the terminal ... which allows me to use the ctrl-alt Fx shortcut to login to a new terminal session (where Fx is F2 through F7).

So i have access to modify my system, load packages, etc without needing garuda-chroot

I've tried the following:

None of these seem to affect the failure of memavaild.service. i checked the Google-machine, but have found almost nothing about this service failure on boot.

  • booting from the last stable BtrFS snapshot. This works, but sudo pacman -Syu breaks my system.

  • using mhwd -li and mhwd -i video-nvidia-390xx-*dkms to try to add/remove the drivers, which didn't seem to affect the status of the modules being loaded during boot. to be clear,i was intermittently loading my initramdisk & its backup, so this could be responsible

  • mhwd failed to remove removing nvidia-390xx-* packages, since pacman could proceed with unmet dependencies. This required sudo pacman -R gme python-py3nvmllib32-nvidia-390xx-utils nvidia-390xx-utils nvidia-390xx-settings nvidia-390xx-dkms

  • using mhwd and etc to install video-linux drivers. i am unsure of whether they are being loaded as modules during boot. i can't validate whether video-linux drivers are set as active. i tried referring to mhwd-gpu --help but couldn't find where to set this checkbox via command-line.

  • reinstalling grub

Misc questions, notes, possibilities:

  • it may be that memavaild.service is expected to be running to provide information to Linux about GPU memory stats and, lacking this service, loading the GPU modules fails. (i am a few pieces short of understanding how Kernel modules detect availablility of required services and/or interact with them on boot)

  • it may be that the 5.11.1-zen kernel is causing the failures.

  • I noticed a garuda-* metapackage involving mhwd which was installed the last time before I updated. I may be able to post my last /var/log/pacman.log. Whether this metapackage is specifically what broke my system, i donno.

  • I had originally removed the video-linux drivers from my system. I have noticed that they include vulkan related dependencies, so I may want to try them in the future.

  • However, AFAIK, OBS cannot use the NVENC GPU-assisted video encoding functionality without nvidia drivers. I have a 2013 MacbookPro with a GPU and this is a must-have for me. I livestream while using software like Krita and Julia -- OBS's CPU video encoding causes dropped frames to hover at 2% and spike at 25-75% during heavy CPU usage. Is there anything the video-linux drivers can do to supplant this?

  • The other time I ran into a memavaild.service failure during boot, I removed tela-circle-icon-theme-git package and perhaps some related dependencies ... and I think I remember this fixing my problems? I can't remember how i solved it, but I swear it had something to do with the tela-circle-icon-theme-git plugin -- which took me about 30 minutes to load after the package was downloaded? Regardless, whatever I did to solve this the first time, it seemed to be unrelated to the memavaild.service.

  • There may be some problem with Arch/KDE's resume/hibernate functionality, but swapon /dev/sdxN is showing that my swap is mapped during boot. How do I check this?

  • Can anyone provide a link or a quick overview on the differences b/w the video-linux and video-nvidia-390xx-dkms drivers?

  • (Related to video-linux drivers?) I heard that Linux gaming just got an upgrade with kernel 5.11: something to do with beginning to implement anti-cheat capabilities into the Linux Kernel.

  • On the nvidia drivers: when reinstalling my video-nvidia drivers recently, the system initially installed video-nvidia-390xx-* with support for nvidia drivers 390.141. then, before i was able to use 390.141, the system decided it needed to downgrade to 390.138-3. Does anyone know why this happened or which logs to search to discover why?

I've got to run for now, but I'll check back later tonight to add logs, etc... Thanks for your help!

1 Like

Look at its journal entries to see why it's failing before you go off and look at a load of other things.

For example:

sudo journalctl -u memavaild.service

Please also try to keep a thread focussed on a single issue.

2 Likes

yeh, turns out that memavaild.service has basically never worked ... so that's a red herring.

it looks like i upgraded the kernel, but the linux-zen-headers-5.11.1.zen1-1 package wasn't installed, so dkms couldn't build the nvidia modules ... or at least that's where I'm at now.

however dkms install --no-depmod -m nvidia -v 390.138 -k 5.11.1-zen1-1-zen is still failing. the log /var/lib/dkms/nvidia/390.138/build/make.log shows that a header asm/kmap_types.h cannot be found.

I updated 390xx to 390.141, so you're running an old driver package without support for kernel 5.11. Therefore, make sure you have fully updated your system.

6 Likes

On Manjaro I'm having problems installing 390xx drivers using mhwd, I have an old Asus laptop with a 710m and linux kernel is 5.11.rc7.d0207.g92bf226-1 this is the error message I get after

sudo mhwd -i pci video-nvidia-390xx
Installing video-nvidia-390xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
error: target not found: linux511-nvidia-390xx
core is up to date
extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!
Error: script failed!

This is the very wrong forum. Please complain about Manjaro to the Manjaro developers, or switch over to Garuda where things work correctly. :stuck_out_tongue_winking_eye:

7 Likes

I mean it seems to be the same exact problem, which is not something related with the distro, but whatever

1 Like

It is distro-specific if the issue is that Manjaro has 390xx drivers that are not compatible with kernel 5.11. :wink:

See? No 390xx driver available for linux511 in Manjaro.

But really, now you're here, try a Garuda live image and see what you think. The KDE and Xfce images provide contrasting approaches to a Garuda setup, but if neither takes your fancy then have a look at EndeavourOS as that provides a much more "vanilla" setup.

"Once you go Arch you don't go back"

6 Likes

alright my fault, I apologize, btw I wrote here cause I have another pc on garuda

3 Likes

Ah, fair enough. It's not always obvious how different Manjaro is to other Arch derivatives.

3 Likes

run sudo pacman -Syu linux511-nvidia-390xx, perhaps with verbose output. whatever is causing pacman to fail should show there.

before you try this, you may get more consistent results by simply updating pacman entirely before installing linux511-nvidia-390xx... however this package is not available for me AFAIK.

i would also recommend switching over to Garuda from Manjaro

thanks so much! what kind of help do you need for the 390xx packages on AUR? I don't know much about managing security for these packages, but I have done a bit of graphics programming. if we connect and i get an idea of what's required to maintain this AUR package, then perhaps I can help out.

I have to use VirtualDJ, which I don't feel like setting up with Wine, so for now I'm trying to get Julia to run in MacOS... xcode is in a bad state though :frowning: as soon as I can, i'll update 390xx in Garuda.

1 Like

Essentially, testing on 390xx hardware and ongoing patching of the NVIDIA driver for new kernel support.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

well i think i can help out with that. i'll set the AUR package to send me updates and you can also ping me on here. i have the 390xx hardware and it doesn't look like i'm getting anything newer. the updates worked perfectly for me...

but now i'm running into problems with compatibility between CUDA and gstreamer-nvidia -- the last of which likes to install cuda-11.2 and/or for no reason at all

.... technically it's because gstreamer-nvidia requires the cuda package and tries to satisfy the dependencies, but some package hasn't set the cuda <= 10.0 requirement properly, so pacman doesn't know to prevent the upgrade. cuda > 11.0 has some idiosyncratic install/upgrade scripts AFAIK, which end up requiring nvidia-450xx, nvidia-460xx or some 4-series drivers -- even though this doesn't seem to be specified in the CUDA package AFAIK. so then installing the CUDA drivers upgrades my nvidia-390xx drivers.

long story short: i've been re/installing nvidia-390xx with cuda-y.x, then rebooting over and over again, while decrementing y. when it seems that the gst-plugins-bad or gstreamer-nvidia packages should even detect CUDA -- they don't. they ignore it and sometimes upgrade it anyways.

i've played around with aur-utils a bit, but i don't have a ton of experience managing my own dependencies and ABS packages. is this what I need to do?

1 Like

Have you tried or thought about Nouveau? Last I heard the 600/700 series of GPUs was quite well supported.

Nvidia is such a PITA :pensive:

4 Likes

@jonathon @Yorper

I'm trying out the nouveau drivers and they are working out well. However, I really need to get obs-studio-wayland to be able to use nvenc encoding or at least the VAAPI encoding. After setting up my system to use nouveau/mesa, I still can't get anything but the software H264 encoding to work in OBS. Also, cuda is unavailable AFAIK when using nouveau.

I just found that NVidia offers the nvidia-418xx drivers for my card, but there's no arch package for the 418 drivers. These drivers did compile for me, but failed when trying to compile the DKMS module.

Since the zen-kernel requires DKMS (with patches) for the driver modules to be persistently recompiled on most pacman updates, I can't simply use their installer. I started cargo-culting Jonathan's 390xx ABS packages from AUR to see if the same Linux 4.x and 5.x patches on NVidia would miraculously function (or at least result in something very close), but then started trying out the Nouveau drivers.

However, I'm unsure of whether I want to follow this line of work, since I am not experienced enough to post/maintain it on AUR and, even if I was to use it personally, it could break at any time and I would be lucky to address changes in the patches, should they be needed.

One last thing: I found out that the gstreamer-nvidia package may not be needed for me to get NVEncode& NVDecode functionality in OBS/etc. The only thing that should be needed is the NVidia Video Codec SDK ... but they recently bumped the minimum NVidia Driver version to 455, so I need a legacy version of the NVidia Codec SDK. If this SDK exists (and thus the NVEnc functions exist on my system), then OBS should simply be able to use the capability without any custom OBS build/plugins (for OBS >= 23). However, I am unsure of: (1) whether this requires > 390xx and (2) whether this video SDK would require a DKMS driver to be built.

I know this thread goes in a ton of different directions, but if anyone else has to go through this or make these decisions, this would save a ton of time.

All I know is that, about 2-3 months ago, I could stream from within OBS for the first time using the NVEnc and it's required for me to have a stable stream. Then it was gone.

Have you explicitly installed opencl-nvidia-390xx ?

3 Likes

No one likes to spend money when their graphics card is still fully functional. However, this will be a never ending battle for you if you insist on using Nvidia cards. I just got tired of Nvidia depreciating drivers of my last 2 graphics card purchases. Never again. While AMD is not perfect at least they support the open source Linux community and you will probably have driver support from them for many years to come.

If cost is the prohibiting factor then perhaps buying used from EBay may be a cost effective way of changing cards. The buyer is well protected on used transactions and if you are selective in your purchasing decisions many great deals can be had this way. You're headaches are never going to end as long as you persist with Nvidia, they will only get worse as your card gets older and less supported over time.

5 Likes

I have an HP laser printer (~1995?) and an all-in-one canon colour printer scanner that have not been supported on Win for decades but still work on linux.

(I have to admit that I powered them down 2 years ago because I don't need them, but I assume they still work).

I look since month for new PC and laptop. All good ready Notebook CPU Ryzen you can buy only with Nvidia GPU. So, no Notebook.

All fine Ryzen CPU you can#t buy since offer date (Out of stock).
But they do not close the promotion websites :slight_smile:

The shops offer only the rest of old hardware, they still have in stock. Understandable, but by the time they're gone, there's already the next generation and I haven't bought anything again :smiley:

Not my year(s) since Ryzen 1 .

2 Likes