Add/remove software not opening

add/remove software not opening i've also tried to restore it with previous snapshot and it opens and when i got some updates after updating i closed but when i tried to open it again it's not starting again
output of inxi -Fxxxz

[πŸ”] Γ— inxi -Fxxxz
System:    Kernel: 5.12.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 
tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: EX-A320M-GAMING v: Rev X.0x serial: <filter> 
UEFI: American Megatrends v: 5007 date: 06/18/2019 
CPU:       Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP 
arch: Zen/Zen+ note: check rev: 1 cache: L2: 2 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 59089 
Speed: 2940 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 1: 2940 2: 3045 
3: 3055 4: 3032 5: 3029 6: 3045 7: 3061 8: 3053 
Graphics:  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 06:00.0 
chip-ID: 1002:15d8 class-ID: 0300 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa resolution: 1600x900~60Hz s-dpi: 96 
OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.12.8-zen1-1-zen LLVM 11.1.0) 
v: 4.6 Mesa 21.1.1 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel 
v: kernel bus-ID: 06:00.1 chip-ID: 1002:15de class-ID: 0403 
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.8-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
v: kernel port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp4s0 state: down mac: <filter> 
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB driver: r8188eu 
bus-ID: 1-7:2 chip-ID: 0bda:8179 class-ID: 0000 serial: <filter> 
IF: wlp1s0f0u7 state: up mac: <filter>
Drives:    Local Storage: total: 689.33 GiB used: 136.83 GiB (19.8%)
ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB speed: 6.0 Gb/s
rotation: SSD serial: <filter> rev: 041 scheme: GPT
ID-2: /dev/sdb vendor: Seagate model: ST3500414CS size: 465.76 GiB speed: 3.0 Gb/s
rotation: 5900 rpm serial: <filter> rev: CA14 scheme: GPT
Partition: ID-1: / size: 214.52 GiB used: 22.7 GiB (10.6%) fs: btrfs dev: /dev/sda2
ID-2: /boot/efi size: 252 MiB used: 546 KiB (0.2%) fs: vfat dev: /dev/sda1
ID-3: /home size: 214.52 GiB used: 22.7 GiB (10.6%) fs: btrfs dev: /dev/sda2
ID-4: /var/log size: 214.52 GiB used: 22.7 GiB (10.6%) fs: btrfs dev: /dev/sda2
ID-5: /var/tmp size: 214.52 GiB used: 22.7 GiB (10.6%) fs: btrfs dev: /dev/sda2
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
ID-2: swap-2 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 740.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 53.9 C mobo: 0 C gpu: amdgpu temp: 53.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 306 Uptime: 12m wakeups: 0 Memory: 5.79 GiB used: 2.38 GiB (41.1%) Init: systemd
v: 248 Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1249 Shell: fish v: 3.2.2
running-in: konsole inxi: 3.3.04
1 Like

This looks different from recent problems, when it was opening but without showing anything.
In that case it was solved by:
sudo pacman -S archlinux-appstream-data-pamac
If you want to give it a try...

3 Likes

Im quite sure that this is also caused by the pacman 6 update, to be sure open pamac-manager using the terminal and post the output please. :eyes:

3 Likes

I think it is because pacman was update and pamac needs to be rebuilt. Just wait for it to be rebuilt.

3 Likes

The AUR page says this:

image

The issue in question is this one, to track progress:

4 Likes

I have restored system again with previous snapshot and I can open add/remove software
and got too many updates but I will not update this time bcz problem occurs again If I update this time
Waiting for bug fix

output after restoring my system from snapshot (add/remove software is opening and got too many updates but not updating)

╭─[email protected] in ~
╰─λ open pamac-manager

╭─[email protected] in ~
╰─λ Icon theme "adwaita" not found.
Icon theme "ubuntu-mono" not found.
Icon theme "yaru" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.

(google-chrome:24945): Gtk-WARNING **: 14:29:37.129: Theme parsing error: gtk-dark.css:6342:10: 'height' is not a valid property name
Opening in existing browser session.

Same- just installed for the first time, and pamac etc was working fine before the huge update, but now it doesn't open. Kind of a relief to see it isn't my fault honestly I was about to jump ship lol

1 Like

Yeah, because you didnt update pacman to version 6 yet. Nothing but waiting for Manjaro to fix this can be done here :man_shrugging:

3 Likes

This is what I'm getting:

╰─λ pamac-manager
pamac-manager: error while loading shared libraries: libalpm.so.12: cannot open shared object file: No such file or directory

Funny how we're effectively downstream from Manjaro that way. I'm going to periodically try pacman -Syu chaotic-aur/pamac-aur-git in hopes it comes faster that way :face_with_raised_eyebrow:

warning: cannot resolve "pacman<5.3", a dependency of "pamac-aur-git"
:: The following package cannot be upgraded due to unresolvable dependencies:
pamac-aur-git
2 Likes

Agreed...it's not very agreeable. But it's not like they're not a major player in the Arch world nowadays. If everyone would quit panicking for a bit it might just get fixed.

I've never seen such a whiny pack of--whatever--so bummed they couldn't update right now!
:smiley:

7 Likes

We are effectively downstream for a lot of projects. Arch Linux, KDE, GNOME, etc. Thats not an issue, its just how open source works at times. Manjaro is just another of those. Luckily its "just" Pamac being influenced by them :wink:

4 Likes

I chose to take the update and cascade-remove pamac, so no Garuda Assistant for me either for a while... but I guess I'm one of those

:laughing:
Linux, like all freedoms, doesn't come without compromises.

4 Likes

Ey, Id trade a fully recently updated system with latest software for a working GUI package manager which I almost never use any day and wouldnt call it compromise :stuck_out_tongue:

4 Likes

They're (GUI Pkg Mgr) handy to reach that stage.

I suspect that's quite a few users, or at least the ones not "growing up" with some sort of package store(front).

In fact, with Archlinux who needs an update "reminder" running resident since, as we know, Arch has updates every day. :wink:

4 Likes

This statement is just silly. You don't need a GUI package manager to update your system

If you are not keen on using a GUI tool dependent on Manjaro to update immediately use the terminal. If you are a KDE user it makes more sense to install a Qt GUI updater such as Octopi or Discover if you don't want MJ tools.

I suspect any other GUI update tool will also have issues until the apps are updated themselves. Learn to merge your pacnew files if you haven't done so already, then simply use pacman until the glitzy breakage prone GUI tools are updated.

6 Likes

I update all my distros on a 2 weekly basis. Including the arch based ones. I just updated all my arch ones about 4-5 days ago and so I'll address this in 9 days.

If need be I can rebuild necessary AUR packages (including pamac-aur, yay) in terminal. Except for garuda vm, I don't use the chaos repo.

Yes, pamac is useful for one off tasks, but since it's from manjaro one has to accept that its release timing is slightly behind arch. Same if you use manjaro stable and some AUR packages can't be updated because a dependency hasn't hit the stable repo yet. Pros and cons.

One just has to accept it and move on.

5 Likes

I've never actually used pamac GUI, so I'll be fine. I just like to keep up with issues like this

2 Likes

In an attended solution to the problem, I installed "Bauh":
is a package manager made by the Manjaro team, also includes Flatpak, Snap, AppIt, and Arch / Aur.
It is minimal but does its job very well.
For install In the thermal:
$ sudo pip3 install bauh
$ bauh
If you want to start the command to automatically start: bauh-tray
Sorry for my English...

1 Like

Incorrect. Upstream has nothing to do with Manjaro:

Just because Manjaro includes something, or claims something as a part of an edition (e.g. Cutefish), doesn't mean it's theirs.

However, to confirm, Bauh is a perfectly viable option.

But please don't do

It's in the AUR, so install it as your would any AUR package (e.g. use yay or paru or whatever).

4 Likes