ADB Fastboot and Qualcomm Android USB Drivers Installation Help

Read

please
and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.

Okay, yeah that didn't help. So I'm new to Garuda...it's by far one of the coolest and quickest distro's I've tried and I've tried...well, a LOT, haha. My biggest thing is needing compatibility to adb and fastboot protocols(?) for Android flashing/programming/etc. I tried running the following command:
sudo pacman -Syyu --needed blackarch --overwrite=''*
and the following error came back to me:
╭─[email protected] in ~ took 11s
[:red_circle:] × sudo pacman -Syyu --needed blackarch --overwrite=''*

:: Synchronizing package databases...
core 134.2 KiB 69.3 KiB/s 00:02 [------------------------------------] 100%
extra 1565.4 KiB 330 KiB/s 00:05 [------------------------------------] 100%
community 5.6 MiB 631 KiB/s 00:09 [------------------------------------] 100%
multilib 149.7 KiB 80.6 KiB/s 00:02 [------------------------------------] 100%
chaotic-aur 1248.5 KiB 532 KiB/s 00:02 [------------------------------------] 100%
error: target not found: blackarch

Furthermore, there are USB Drivers from Google for Android ADB/ADB Composite/fastboot/etc and how do I go about installing those drivers? Every single Linux guide I've found shows various ways, depending upon your kernel type, but none of the sudo commands seem to be speaking the same language as Garuda. I would like to say, though, that other than this, for a Beginner-Slightly Experienced Linux user, this entire OS has been VERY user friendly and fun to work with. This current issue is the only thing I've had any trouble with thus far.
Lastly, say I can get ADB/fastboot support installed (I think it'd be cool if it was part of that "Add/Remove Software" option in the Welcome Screen, where we can choose emulators and gaming stuff to add/remove but anways...say some helpful, smart, awesome person helps me get ADB and Fastboot going; my next thing is QUALCOMM. Qualcomm has the QSBULK drivers for reading Qualcomm chipset devices in EDL mode, 9008, and I do a lot of development so I am REALLY hoping there is a way to install these drivers OR install the drivers I've installed on Windows without needing to search out a Garuda-Linux version. But again, I don't know. Could anyone please give me some friendly advice/help. Perhaps adb is already in the Garuda system but as I'm still learning the file system maybe I just haven't found it yet. I would really appreciate ANYONE taking time to try to help me out.
Thanks so much for letting me be a part of the community and thanks to the very smart, very hard-working developers who made Garuda a distro option for all of us!

Best Wishes,
Clinton

Please one "problem" one thread.
BlackArch
Android

2021-07-10_19-24

*sudo pacman -Syyu --needed blackarch --overwrite='*'*
*and the following error came back to me:*
*╭─[email protected] in ~ took 11s*
****[:red_circle:] × sudo pacman -Syyu --needed blackarch --overwrite='*'****

****:: Synchronizing package databases...****
****core 134.2 KiB 69.3 KiB/s 00:02 [------------------------------------] 100%****
****extra 1565.4 KiB 330 KiB/s 00:05 [------------------------------------] 100%****
****community 5.6 MiB 631 KiB/s 00:09 [------------------------------------] 100%****
****multilib 149.7 KiB 80.6 KiB/s 00:02 [------------------------------------] 100%****
****chaotic-aur 1248.5 KiB 532 KiB/s 00:02 [------------------------------------] 100%****
****error: target not found: blackarch****

Help only if you read :slight_smile:

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.