Above and below portions of screen not working after update

Hi,

Using Garuda: garuda-dr460nized-linux-tkg-bmq-210107.iso

I was updating my computer day before yesterday, (I had not done it for a while) and restarted my computer. I was able to login properly with my user, but once logged in, some of the above and below portions of my screen stop responding. The mouse does work in those areas (and KRunner also works), but no window is rendered in the area. There is one thin area in the middle of the screen which works properly. I tried to restart, but the problem persisted.

I thought this might be caused by me not shifting to non-git versions of packages as told in https://forum.garudalinux.org/t/transition-to-fixed-release-packages/5613 (I am new to garuda, so I am not sure :slight_smile: ). Switching to fixed release packages did not work either. Also, alacritty shows a lot of warning messages like in https://forum.garudalinux.org/t/when-i-open-console-then-its-shows-some-text/6989. But the solution shown there does not work for me (do not know if that is relevant).

Output of inxi -Fxxxza

System:    Kernel: 5.11.17-152-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
           root=UUID=db8ae1fb-f80d-42ea-92da-84f2a93df45c rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=62cf41bd-318b-4740-88f9-9ace3ed0e2b1
           loglevel=3
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop Mobo: GOOGLE model: Zako v: 1.0 serial: <filter> UEFI: coreboot v: MrChromebox-4.11.2
           date: 03/17/2020
CPU:       Info: Dual Core model: Intel Core i7-4600U bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 45 (69)
           stepping: 1 microcode: 26 cache: L2: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16779
           Speed: 3060 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3060 2: 2993 3: 3153 4: 3036
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Google driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:0a16 class-ID: 0300
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
           Monitor-1: HDMI1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1") diag: 470mm (18.5")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 21.0.3 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Google driver: snd_hda_intel v: kernel bus-ID: 00:03.0
           chip-ID: 8086:0a0c class-ID: 0403
           Device-2: Intel 8 Series HD Audio vendor: Google driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
           class-ID: 0403
           Sound Server-1: ALSA v: k5.11.17-152-tkg-bmq running: yes
           Sound Server-2: JACK v: 0.125.0 running: no
           Sound Server-3: PulseAudio v: 14.2 running: yes
           Sound Server-4: PipeWire v: 0.3.26 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: 2000 bus-ID: 01:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Hewlett-Packard driver: ath9k v: kernel
           port: 2000 bus-ID: 02:00.0 chip-ID: 168c:0034 class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:6 chip-ID: 0cf3:311e class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 119.24 GiB used: 42.68 GiB (35.8%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: OSC model: M.2 128GB size: 119.24 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 7A scheme: GPT
Partition: ID-1: / raw-size: 110.15 GiB size: 110.15 GiB (100.00%) used: 42.67 GiB (38.7%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1
           maj-min: 8:1
           ID-3: /home raw-size: 110.15 GiB size: 110.15 GiB (100.00%) used: 42.67 GiB (38.7%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-4: /var/log raw-size: 110.15 GiB size: 110.15 GiB (100.00%) used: 42.67 GiB (38.7%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-5: /var/tmp raw-size: 110.15 GiB size: 110.15 GiB (100.00%) used: 42.67 GiB (38.7%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
           ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3
           ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
           ID-3: swap-3 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
           ID-4: swap-4 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
           ID-5: swap-5 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 127.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 237 Uptime: 22m wakeups: 0 Memory: 7.65 GiB used: 3.63 GiB (47.5%) Init: systemd v: 248 tool: systemctl
           Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1723 lib: 360 Shell: fish v: 3.2.1 running-in: alacritty
           inxi: 3.3.04

Let me know if more information is needed.

EDIT: This seems to be random. Sometimes it works properly, sometimes I face this problem. I had tried restarting the computer 5-7 times and saw this result.

Thanks

Just reboot your machine
And after restart your compositor

Hi,
Thanks for the reply, I think you mean:

  1. Reboot
  2. System Settings -> Compositor -> change to Opengl 2.0, apply, then change back to Opengl 3.1 and apply.
  3. Reboot

Doing these steps, I am not able to solve the problem.
Thanks

It looks like a latte-dock issue.
Search the forum for this.
Restart latte.
Set it to start with 3 sec delay.

2 Likes

This is odd dragonized doesn't normaly have this issue.

It has nothing to do with the distro or version. It's about the installed system (individual issue, HW dependent)

2 Likes

Hi,
Yeah, this seems to be a latte-dock error. Restarting latte-dock (pkill latte-dock & latte-dock) solved the problem for that session. As you told, I set a 3 second delay before starting latte-dock as shown here: https://forum.garudalinux.org/t/half-screen-and-latte-dock-glitch/5834/10.
And it seems to work! (Tested 5 times)
Thanks!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.