A2DP sink profile is unavailable

Hello! My bluetooth headphones are always set to the "Headset Head Unit (HSP/HFP)" profile, resulting in very poor sound quality. Setting them as A2DP sink would solve the issue, but the A2DP sink profile is unavailable as pactl confirms:

pactl list | grep -C2 A2DP

Profiles:
headset_head_unit: Headset Head Unit (HSP/HFP) (sinks: 1, sources: 1, priority: 30, available:yes)
a2dp_sink: High Fidelity Playback (A2DP Sink) (sinks: 1, sources: 0, priority: 40, available: no)
off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
Active Profile: headset_head_unit

The same exact issue is troubleshooted on the Arch wiki, but none of the solutions worked for me. I also tried using pipewire, but the issue remained. The headphones worked fine (the A2DP profile was available on both pulseaudio and pipewire) a few months back on a different Arch machine. Any ideas?

P.S. : dmesg provides the following output, I don't know if it has to do with the issue:

hci0: urb 00000000171613fa submission failed (90)
hci0: sending frame failed (-90)
hci0: SCO packet for unknown connection handle 0
hci0: SCO packet for unknown connection handle 48
hci0: SCO packet for unknown connection handle 257

Kernels tested: 5.10.43-1-lts, 5.12.10-zen1-1

There's an AUR package, IIRC (don't remember exact details) that should help with that. Someone (or Google) will.

regards

1 Like

Do you mean fix-bt-a2dp? If that's the one you mean, I already tried it (it was mentioned in the Arch wiki as a possible solution, but as stated before, no solution works for me).

Try a different headset if its got a built in mike and that is on it will not use A2DP or turn the mike off.

1 Like

Unfortunately I don't have a different bluetooth headset atm. I also tried Ubuntu LTS 20.04 live a few minutes ago on the same machine and everything worked fine. It could be the kernel, but unfortunately I can't test any other kernels on Garuda since it doesn't boot if I do so.

Use "advanced" in grub menu.

If several are installed.

Yeah I am aware, it literally won't boot (freezes in the middle of booting). I will have to investigate this further by disabling quiet mode in grub etc.

Edit: Any other suggestions apart from LTS kernel?

Ah, ok, now I understand.

1 Like

Managed to boot from lts (5.10.43-1-lts, I was missing nvidia-lts, oops), still not working. Original post updated with kernel versions.

Edit: can anyone test with their own headsets so I know I'm not a victim of a kernel/bluez/pulseaudio bug (everything is in the latest version btw)?

Works fine here on Gnome

2 Likes

Works in the latest KDE-Dragonized (live, non-gaming edition), which I see uses pipewire by default, a welcome change. I copied the pipewire configs from the live just in case, but the issue persists.

P.S.: Arch forums didn't provide any solutions either. In fact, no one ever replied :pensive:.

The issue seems to affect other users as well, you can see the discussion on the arch forums here.

Open issue on gitlab/github.
Garuda use maybe this "tools/apps" but Garuda can't fix them.

I know, problem is that none of the components (kernel, pipewire, pulseaudio, bluez, front-ends, headphones, hardware) seems to be to blame! So I have no idea where to report anything other than forums (more details on arch forums).

1 Like

Please do not post your non-Arch problems in the Arch Forums about the problems you are experiencing in Garuda. Garuda is not Arch, and you don't want to give Garuda users a bad reputation, do you?

Fact of the matter is, if I see your posts there I will have a moderator dustbin them as "not Arch." You signed up for the Arch Forums under conditions that you are attempting to evade.

That's not cool. Not at all.

3 Likes

Oh I'm sorry. Anyway, other users have the issue as well with vanilla Arch so at least it's not a Garuda specific issue. Won't happen again.

Edit: And it obviously has nothing to do with Garuda and its custom components additional to Arch.

Good news! A solution/workaround has been found:

  1. Downgrade bluez, bluez-libs, bluez-utils to version 5.58-1
  2. Remove /var/lib/bluetooth directory

We'll probably file a bug report to bluez.

2 Likes

I thought and the Wiki KDE uses bluesdevil for bluetooth?

1 Like

Yes KDE uses bluedevil as a front-end. Bluez is the back-end, and it's bluez that turned out to cause the issue.

1 Like

So why no problem With gnome that uses blues front end and back end that to me sounds like a blue devil problem not a blues problem?

1 Like