Zsh Segmentation Fault

I tried setting up zsh to work and look like fish since I already had some aliases and scripts that worked better with zsh. I used part of the provided .zshrc from garuda, but I saw that paleofetch was missing, so I added

# Run paleofetch if session is interactive
if [[ -o interactive ]] then
   paleofetch
fi

Most of the time this works perfectly, but the first time I launch the terminal after a login paleofetch fails and I get zsh: segmentation fault (core dumped) paleofetch. If I launch another terminal session this doesn't happen, but the first one always gets a segmentation fault. I really don't know what is causing this, since it only happens once per login.

Just use

paleofetch

:slight_smile:

2 Likes

Unfortunately even without the if condition, paleofetch crashes zsh. The output is this

                     .%;888:8898898:              [email protected]
                   x;XxXB%89b8:b8%b88:            ------------------
                .8Xxd                8X:.         OS: Garuda Linux x86_64
              .8Xx;                    8x:.       Kernel: 5.10.40-1-lts
            .tt8x          .d            x88;     Uptime: 0 mins
         [email protected];          .db:              [email protected];   
       ,tSXX°          [email protected];  Packages: 1615 (pacman)
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: zsh
   ,888S                                     pd!  Resolution: 1920x1080
zsh: segmentation fault (core dumped)  paleofetch

I don't know if it's my terminal's problem ( i am using tilix ) or a shell problem

2021-06-03_12-27
In xfce4-terminal


In tilix terminal

2021-06-03_12-32
ZSH in tilix

2021-06-03_12-34
With

# Run paleofetch if session is interactive
if [[ -o interactive ]] then
   paleofetch
fi

Work all fine

Segmentation fault" means that you tried to access memory that you do not have access to.

1 Like

I think that it has to do with launching it from a gnome shortcut. For some reason if I launch it from albert launcher or from the apps list even after login there is no problem. But if I launch first thing after login with CTRL+ALT+T it goes seg fault

After some testing the error occurs not only in tilix but even in other terminals if I launch them the first time using a gnome keyboard shortcut. I tried setting a shortcut for gnome-terminal and launching it after login and the segmentation fault occurs. I really can't think of a reason for this kind of behaviour

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.