Youtube-dl not working

It's the current version (v2021.12.17). Pacman -Dk is fine. Garuda-inxi further down.

youtube-dl --verbose "https://www.youtube.com/watch?v=K34AwhoQhb8"
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: ['--verbose', 'https://www.youtube.com/watch?v=K34AwhoQhb8']
[debug] Encodings: locale UTF-8, fs utf-8, out utf-8, pref UTF-8
[debug] youtube-dl version 2021.12.17
[debug] Python version 3.11.3 (CPython) - Linux-6.3.8-zen1-1-zen-x86_64-with-glibc2.37
[debug] exe versions: ffmpeg 6.0, ffprobe 6.0, rtmpdump 2.4
[debug] Proxy map: {}
[youtube] K34AwhoQhb8: Downloading webpage
ERROR: Unable to extract uploader id; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
Traceback (most recent call last):
File "/usr/lib/python3.11/site-packages/youtube_dl/YoutubeDL.py", line 815, in wrapper
return func(self, *args, **kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/youtube_dl/YoutubeDL.py", line 836, in __extract_info
ie_result = ie.extract(url)
^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/youtube_dl/extractor/common.py", line 534, in extract
ie_result = self._real_extract(url)
^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/youtube_dl/extractor/youtube.py", line 1794, in _real_extract
'uploader_id': self._search_regex(r'/(?:channel|user)/([^/?&#]+)', owner_profile_url, 'uploader id') if owner_profile_url else None,
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/youtube_dl/extractor/common.py", line 1012, in _search_regex
raise RegexNotFoundError('Unable to extract %s' % _name)
youtube_dl.utils.RegexNotFoundError: Unable to extract uploader id; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include itscomplete output.

Garuda-inxi:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_GB:en_US:en_GB",
LC_ALL = (unset),
LC_MONETARY = "en_DE.UTF-8",
LC_MEASUREMENT = "en_DE.UTF-8",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
System:
Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f98349e3-8520-4d18-968f-b7d3b3f4b259 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=f38c84c4-3b3e-4abc-afd9-6f44ced56afd loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0
serial: <filter> UEFI: American Megatrends LLC. v: A.A0 date: 05/26/2022
CPU:
Info: model: AMD Ryzen 5 5600G with Radeon Graphics socket: AM4 bits: 64
type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3900 min/max: 1400/4464 boost: enabled
base/boost: 3900/4450 scaling: driver: acpi-cpufreq governor: performance
volts: 1.4 V ext-clock: 100 MHz cores: 1: 3900 2: 3900 3: 3900 4: 3900
5: 3900 6: 3900 7: 3900 8: 3900 9: 3900 10: 3900 11: 3900 12: 3900
bogomips: 93428
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm
built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: HDMI-A-1 empty: DP-1,DP-2 bus-ID: 30:00.0
chip-ID: 1002:1638 class-ID: 0300 temp: 36.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Philips PHL 273V5
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.2 renderer: AMD Radeon Graphics (renoir LLVM
15.0.7 DRM 3.52 6.3.8-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 30:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.71 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 2a:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp42s0 state: down mac: <filter>
Device-3: Qualcomm Atheros AR9271 802.11n driver: ath9k_htc type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:3 chip-ID: 0cf3:9271
class-ID: ff00 serial: <filter>
IF: wlp48s0f3u1 state: up mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
bus-ID: 1-2.2.3:6 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 8.32 TiB used: 7.21 TiB (86.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B4QFXO7 temp: 37.9 C
scheme: GPT
SMART: yes health: PASSED on: 50 hrs cycles: 273
read-units: 15,756,349 [8.06 TB] written-units: 3,407,400 [1.74 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Kingchuxing model: 128GB
size: 119.24 GiB block-size: physical: 512 B logical: 512 B sata: 3.2
speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: A25E temp: 40 C
scheme: GPT
SMART: yes state: enabled health: PASSED on: 164d 23h cycles: 159
read: 24.4 MiB written: 38.3 MiB
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: Expansion Desk
size: 2.73 TiB block-size: physical: 4096 B logical: 4096 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 0737
SMART Message: A mandatory SMART command failed. Various possible causes.
ID-4: /dev/sdc maj-min: 8:32 model: MXT-USB Storage Device size: 7.5 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1501 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD50NDZW-11BCSS0 family: Elements / My Passport (USB, AF)
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 sata: 3.1 speed: 6.0 Gb/s
tech: HDD rpm: 4800 serial: <filter> fw-rev: 1034 drive-rev: 01.01A01
temp: 42 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 40d 3h cycles: 14
ID-6: /dev/sde maj-min: 8:64 vendor: Actions model: HS USB FlashDisk
size: 7.84 GiB block-size: physical: 1024 B logical: 1024 B type: USB
rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 104.05 GiB size: 104.05 GiB (100.00%)
used: 101.22 GiB (97.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 104.05 GiB size: 104.05 GiB (100.00%)
used: 101.22 GiB (97.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 104.05 GiB size: 104.05 GiB (100.00%)
used: 101.22 GiB (97.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 104.05 GiB size: 104.05 GiB (100.00%)
used: 101.22 GiB (97.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.54 GiB used: 666.3 MiB (4.8%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 14.9 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 43.1 C mobo: N/A gpu: amdgpu temp: 35.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 431 Uptime: 20h 40m wakeups: 2 Memory: available: 13.54 GiB
used: 6.6 GiB (48.8%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: guix-sys
pkgs: 0 pm: guix-usr pkgs: 0 pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0
pm: nix-usr pkgs: 0 pm: pacman pkgs: 2567 libs: 565 tools: octopi,paru,yay
pm: flatpak pkgs: 0 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2022-10-03
Last full system update: 2023-06-21 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:            nmb.service

python3 --version
Python 3.11.3

looks like there might be a fix in the 3rd post there.

2 Likes

There was an update today for yt-dlp.

Last full system update: 2023-06-21 ↻

Reboot and please search before posting help request for unsupported software.
Btw, work fine here.

2 Likes

Hi,

Try yt-dlp . It is in extra repository of Arch Linux. So, simply install with

sudo pacman -Syu yt-dlp

It is based on youtube-dl, but is much faster that youtube-dl, ever since youtube introduced some features that prevented high speed downloads by limiting the download on a particular session. So, download speed was actually very very limited on youtube-dl

But yt-dlp is much faster and much more alive in development now. It pretty much have replaced youtube-dl as per now.

3 Likes

Haaaaa, I only know yt-dlp.

Actually, yt-dlp is a fork of youtube-dl

There were a lot of legal issues over youtube-dl. Google sued youtube-dl over digital rights.

But Github supported Youtube-dl a lot. Idk why, but they did. So, the youtube-dl survived, but it was actually better to create an independent fork.

  1. yt-dlp didn't have to face any legal issues, because Google now knew that it was pointless suing it again for same reason.
  2. They could add more features like proxy downloading etc without any trouble.

My knowledge is primarily based on my memory, and it might be slightly wrong.

3 Likes

In this case here, I know that it didn't work before the last upgrade and same for the last reboot. yt-dlp actually works, so it's kinda resolved. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.