Youtube-dl doesn't work anymore

Youtube-dl worked before but it doesn't work anymore.
Anybody has any idea what could be wrong?

╭─mak at jmak-inspiron137378 in ⌁
╰─λ youtube-dl
fish: No matches for wildcard “”. See help expand.
╭─mak at jmak-inspiron137378 in ⌁

Is fish matching the ? as a wildcard so you need put the URL within quotation marks?


I jjust downloaded the one link using youtube-dl-gui-git without issue. I have bioth that and youtube-dl installed.

I don't remember exactly when. It was a while ago but it worked.

I don't know then what could be the problem. My system works properly. I reinstalled youtube-dl but it still doesn't work.

You seem to have ignored the second part of my reply:

That is, and to make it absolutely explicit, run this command:

youtube-dl ""

Ok. The quotation marks work. Thanks. Interesting, because I never had to do this before.

Different shells have different defaults. Bash does not use wildcards by default, so, for example:

$ bash -c 'echo 3?3'
$ zsh -c 'echo 3?3'
zsh:1: no matches found: 3?3

Thanks for the explanation.

1 Like

here is a news to yt-dl in german but easily translate it in english if needed

there are always other software in browser or extern to use equal effect

here my question what is preinstalled in the gamer editon there was a download manager or something called ..... but the name i don't no anymore

1 Like

I'm using zsh. Since I'm too lazy to always have to quote URLs, I put this in zshrc.

# URL autoquote
autoload -Uz bracketed-paste-magic
zle -N bracketed-paste bracketed-paste-magic

autoload -Uz url-quote-magic
zle -N self-insert url-quote-magic

It autoquotes URLs. Don't know whether it works in fish however. I'm posting it because someone may find it useful, if it indeed works in fish as it does in zsh.