Youtube Broken on Todays Update

Yes, it is normal that the pipewire process is still there. The new package replaced only pipewire-media-session.
I thought it was the same issue, so same solution... :pensive:

2 Likes

I think this could be repacked as a garuda feature, a privacy feature.

YT is a total waste of your time and not worth anyone's attention after 2021, its a platform for misinformation just like facebook and Windows, sorry for off topic, but truth is burning.

Request for YouTube to be disabled by default :smiley:

1 Like

Not so fast! Garuda's hotfix notification appeared for me this morning. I assume that was for the pipewire thing that my earlier rollbacks had undone. Clicking ok to install that hotfix broke YT again.

Running

systemctl --user stop pipewire.service pipewire.socket

made YT work again. I replaced wireplumber with pipewire-media-session per the other post's recommendation. I can't definitively say whether that solved the issue permanently, as I messed up the initial pipewire replacement and had to do another snapshot restore. If the Garuda hotfix breaks something again, I will whine about it further.

1 Like

The only difference I can see comparing your inxi with mine (YT and audio in general work fine here) is that you still have pulseaudio running. I replaced it (not now, long ago) with pipewire-pulse.
If you want to give it a try, install pipewire-pulse, which will ask to replace pulseaudio, then reinstall wireplumber (which will replace pipewire-media-session of course) and check if YouTube and your audio in general work. If not, just a new restore...

1 Like

On a serious note, we can't do that. I also agree that youtube is just a money factory for Google, but many people like it and we can't control it. A lot of times, you have to depend on youtube, for various basic things, from latest music videos, to latest launch events and so on. And there are not much widely used alternatives. Odyssey is not much used, at least in India. So, we have to solve the bug.
:man_shrugging:

6 Likes

Without YT I could not do what I can (I think I can) :smiley:

Ok, you can not learn taste but without the right technique taste also brings nothing :wink:

I would like to mention here the tutorials of "Logos By Nick" (Saporito).

Have a look @TilliDie :smiley:

6 Likes

I thank @SGS You are so kind and humbled!
I too without YT or the internet I would never have been able to expand my Knowledge to the level I have tried to aspire too without it :smiley:
One thing i have learnt on Garuda forum is if you want to learn you will teach :+1:
Sorry if that sounds corny :face_with_hand_over_mouth:

6 Likes

A friend of mine had the same issue. Installing pipewire-support fixed it for him.

2 Likes

I can confirm that this fixed the issue also for me! :100:

1 Like

So I tried sudo pacman -Rdd pipewire-media-session but get the target not found error. I am keeping Garuda up to date by checking for updates every time I boot up but need to run systemctl --user stop pipewire.service pipewire.socket if I want to play something on you YT. What did you guys do to fix it permanently?
Thanks for your help!

Try systemctl --user disable pipewire.service pipewire.socket

2 Likes

Made a quick cmd that should fix any audio issues people are still having from the originally broken hotfix.

update remote 2021-10-audio

Let me know if that works!

1 Like

Hi @TNE, thanks for taking the time but unfortunately it did not fix the issue. The cmd went through everything without a glitch but ended with the message "Pipewire-support is not installed! Not applying any fixes".

inxi -A reports this:

Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
Device-3: Kingston HyperX 7.1 Audio type: USB driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.39 running: yes

YT still is acting up and once I systemctl --user stop pipewire.service pipewire.socket videos start playing.

I will try systemctl --user disable pipewire.service pipewire.socket and see whether that fixes it (assuming it will disable pipewire for good).

Tried to disable pipewire.service and .socket as suggested by @cooter but to no avail. YT still doesn't play any video unless I use systemctl --user stop pipewire.service pipewire.socket. What am I missing or doing wrong?

You don't have pipewire-support installed, did you manually install pipewire??
You should fully install pipewire-support via sudo pacman -S pipewire-support and then subsequently run update remote 2021-10-audio

4 Likes

No, I did not manually install pipewire (I have absolutely no idea what it does although I am guessing it has to do with audio :wink: ).
Just going through the install of pipewire-support: it is in conflict with all things pulseaudio. pulseaudio has been replaced by pipewire now.
As long as my audio works I don't care whether it is pulseaudio or pipewire. Will let youy know how it went.
Thanks for taking the time and your support, @TNE! Much appreciated!

1 Like

Ok, that did it! Thanks, @TNE , for providing the fix and instructions.

1 Like

This worked for me. The issue i ran into was that I need pulse and jack. Pipewire is not staying out of the way. But it seems to be a temporary fix. After reboot the issue persists. Pulse and pipewire are in total conflict.

╰─λ systemctl --user stop pipewire.service pipewire.socket

1 Like

I was plagued by this issue, tried all the suggestions above, but nothing worked. BTW, from what I have read the developers changed some config files but neglected to provide a converter for the existing configurations. Lots of people in this mess posting in reddit.

Right, so, anyway, here is what worked for me, finally;

  1. Remove all the configuration files in /etc/pipewire (sudo mv /etc/pipewire /tmp)
  2. Reinstall pipewire, pipewire-pulse, and pipewire-media-session (sudo pacman -S pipewire pipewire-pulse pipewire-media-session)
  3. Enable and start the relevant services (systemctl --user enable pipewire pipewire-pulse pipewire-media-session) and (systemctl --user restart pipewire pipewire-pulse pipewire-media-session). After that, my devices appeared as usual and I was back in business.
5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.