Yet another infinite pacman sync (help I want to go to bed)

Hey there,
I've just been trying to update my system, but pacman seems to sync all filesystems indefinitely.
There are no dmesg errors indicating issues, but in the console I can see a lot of anannicy infos:

Apr 29 23:54:15 lolcat ananicy-cpp[580]: [2022-04-29 23:54:15.272] [info] mkdir(777343)
Apr 29 23:54:15 lolcat ananicy-cpp[580]: [2022-04-29 23:54:15.539] [info] pacman(777366)
Apr 29 23:54:15 lolcat ananicy-cpp[580]: [2022-04-29 23:54:15.680] [info] pacman(777367)
Apr 29 23:54:15 lolcat ananicy-cpp[580]: [2022-04-29 23:54:15.940] [info] rm(777369)
Apr 29 23:54:16 lolcat ananicy-cpp[580]: [2022-04-29 23:54:16.192] [info] wc(777373)
Apr 29 23:54:16 lolcat ananicy-cpp[580]: [2022-04-29 23:54:16.198] [info] mkdir(777375)
Apr 29 23:54:16 lolcat ananicy-cpp[580]: [2022-04-29 23:54:16.208] [info] pacman(777392)
Apr 29 23:54:16 lolcat ananicy-cpp[580]: [2022-04-29 23:54:16.874] [info] rm(777401)
Apr 29 23:54:21 lolcat ananicy-cpp[580]: [2022-04-29 23:54:21.578] [info] wc(777406)
Apr 29 23:54:21 lolcat ananicy-cpp[580]: [2022-04-29 23:54:21.594] [info] wc(777416)

This has been scrolling through journalctl for about 20 minutes now, and this is definitely not supposed to be happening. Is it a bad idea to kill pacman? I really want to shut off my pc for the night and thus I don't have a lot time.

While writing this I just got crash info in journalctl:

Apr 29 23:55:44 lolcat kernel: INFO: task sync:775829 blocked for more than 122 seconds.
Apr 29 23:55:44 lolcat kernel:       Tainted: G        W         5.17.5-zen1-1-zen #1
Apr 29 23:55:44 lolcat kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Apr 29 23:55:44 lolcat kernel: task:sync            state:D stack:    0 pid:775829 ppid:     1 flags:0x00004006
Apr 29 23:55:44 lolcat kernel: Call Trace:
Apr 29 23:55:44 lolcat kernel:  <TASK>
Apr 29 23:55:44 lolcat kernel:  ? __x64_sys_tee+0xd0/0xd0
Apr 29 23:55:44 lolcat kernel:  __schedule+0xaed/0x1360
Apr 29 23:55:44 lolcat kernel:  ? __x64_sys_tee+0xd0/0xd0
Apr 29 23:55:44 lolcat kernel:  schedule+0x4b/0xc0
Apr 29 23:55:44 lolcat kernel:  sync_inodes_sb+0x304/0x350
Apr 29 23:55:44 lolcat kernel:  ? finish_wait+0x80/0x80
Apr 29 23:55:44 lolcat kernel:  ? __x64_sys_tee+0xd0/0xd0
Apr 29 23:55:44 lolcat kernel:  iterate_supers+0x87/0xf0
Apr 29 23:55:44 lolcat kernel:  __do_sys_sync+0x40/0xa0
Apr 29 23:55:44 lolcat kernel:  do_syscall_64+0x5c/0x80
Apr 29 23:55:44 lolcat kernel:  ? exc_page_fault+0x72/0x170
Apr 29 23:55:44 lolcat kernel:  entry_SYSCALL_64_after_hwframe+0x44/0xae
Apr 29 23:55:44 lolcat kernel: RIP: 0033:0x7f61dbef129b
Apr 29 23:55:44 lolcat kernel: RSP: 002b:00007ffe49bdb728 EFLAGS: 00000246 ORIG_RAX: 00000000000000a2
Apr 29 23:55:44 lolcat kernel: RAX: ffffffffffffffda RBX: 00007ffe49bdb908 RCX: 00007f61dbef129b
Apr 29 23:55:44 lolcat kernel: RDX: 00007f61dbff2c01 RSI: 00007ffe49bdb908 RDI: 00007f61dbfafdf8
Apr 29 23:55:44 lolcat kernel: RBP: 0000000000000001 R08: 0000000000000001 R09: 0000000000000000
Apr 29 23:55:44 lolcat kernel: R10: 0000559d8797b3b0 R11: 0000000000000246 R12: 0000559d860c3bc0
Apr 29 23:55:44 lolcat kernel: R13: 0000559d860c119e R14: 00007f61dbfea24c R15: 0000559d860c1034
Apr 29 23:55:44 lolcat kernel:  </TASK>

How do I stop this process?
Thanks!

Inxi:

System:
  Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6e6211b4-cfb4-44c0-8970-5e4a826e0c5e rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1
    iommu=soft
  Desktop: Unity info: waybar wm: wayfire v: 0.8.0-9458f589 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 2968 high: 4158 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 2782 2: 2385
    3: 3752 4: 3511 5: 4158 6: 2386 7: 2388 8: 3385 9: 2936 10: 3115 11: 2413
    12: 2409 bogomips: 86224
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X] vendor: ASUSTeK
    driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
    active: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 08:00.0 chip-ID: 1002:67ff
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: wayfire v: 0.8.0-9458f589 driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu d-rect: 3600x1200
    display-ID: 1
  Monitor-1: DVI-D-1 pos: right res: 1920x1200 size: N/A modes: N/A
  Monitor-2: HDMI-A-1 pos: primary,left res: 1680x1050 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 560 Series (polaris11 LLVM 13.0.1 DRM
    3.44 5.17.5-zen1-1-zen)
    v: 4.6 Mesa 22.0.2 direct render: Yes
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 8 bus-ID: 08:00.1 chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Device-4: C-Media USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:4 chip-ID: 0d8c:9700
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 1-3:4 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 1.13 TiB (38.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A82 scheme: GPT
Partition:
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 124.77 GiB (64.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 171.18 GiB (23.3%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 124.77 GiB (64.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 124.77 GiB (64.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.3 GiB used: 4 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1457
Info:
  Processes: 364 Uptime: 1h 21m wakeups: 0 Memory: 31.3 GiB
  used: 4.35 GiB (13.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 2038 apt: 0 pacman: 2020 lib: 495
  flatpak: 18 Shell: Zsh v: 5.8.1 running-in: alacritty inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2021-12-28
  Last full system update: 2022-04-29 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

I might end up killing pacman, and restoring a backup, but that always wipes login cookies in brave when I'm on wayfire for some reason

EDIT: I did not manage to kill pacman for some reason, but I was able to just poweroff my machine. I expected it to interrupt the shutdown process as you can't ctrl+c it, but apparently I am wrong.
I just btrfs-checked my root drive and it seems fine, so I assume that it's working well. If any packages are broken I might notice that, but until then, I will not restore a backup

With the amount of time you waited, you shouldn't be facing any issues with broken packages. All those changes were probably already written to disk. I wonder what caused the issue though!

All the ananicy info makes me believe that it's envolved with this, I might try to disable it and sync afterwards

EDIT: I am unsure, but it might actually be related to ananicy. I stopped it and now the sync seems faster. Next time I update my system I'm gonna try it without ananicy. This program, while increasing performance seems to cause quite some issues - first the wayland issue and now this.

I am pretty sure this is related to ananicy-cpp. I have disabled the service since I had these problems and the syncs appear to be faster. There are some ~1 min syncs with bigger packages, but no more infinite ones.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.