Xwayland not working correctly?

Hi,
When logging in via sddm (or lightdm) into a Plasma (Wayland) session, X doesn't work correctly. When trying to start xeyes from the console I get these Errors:

Invalid MIT-MAGIC-COOKIE-1 keyError: cannot open display ''

when I look into htop, XWayland is there.
Interestingly, when I go to another tty, log in there, and start a new plasma-wayland session like this:

dbus-run-session startplasma-wayland

it works perfectly fine (although I have to unlock kwallet manually)

reinstalling sddm, plymouth or plasma-wayland-session doesn't fix it. installing git versions of these programs also doesn't.

garuda-inxi: (I ran this in a session I started manually from tty3 as described above)

╭─[email protected] in ~ via  v3.10.6 took 2m57s
╰─λ garuda-inxi
System:
Kernel: 5.19.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ed7d29e6-cb8d-43b9-8031-6acbb474bc2d rw rootflags=sub[email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
amdgpu.ppfeaturemask=0xffffffff acpi_mask_gpe=0x09
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_wayland vt: 3 dm: LightDM v: 1.32.0 Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: Z690 GAMING X DDR4 v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F6
date: 12/17/2021
CPU:
Info: model: 12th Gen Intel Core i5-12600K bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 built: 2021 process: Intel 7 (10nm ESF)
family: 6 model-id: 0x97 (151) stepping: 2 microcode: 0x22
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 4306 high: 4800 min/max: 800/4800:3600 scaling:
driver: intel_pstate governor: performance cores: 1: 4800 2: 3700 3: 4800
4: 3700 5: 4800 6: 4800 7: 4800 8: 3700 9: 4708 10: 4800 11: 4800
12: 4800 13: 3601 14: 3700 15: 3700 16: 3700 bogomips: 117964
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel AlderLake-S GT1 vendor: Gigabyte driver: i915 v: kernel
ports: active: none empty: DP-4,HDMI-A-2,HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:4680 class-ID: 0380
Device-2: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,DP-2,HDMI-A-1 empty: DP-3 bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_wayland driver: X: loaded: amdgpu gpu: i915,amdgpu
d-rect: 5760x1080 display-ID: 0
Monitor-1: DP-1 pos: right res: 1920x1080 size: N/A modes: N/A
Monitor-2: DP-2 pos: primary,left res: 1920x1080 size: N/A modes: N/A
Monitor-3: HDMI-A-1 pos: center res: 1920x1080 size: N/A modes: N/A
OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 14.0.6 DRM
3.47 5.19.1-zen1-1-zen) v: 4.6 Mesa 22.1.6 direct render: Yes
Audio:
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte
driver: snd_hda_intel bus-ID: 1-6:3 v: kernel
alternate: snd_sof_pci_intel_tgl chip-ID: 0dba:3000 bus-ID: 00:1f.3
class-ID: 0102 chip-ID: 8086:7ad0 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-3: Digidesign Mbox 2 type: USB driver: snd-usb-audio
Sound Server-1: ALSA v: k5.19.1-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 16.1 running: no
Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Drives:
Local Storage: total: 7.06 TiB used: 2.59 TiB (36.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A7C0
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD60EZAZ-00SF3B0 size: 5.46 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: MZ7LN256HMJP-000H1
size: 238.47 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1H3Q scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 860 QVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
ID-1: / raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 179.51 GiB
(93.9%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 576 KiB
(0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 848.99
GiB (91.1%) fs: btrfs dev: /dev/sdd1 maj-min: 8:49
ID-4: /var/log raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 179.51
GiB (93.9%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 179.51
GiB (93.9%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.06 GiB used: 3.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 46.87 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdc3 maj-min: 8:35
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
mem: 48.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 492 Uptime: 54m wakeups: 0 Memory: 31.06 GiB used: 7.36 GiB
(23.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 alt: 10 clang: 14.0.6 Packages: 2459 pacman: 2454
lib: 572 flatpak: 5 Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2021-07-26
Last full system update: 2022-08-22 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Timeshift
Failed units:            fancontrol.service systemd-networkd-wait-online.service

Xeyes is not wayland compatable.

1 Like

It isn't but if you run xeyes on Wayland you should see xeyes which can detect mouse if you hover on an xwayland application, including xeyes.

Update:
seems to be working again!
(at least I just started up my pc, noticed that in lightdm no Plasma Wayland session was available (probably from experimenting yesterday), so I switched to tty3, installed plasma-wayland-session from the extra repo, and restarted lightdm. There, I selected a Plasma (Wayland) session, typed in my password and suddenly I can start steam again and everything seems to be working (for now))

nevermind, tried to login today and it's not working....