XRDP launch problems "Unable to contact to settings server"

I will just start off with inxi before I do anything…

╭─fenris@fenris in ~ took 25ms
 ╰─λ sudo garuda-inxi
[sudo] password for fenris:         
  Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=cd6e149b-2970-476f-b742-e3dc1120bedc rw rootflags=subvol=@
    quiet rd.luks.uuid=264cadad-c8c3-46fe-b132-32f30ff8b69c
    resume=/dev/mapper/luks-0dd705d1-74f7-4ae7-8f55-96ae57f524b8 loglevel=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver avail: xautolock dm: LightDM
    v: 1.32.0 Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: AZW model: MINI S v: 10 serial: N/A part-nu: 01
    uuid: 03000200-0400-0500-0006-000700080009 UEFI: American Megatrends LLC.
    v: ADLNV104 date: 02/06/2023
  Info: model: Intel N100 socket: U3E1 bits: 64 type: MCP arch: Alder Lake
    level: v3 note: check built: 2021+ process: Intel 7 (10nm ESF) family: 6
    model-id: 0xBE (190) stepping: 0 microcode: 0x15
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 1x2 MiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 700 min/max: 700/3400 base/boost: 2871/3400 scaling:
    driver: intel_pstate governor: powersave volts: 1.0 V ext-clock: 100 MHz
    cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 6451
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Alder Lake-N [UHD Graphics] driver: i915 v: kernel
    alternate: xe arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: HDMI-A-1 empty: HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:46d1
    class-ID: 0300
  Device-2: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4.4:8
    chip-ID: 041e:40a0 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer G247HYL serial: <filter>
    built: 2016 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu
    name: Intel Graphics (ADL-N) driver: mesa intel v: 24.0.5-arch1.1
    device-ID: 8086:46d1 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.5-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Alder Lake-N PCH High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:54c8 class-ID: 0403
  Device-2: C-Media CM106 Like Sound Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-4.3:6 chip-ID: 0d8c:0102 class-ID: 0300
  Device-3: Creative Live! Cam Sync 1080p V2 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4.4:8
    chip-ID: 041e:40a0 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.5 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel CNVi: Wi-Fi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:54f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet driver: ax88179_178a type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-4.1:4
    chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp0s20f0u4u1 state: down mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
  Local Storage: total: 2.73 TiB used: 1.07 TiB (39.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 4B2QJXD7 temp: 55.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM015-2E8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-1: / raw-size: 914.27 GiB size: 914.27 GiB (100.00%)
    used: 27.1 GiB (3.0%) fs: btrfs block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-264cadad-c8c3-46fe-b132-32f30ff8b69c
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 728 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 914.27 GiB size: 914.27 GiB (100.00%)
    used: 27.1 GiB (3.0%) fs: btrfs block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-264cadad-c8c3-46fe-b132-32f30ff8b69c
  ID-4: /var/log raw-size: 914.27 GiB size: 914.27 GiB (100.00%)
    used: 27.1 GiB (3.0%) fs: btrfs block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-264cadad-c8c3-46fe-b132-32f30ff8b69c
  ID-5: /var/tmp raw-size: 914.27 GiB size: 914.27 GiB (100.00%)
    used: 27.1 GiB (3.0%) fs: btrfs block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-264cadad-c8c3-46fe-b132-32f30ff8b69c
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 16.94 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-0dd705d1-74f7-4ae7-8f55-96ae57f524b8
  ID-2: swap-2 type: zram size: 15.4 GiB used: 2.57 GiB (16.7%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
    dev: /dev/zram0
  System Temperatures: cpu: 59.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.4 GiB used: 7.98 GiB (51.8%)
    igpu: 60 MiB
  Processes: 357 Power: uptime: 1d 17h 50m states: freeze,mem,disk
    suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
    reboot, suspend, test_resume image: 6.14 GiB
    services: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1759 libs: 469 tools: pamac,paru Compilers:
    clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi (sudo) default: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-04-11
  Last full system update: 2024-04-22 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            vmware-workstation-server.service vmware.service 

 ╭─fenris@fenris in ~ as 🧙 took 6s

First of all, I installed XRDP it looked like it was working till I connected. Got the login screen but it wasn’t accepting my root username/password. It had a wierd screen on it with a windows blue background telling me it couldn’t accept the username and password.

So I went here to follow these instructions: How to enable remote desktop

Also by doing xfce4-session I get the following and do not know if this is adding to the problem, nor how to fix

 ╭─fenris@fenris in /mnt/veracrypt1/Videos as 🧙 took 446ms
 ╰─λ xfce4-session

(xfce4-session:1270493): xfce4-session-WARNING **: 15:41:44.596: Another session manager is already running

 ╭─fenris@fenris in /mnt/veracrypt1/Videos as 🧙 took 93ms
[🔴] × 

So I login again from my windows pc, and I get this screen https://user-images.githubusercontent.com/3178490/106655305-144a2980-6591-11eb-9d8f-6344dc2b3c35.png

So I tried to follow this "Unable to contact settings server" when lauching XFCE remote desktop session on CentOS8 · Issue #872 · OSC/ondemand · GitHub which is what I see on the screen

I also looked at this entry [SOLVED] Unable to Contact Settings Server / Applications & Desktop Environments / Arch Linux Forums but it doesn’t seem to be working out for me

Just for the record physically connecting over the network to the Garuda PC isn’t the problem, that works just fine as you can see here:

 ╭─fenris@fenris in /mnt/veracrypt1/Videos as 🧙 took 109ms
 ╰─λ sudo systemctl status xrdp
● xrdp.service - xrdp daemon
     Loaded: loaded (/usr/lib/systemd/system/xrdp.service; enabled; preset: dis>
     Active: active (running) since Mon 2024-04-22 14:13:59 CDT; 17s ago
       Docs: man:xrdp(8)
   Main PID: 1261456 (xrdp)
      Tasks: 1 (limit: 18869)
     Memory: 1.7M (peak: 1.9M)
        CPU: 25ms
     CGroup: /system.slice/xrdp.service
             └─1261456 /usr/bin/xrdp --nodaemon

Apr 22 14:13:59 fenris-minispro12 systemd[1]: Starting xrdp daemon...
Apr 22 14:13:59 fenris-minispro12 (xrdp)[1261456]: xrdp.service: Referenced but>
Apr 22 14:13:59 fenris-minispro12 systemd[1]: Started xrdp daemon.
Apr 22 14:13:59 fenris-minispro12 xrdp[1261456]: [INFO ] starting xrdp with pid>
Apr 22 14:13:59 fenris-minispro12 xrdp[1261456]: [INFO ] address [] port>
Apr 22 14:13:59 fenris-minispro12 xrdp[1261456]: [INFO ] listening to port 3389>
Apr 22 14:13:59 fenris-minispro12 xrdp[1261456]: [INFO ] xrdp_listen_pp done

I also don’t have UFW installed so there is no ports being blocked. Its like XFCE isn’t accepting the session login for what ever reason and I ran out of things to try and fix this issue

Also, I don’t know how to categorise this topic cause I can’t tell if this is a Garuda issue in general or an XFCE4 problem

Did you reboot (↻) after install XRDP?


This is an old problem, it has been like this for a long time, and there is nothing I can do about it nor has anyone on this forum been successfully able to help me fix it

Yes I rebooted, and I still have the same problem

I still have this problem after reboot

I initially had the XRDP login screen, but then I messed it up and broke it and that happened. Now, I don’t know how to fix it. I do not know how to undo my mistakes

So following this guide:

What I didn’t do was

sudo useradd rdpuser
sudo passwd rdpuser

Which, I probably should have cause I wanted to use fenris as my login (which is my admin account)

I went right to

echo "xfce4-session" > .xsession

Thats when I noticed XRDP and Garuda go hay wire, and I don’t know how to undo my screw ups. I had an XRDP login window with a nice blue background, then after doing this, it stopped working.

1 Like

Super frustrating. Sadly I don’t now anything about xrdp. Maybe you could try something like ‘remmina’. I’ve used that in the past its pretty simple and might do what you need.

Thank you for your reply. I have waited a long time for someone to look deeper into the post. Remmina sounds nice, however I’m trying to access Garuda from remote over a local area network, not the other way around. AnyDesk and Rust do the job, but it eats up my bandwidth to do that. RealVNC is the only thing I have found that works but I have to pay for that feature. I also tried TigerVNC but again, I have had no success.

To make things more clear, I’m trying to remote into Garuda from Windows on a LAN

1 Like

From your link:
On Linux, you can use FreeRDP, or Remmina.
IDK if XRDP is the same like FreeRDP.

Thread moved from Issues & Assistance to Unsupported Software (AUR & Other)

1 Like

Ok then how do you get this to work with FreeRDP on Garuda instead of Ubuntu as a server?

I just thought of something. Could I call upon BTRFS to completely roll back the installation of XRDP? If so, if I were to roll that back, would it also flush out all the configuration files I tweaked before it all went sour?

I’m not sure, but does BTRFS work like VMware Workstation when you take a snapshot so you can reset everything completely the way it was before you made chances?

Yes, you can restore the pre-installation snapshot and essentially “roll back”.

It depends on where the config files are located. The default Snapper config does not take snapshots of the home subvolume, you would have to set that up on your own. If they are in /etc or something, then yes.

On a very basic level: yes, you have the right idea with this concept.

1 Like

I don’t know where the .xsession is stored to be honest

Now let me ask you an obvious question…how do I do this? I would need to roll back sometime in the morning of 22-Apr-2024, 21-Apr-2024 would get it for sure

There are probably 100 ways to restore a Btrfs snapshot. One of the easiest (in my opinion) is to use Btrfs Assistant. It takes care of a lot of dirty details for you, and makes the whole process extremely simple.

In Btrfs-Assistant, open the Snapper tab and click “Browse/Restore”. Make sure you are interacting with the target you want (it will be called “root”–it is most likely the only one you have in there).

Find the snapshot you want to restore by referencing the timestamp or snapshot description. The Pacman snapshots are labeled pre- and post- for each transaction (you can read that as “before I installed package foo” or “after I updated the system”). In your case you may be looking for something like “pre pacman -S xrdp”, if you installed it with Pacman.

Click the Restore button, optionally give the backup of the current state a unique name (it saves it in case you want to revert), and then reboot.

It is in your home directory. It looks like you have chosen to completely overwrite the file during this step:

In that case, you may as well just delete it and allow a fresh one to be populated the next time you sign in.

rm ~/.xsession

If you wish, instead of deleting it you can move it to a backup. This will have the same effect as deleting it but will preserve the state of the file in case you wish to refer to it in the future.

mv ~/.xsession ~/.xsession_backup

In this case it is unlikely you will ever want a backup of this file, but moving files to a backup state instead of just deleting them is a good habit to get into because it creates the opportunity to restore the file if something goes wrong.

1 Like

I have some bad news, it doesn’t look like that image is left on file, only 10 snap shots were taken and a week later all those commands are not listed anymore :cry:

I followed your suggestion, I even did a sudo systemctl restart xrdp xrdp.service and it didn’t fix the problem so it must be something else that I can’t seem to find

I’m sure you could just uninstall it normally, no need to use a snapshot.

That suggestion was related to undoing the changes made to ~/.xsession, since you had asked how to revert back to the state your system was in before you set it up. It now sounds like you are now trying to get it working again instead, so I’m not sure this would be a relevant suggestion.

Ok you were right stripping it all out and reinstalling it got me to where I started. So, thank you for that.

So I get this screen, when I re-installed XRDP, so far so good…

Now here are my problems…

This is what I get, when I try to connect to my root account

This is what I get when I try to not use a password to login to my root account

So I made an account to login with so I don’t use my root account, rdpfenris, this is what I get

If I attempt to use the neutrino option, I get

And just for fun, I tried doing a on a vnc-any option, I knew it would fail but I just wanted to show what it looks like

So, hopefully someone knows something at this point…So close, yet so far away

Perhaps you never noticed that another thread was created yesterday on the forum regarding xrdp and trying to get it to work properly.

While the problem is not identical to yours, it is similar enough to make me think the timing is a little more than coincidental.

Have you considered that this may be a problem with the xdrp program itself? Perhaps you need to do some in-depth searching to see if others are having this same issue with xrdp, and if a workaround/fix has been found.

Sorry I can’t be more helpful, but if the problem is not with Garuda or Xfce, then you are simply wasting your time working under the assumption that it is. The other Garuda user that reported a problem starting xrdp is a KDE user, so this would seem to indicate that the desktop in use isn’t the cause.

Good luck with your issue, but perhaps testing other remote access software is your best bet. Sorry, I can’t be much help recommending alternatives there either, as I’ve always considered remote access to be a security risk and never allow it on any computer I own.

1 Like

Ya, that is strange isn’t it? Ironically, I was just thinking and wishing there would be some other assistance for me perhaps someone else knew how to fix this

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.