XCOM 2 on Steam crashes at launch, missing shared libraries?

Hello.
I have recently bought XCOM 2 on Steam. I am trying to launch it on my dual-booted KDE Dr460nized edition. The game should run natively, but it closes as soon as I launch it.
By running Steam from the console, I was able to find that the game closes itself because it couldn't find some shared libraries, such as "liblber-2.4.so.2". I'm not too sure what that means or how to fix it.

So far, I've tried to:

  • verify the game files.
  • update the system through update
  • run the game with "LD_LIBRARY_PATH=./lib/x86_64/:../lib/x86_64/ %command% -allowconsole" as my launch options.
  • run the game with "LD_LIBRARY_PATH=/home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/lib/x86_64/ %command% -allowconsole" as launch options

openssl - XCOM2 on Fedora: Can't find libcrypto.so.1.0.0 - Unix & Linux Stack Exchange this post on stackexchange was the closest one I could find to my issue. I have included below the output of ldd ./XCOM2. I didn't understand the proposed solution too well, so I didn't follow it.

I didn't bother trying to run the game on proton, because it would mean downloading 11Gb of additional content and I figured that there must be a more efficient way.

.
Steam's console output when launching the game:

GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to ShowLaunchOption with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp waiting for user response to ShowLaunchOption ""
GameAction [AppID 268500, ActionID 4] : LaunchApp continues with user response "0"
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to ProcessingInstallScript with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to SynchronizingCloud with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to SynchronizingControllerConfig with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to CreatingProcess with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp waiting for user response to CreatingProcess ""
GameAction [AppID 268500, ActionID 4] : LaunchApp continues with user response "CreatingProcess"
/bin/sh\0-c\0/home/anonyme/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=268500 -- '/home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/XCOM2.sh'\0
Game process added : AppID 268500 "/home/anonyme/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=268500 -- '/home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/XCOM2.sh'", Pro
cID 10341, IP 0.0.0.0:0
chdir /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to WaitingGameWindow with ""
GameAction [AppID 268500, ActionID 4] : LaunchApp changed task to Completed with ""
ERROR: ld.so: object '/home/anonyme/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/anonyme/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/home/anonyme/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
pid 10344 != 10343, skipping destruction (fork without exec?)
ERROR: ld.so: object '/home/anonyme/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/anonyme/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
/home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/XCOM2: error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory
Game process removed: AppID 268500 "/home/anonyme/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=268500 -- '/home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/XCOM2.sh'", Pr
ocID 10341
ThreadGetProcessExitCode: no such process 10345
ThreadGetProcessExitCode: no such process 10343
Uploaded AppInterfaceStats to Steam

.
ldd /home/anonyme/.local/share/Steam/steamapps/common/XCOM\ 2/bin/XCOM2

linux-vdso.so.1 (0x00007fff8758b000)
libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007f90a5a27000)
libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007f90a59f9000)
libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0x00007f90a59ee000)
libCoreFoundation.so.476 => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64
/libCoreFoundation.so.476 (0x00007f90a5600000)
libcurl.so.4 => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64/libcurl.so.
4 (0x00007f90a5200000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f90a59e7000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007f90a59e2000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f90a59dd000)
libSDL2-2.0.so.0 => /usr/lib/libSDL2-2.0.so.0 (0x00007f90a503b000)
libSDL2_image-2.0.so.0 => /usr/lib/libSDL2_image-2.0.so.0 (0x00007f90a59bd000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f90a59a3000)
libcef.so => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64/libcef.so (0x0
0007f90a107c000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f90a552f000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f90a54df000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f90a0e45000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f90a0d5d000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f90a54bf000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f90a0b76000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f90a5cd4000)
libogg.so.0 => /usr/lib/libogg.so.0 (0x00007f90a54b2000)
libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f90a54a9000)
libicui18n.so.51 => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64/libicui
18n.so.51 (0x00007f90a0600000)
libicuuc.so.51 => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64/libicuuc.
so.51 (0x00007f90a0200000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007f90a5472000)
librtmp.so.0 => /usr/lib/librtmp.so.0 (0x00007f90a0b5a000)
libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f90a0aec000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f90a0a97000)
liblber-2.4.so.2 => not found
libldap_r-2.4.so.2 => not found
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f90a0a5e000)
libjxl.so.0.6 => /usr/lib/libjxl.so.0.6 (0x00007f909fe0a000)
libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007f909fd87000)
libtiff.so.5 => /usr/lib/libtiff.so.5 (0x00007f909fcf2000)
libwebp.so.7 => /usr/lib/libwebp.so.7 (0x00007f909fc81000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007f90a05a1000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f909fb46000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00007f90a0a4e000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00007f909fa22000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00007f909f9ba000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f909f877000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f90a0a3a000)
libnss3.so => /usr/lib/libnss3.so (0x00007f909f742000)
libnssutil3.so => /usr/lib/libnssutil3.so (0x00007f909f710000)
libsmime3.so => /usr/lib/libsmime3.so (0x00007f909f6e8000)
libplc4.so => /usr/lib/libplc4.so (0x00007f90a0a33000)
libnspr4.so => /usr/lib/libnspr4.so (0x00007f909f6a7000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007f90a0a2c000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f90a0a17000)
libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f909f5b8000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f90a059c000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f90a0593000)
libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007f909f5af000)
libgconf-2.so.4 => not found
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f909f5a3000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f909f596000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f909f589000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f909f558000)
libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f909f505000)
libcups.so.2 => /usr/lib/libcups.so.2 (0x00007f909f465000)
libcap.so.2 => /usr/lib/libcap.so.2 (0x00007f909f459000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f909f446000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f909f35b000)
libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1 (0x00007f909f34d000)
libicudata.so.51 => /home/anonyme/.local/share/Steam/steamapps/common/XCOM 2/bin/../lib/x86_64/libicud
ata.so.51 (0x00007f909dc00000)
libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0x00007f909da00000)
libhogweed.so.6 => /usr/lib/libhogweed.so.6 (0x00007f909d9b7000)
libnettle.so.8 => /usr/lib/libnettle.so.8 (0x00007f909d963000)
libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007f909d8c0000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f909d7e5000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f909d7b5000)
libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f909d7af000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f909d7a0000)
libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f909d799000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f909d787000)
libbrotlienc.so.1 => /usr/lib/libbrotlienc.so.1 (0x00007f909d6e2000)
libzstd.so.1 => /usr/lib/libzstd.so.1 (0x00007f909d637000)
liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f909d60d000)
libffi.so.8 => /usr/lib/libffi.so.8 (0x00007f909d601000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f909d587000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00007f909d56f000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f909d542000)
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00007f909d532000)
libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x00007f909d52d000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f909d480000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f909d2b5000)
libfribidi.so.0 => /usr/lib/libfribidi.so.0 (0x00007f909d295000)
libthai.so.0 => /usr/lib/libthai.so.0 (0x00007f909d288000)
libplds4.so => /usr/lib/libplds4.so (0x00007f909d283000)
libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f909d1a6000)
libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0x00007f909d198000)
libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0x00007f909d184000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f909d160000)
libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1 (0x00007f909d13d000)
libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0x00007f909d00a000)
libidn2.so.0 => /usr/lib/libidn2.so.0 (0x00007f909cfe8000)
libunistring.so.2 => /usr/lib/libunistring.so.2 (0x00007f909ce3c000)
libtasn1.so.6 => /usr/lib/libtasn1.so.6 (0x00007f909ce25000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f909ce1e000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f909ce16000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007f909ce0f000)
libmount.so.1 => /usr/lib/libmount.so.1 (0x00007f909cdcb000)
libdatrie.so.1 => /usr/lib/libdatrie.so.1 (0x00007f909cdbf000)
libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f909cc76000)
liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f909cc54000)
libblkid.so.1 => /usr/lib/libblkid.so.1 (0x00007f909cc1b000)
libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f909cbf5000)

there are a bunch of .so.X files which are "not found".
liblber-2.4.so.2 (this is the one which appears in the output when I launch the game)
libldap_r-2.4.so.2
libgconf-2.so.4
I'm guessing that I am supposed to install these? The issue is that I don't know how, or if I should even mess with them.

garuda-inxi

System:
Kernel: 5.19.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c5ea7d35-48e9-4936-abf3-cc1ba8dcc8cf rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506LH_TUF566LH
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX506LH v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: FX506LH.310 date: 11/26/2021
Battery:
ID-1: BAT1 charge: 9.5 Wh (22.7%) condition: 41.8/48.1 Wh (87.0%)
volts: 10.0 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
status: discharging
CPU:
Info: model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2298 high: 2608 min/max: 800/4500 scaling:
driver: intel_pstate governor: performance cores: 1: 2300 2: 2608 3: 2587
4: 2354 5: 1085 6: 2308 7: 2585 8: 2557 bogomips: 39999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117M vendor: ASUSTeK driver: nvidia v: 515.65.01
alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
2022-08) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-7:2 chip-ID: 322e:202c class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Najing CEC Panda 0x004d built: 2019
res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 199.54 GiB (41.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2210 MTFDHBA512QFD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 29.9 C scheme: GPT
Partition:
ID-1: / raw-size: 394.3 GiB size: 394.3 GiB (100.00%) used: 199.52 GiB
(50.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 25.9 MiB
(10.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 394.3 GiB size: 394.3 GiB (100.00%) used: 199.52
GiB (50.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 394.3 GiB size: 394.3 GiB (100.00%) used: 199.52
GiB (50.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 394.3 GiB size: 394.3 GiB (100.00%) used: 199.52
GiB (50.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 86.8 MiB (1.1%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C pch: 48.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 292 Uptime: 9m wakeups: 1 Memory: 7.6 GiB used: 4.67 GiB (61.4%)
Init: systemd v: 251 default: graphical tool: systemctl Compilers:
gcc: 12.2.0 Packages: pm: pacman pkgs: 1971 libs: 557 tools: octopi,paru
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.21
Garuda (2.6.7-1):
System install date:     2022-08-30
Last full system update: 2022-09-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Sadly, there wasn't much more information I could gather on the issue.

Looks like the game on Arch Linux based distros (and some others) aren't working well on Native on the base game (without the War of the Chosen DLC) , so its not just you. Some reason I guess the version that uses that DLC doesn't have those issues. https://www.protondb.com/app/268500

From what I gather, if you don't want to get that DLC, you would be best trying Proton and looking at reports from my link if you have other issues. Also, people seem to have a better time with running it in general with either Proton 7 or Experimental.

EDIT:
Be sure to check out this report in particular. It might have a way for you to run the native version: https://www.protondb.com/app/268500#z8VLK0KPKw
The post recommends trying with this as a launch option:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia %command%

1 Like

Hello, thanks for the swift reply

DLC isn't an issue as my version did come with all DLC available, and they are all installed. I had no idea that it was relevant, though.
I do think, although unsure, that launching the game should open the 2K Launcher. Mine doesn't even try, sadly.

As for the launch options, I did try and it still won't launch. But it shouldn't relate to missing libraries, just to using the right graphics card for better performance. However, by looking a little bit more through the website that you linked, I was able to find this post, which does absolutely relate to my issue https://www.protondb.com/app/268500#H9jNvSKx99

I'll see if I can fix this, maybe I can install the missing library files from the core repositories like this report states. Maybe I'll have to bite the bullet and try to run the game on proton. Thanks for the help

1 Like

libldap is available as a package and I already found it installed on my machine. The other 2 are not coming up in a package search for me, but I know liblber is related to libldap Is liblber part of openLDAP? What is it's purpose? - Unix & Linux Stack Exchange

As for libgconf-2.so.4 RPM, there are plenty of libg related packages that should be already installed on Garuda by looking at my install and the package list on the KDE ISO. I am just guessing it doesn't know how to interact with those for some reason?

3 Likes

Hey,

After a moment of searching, I found 2/3 of the solution

liblber-2.4.so.2 came from the lib32-libldap package, but apparently it doesn't include the dependency that I need since its 2.6 update, according to a comment from AUR (en) - crossover.
Instead, i found this package AUR (en) - libldap24, which I speculated was the 2.4 update of the same package. Whether it was or wasn't, I still don't know, but now steam cries out for a different library package, libgconf-2.so.4, which also wasn't found in the ldd ./XCOM 2 package before.

Now, ldd ./XCOM 2 DOES find liblber and libldap

liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007fa5ab7a4000...
libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0x00007fa5a685...

So I think I just have to figure out where I can get myself libgconf-2.so.4, and I shouldn't get the "missing libraries" error

https://bbs.archlinux.org/viewtopic.php?id=168406

1 Like

Oh man, it works!

I found the pkgfile libgconf-2.so.4 command through your link, and it gave me chaotic-aur/gconf, along with three other things. So i installed gconf through pacman -S gconf to see what happens
The launcher came up when I ran the game. And when I pressed play, I was never happier to see a game's title screen come up.

Thanks a lot. If I were there, I'd buy you a cookie. Maybe. :cookie:

1 Like

Glad you got it working!

In these cases the Solution goes to the post providing the right suggestion, not to the relevant implementation. :wink:
Maybe that's the cookie :crazy_face:
PS: choose the right one of course. I didn't follow the topic...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.