Xbox One wired gamepad stops being detected

Hi guys,

Sorry if this is a really n00b issue. I have searched the web and the wiki and have tried a couple of things to fix this but nothing worked so far.
So the issue is that my Xbox One Elite controller stops being detected after a while. It works fine for a bit but then if I don't use it the system (Game Controller and AntiMicroX) just says that it can't detect any gamepads. xboxdrv -L also outputs "no controllers attached", but lsusb shows both controllers as plugged in.
To me it feels like the controllers have gone to "sleep", but I don't know how to "wake them up".
They work normally after a restart, but again if I don't use them for a bit the same thing happens.
Any help would be greatly appreciated.
I tried using xpadneo, same thing; tried editing the xboxdrv file to add a 2nd controller, didn't help.

System:
Kernel: 5.18.13-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=941b2e31-16fe-4aba-9932-fe25573e184e rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=2a8ba6e8-69ea-4e8f-b4fd-634bba5b8b48 loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B550-E GAMING v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0248
date: 04/23/2020
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3704 high: 4065 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3593 2: 3535
3: 3673 4: 4065 5: 3593 6: 3924 7: 3611 8: 3612 9: 3693 10: 3591 11: 3938
12: 3623 bogomips: 86242
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Tul / PowerColor driver: amdgpu v: kernel arch: RDNA 1
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 0a:00.0
chip-ID: 1002:731f class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: DP-1 mapped: DisplayPort-0 model: ASUS XG32V serial: <filter>
built: 2018 res: 2560x1440 dpi: 93 gamma: 1.2
size: 697x393mm (27.44x15.47") diag: 800mm (31.5") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 14.0.6 DRM 3.46
5.18.13-zen1-1-zen)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.18.13-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0
chip-ID: 8086:15f3 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-5:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 2.27 TiB used: 764.37 GiB (32.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1XHE-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614900WD temp: 48.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:11 vendor: Samsung
model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 46.9 C scheme: MBR
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EAVS-00D7B1 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1A01
scheme: MBR
Partition:
ID-1: / raw-size: 214.84 GiB size: 214.84 GiB (100.00%)
used: 67.88 GiB (31.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 214.84 GiB size: 214.84 GiB (100.00%)
used: 67.88 GiB (31.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-4: /var/log raw-size: 214.84 GiB size: 214.84 GiB (100.00%)
used: 67.88 GiB (31.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-5: /var/tmp raw-size: 214.84 GiB size: 214.84 GiB (100.00%)
used: 67.88 GiB (31.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 31.25 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:
System Temperatures: cpu: 46.0 C mobo: 39.0 C gpu: amdgpu temp: 50.0 C
mem: 54.0 C
Fan Speeds (RPM): cpu: 0 gpu: amdgpu fan: 1021
Info:
Processes: 419 Uptime: 1h 54m wakeups: 0 Memory: 31.25 GiB
used: 9.09 GiB (29.1%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 2105
note: see --pkg apt: 0 pacman: 2098 lib: 565 flatpak: 7 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-05-24
Last full system update: 2022-07-23 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Check the Arch wiki page to see if there's anything that looks relevant: https://wiki.archlinux.org/title/Gamepad#Xbox_Wireless_Controller_/_Xbox_One_Wireless_Controller

1 Like

I might be telling the obvious but did you try pushing the Xbox button to wake up?

1 Like

To jonathon:
Yeah that's what I've been reading so far, and trying to find a solution there. It's a wired gamepad btw. And the 2nd gamepad is Turtle Beach Recon controller and it does the exact same thing.

To mrvictory:
Thanks, from what I can tell the Xbox button does absolutely nothing.

Powersaving might have something to do with it. It does with some of my peripherals. A couple of configs specific to mine, inserted into /etc/modprobe.d, helps keep ports alive. One such line is:

options snd_hda_intel power_save=0

Inserted into the configuration file named:

snd_hda_intel.conf

Which is then inserted into /etc/modprobe.d, saved and rebooted.

That works with my Intel/Intel setup. Yours is a bit different.

regards

5 Likes

Thank you, this is what I had in mind too. I'll give it a try, but as you say I have an AMD system so it might not work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.