XBox 360 Wireless not working

I've recently switched from Pop OS to Garuda because I wanted to just try another distro. Garuda looked really nice and the KDE Gaming image feels so smooth in the UI. However, I cannot get either my XBox 360 Wireless nor the wired controller to work. In Pop OS, they worked right out of the box with no issue.

In my case, the 4 lights around the Logo button just flash. Sometimes, it might register finally but when I try to use them in any Steam games, the controller is not working in the games at all.

In Pop OS, I had no issue what-so-ever and never had to do anything special to get it to work, so I'm not sure what is going on with Garuda. I really want to stay with Garuda, but I might have to switch back to Pop OS if I can't get the controllers to work.

Doing lsusb, I can see the XBox 360 receiver is there but for whatever reason, it just won't work.

I've searched and can't find a solution to this at all. As I stated, it works in Pop OS but not Garuda.

Here is my output from garuda-inxi:

System:
Kernel: 6.1.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=20834898-fd28-4c96-aced-9b0c2862486a rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: B450M DS3H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: B450M DS3H-CF serial: <superuser required>
UEFI: American Megatrends LLC. v: F63b date: 05/11/2022
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3967 high: 3968 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3967 2: 3968
3: 3967 4: 3968 5: 3968 6: 3968 7: 3967 8: 3967 9: 3967 10: 3967 11: 3967
12: 3967 bogomips: 86237
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: ASUSTeK driver: nvidia
v: 525.78.01 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 06:00.0 chip-ID: 10de:2184 class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x1080 s-dpi: 101 s-size: 1450x272mm (57.09x10.71")
s-diag: 1475mm (58.08")
Monitor-1: DP-0 pos: primary,center res: 1920x1080 hz: 75 dpi: 85
size: 576x324mm (22.68x12.76") diag: 661mm (26.02") modes: N/A
Monitor-2: DVI-D-0 pos: left res: 1920x1080 hz: 60 dpi: 102
size: 476x268mm (18.74x10.55") diag: 546mm (21.51") modes: N/A
Monitor-3: HDMI-0 pos: right res: 1920x1080 hz: 75 dpi: 85
size: 576x324mm (22.68x12.76") diag: 661mm (26.02") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.78.01 renderer: NVIDIA GeForce GTX
1660/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel bus-ID: 1-1:2 v: kernel chip-ID: 0d8c:0012 pcie:
gen: 3 class-ID: 0300 speed: 8 GT/s lanes: 16 bus-ID: 06:00.1
chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media USB Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.6-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: N/A
bus-ID: 1-5:5 chip-ID: 045e:0719 class-ID: ff00 serial: <filter>
Drives:
Local Storage: total: 7.07 TiB used: 2.27 TiB (32.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power
model: SPCC Solid State Disk size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 91.3
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HDS5C3030ALA630
size: 2.73 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5700 serial: <filter> rev: A580 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HDS723020BLA642
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: A5C0 scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: HD103SI
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 1118 scheme: GPT
ID-5: /dev/sde maj-min: 8:64 type: USB vendor: JMicron Tech model: N/A
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: N/A
serial: <filter> rev: 0509 scheme: MBR
ID-6: /dev/sdf maj-min: 8:80 type: USB vendor: Generic
model: USB SD Reader size: 14.9 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-7: /dev/sdg maj-min: 8:96 type: USB vendor: Toshiba model: MQ01ABF050
size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: HDD
rpm: 5400 serial: <filter> scheme: GPT
Partition:
ID-1: / raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 14.53 GiB (29.7%) fs: btrfs dev: /dev/sdc3 maj-min: 8:35
ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 44.54 GiB (2.5%) fs: btrfs dev: /dev/sdc4 maj-min: 8:36
ID-4: /var/log raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 14.53 GiB (29.7%) fs: btrfs dev: /dev/sdc3 maj-min: 8:35
ID-5: /var/tmp raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 14.53 GiB (29.7%) fs: btrfs dev: /dev/sdc3 maj-min: 8:35
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 16 MiB (0.1%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 88.1 C mobo: 36.0 C gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Info:
Processes: 359 Uptime: 1h 5m wakeups: 0 Memory: 15.54 GiB
used: 7.74 GiB (49.8%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 1860 libs: 514 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-15
Last full system update: 2023-01-15 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hi there, welcome to the community.
See

https://wiki.archlinux.org/title/Gamepad#Xbox_360_controller

3 Likes

Thank you! I needed to the following:

  1. Install xboxdrv package
  2. Restart xboxdrv service => sudo systemctl stop xboxdrv.service && sudo systemctl start xboxdrv.service

That fixed it!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.