Xanmod-cacule produces electronic screeching for a few seconds after login

When booting with xanmod-cacule kernel, right after entering the password, I'm getting a screeching electronic sound from the laptop. The sound lasts just a few seconds and is then silenced. It appears to come from where the speakers are, though muting the speakers has no effect.
Loading Linux 5.13 kernel didn't produce the sounds.
I also tried: Switching integrated/discrete card. Changing between 60/144hz, disabling wifi and bluetooth.

Will edit with inxi -Faz details in a bit. Want to test something first.

edit: booting on batter or plugged in made no difference.

edit: disabled
Disabled optimus, network manager, pulseaudio and many other things in autorun. Nothing helped.

Here are more details:

System: Kernel: 5.14.1-xanmod1-cacule-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-cacule
root=UUID=f8c628f2-67bc-4888-9476-74aed29f0537 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
loglevel=2 mitigations=off
Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 dm: LightDM 1.30.0
Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A
serial: Chassis: type: 10 serial:
Mobo: HP model: 87B1 v: 31.21 serial: UEFI: AMI v: F.20 date: 11/04/2020
Battery: ID-1: BAT0 charge: 37.7 Wh (81.6%) condition: 46.2/46.2 Wh (100.0%) volts: 13.0 min: 11.6
model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Charging cycles: 415
CPU: Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106
cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71868
Speed: 1659 MHz min/max: 1400/3000 MHz base/boost: 3000/4000 boost: enabled volts: 1.2 V
ext-clock: 100 MHz Core speeds (MHz): 1: 1659 2: 2110 3: 3206 4: 1996 5: 1389 6: 2274
7: 2177 8: 1597 9: 1682 10: 1834 11: 2676 12: 2021
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy barriers
only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: NVIDIA TU117M vendor: Hewlett-Packard driver: N/A
alternate: nvidiafb, nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:1f99
class-ID: 0300
Device-2: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-3: Chicony HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 3-3:2
chip-ID: 04f2:b6f1 class-ID: 0e02 serial:
Display: server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: modesetting
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") s-diag: 583mm (23")
Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.1-xanmod1-cacule-1 LLVM 12.0.1)
v: 4.6 Mesa 21.2.1 direct render: Yes
Audio: Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.1-xanmod1-cacule-1 running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.34 running: no
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac:
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 03:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlo1 state: up mac:
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: yes address: N/A
Drives: Local Storage: total: 465.76 GiB used: 76.28 GiB (16.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
type: SSD serial: rev: 2B2QEXM7 temp: 48.9 C scheme: GPT
Partition: ID-1: / raw-size: 130.53 GiB size: 130.53 GiB (100.00%) used: 76.23 GiB (58.4%) fs: btrfs
block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 48.9 MiB (51.0%) fs: vfat
block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 130.53 GiB size: 130.53 GiB (100.00%) used: 76.23 GiB (58.4%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 130.53 GiB size: 130.53 GiB (100.00%) used: 76.23 GiB (58.4%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 130.53 GiB size: 130.53 GiB (100.00%) used: 76.23 GiB (58.4%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:4
Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 15 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors: System Temperatures: cpu: 60.6 C mobo: 55.0 C gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A
Info: Processes: 322 Uptime: 5m wakeups: 1 Memory: 15 GiB used: 1.83 GiB (12.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1387 lib: 350
Shell: Bash (sudo) v: 5.1.8 running-in: cool-retro-term inxi: 3.3.06

Whenever someone posts that they are having an issue that only impacts a specific kernel my answer will always be, "Use a different kernel"

4 Likes

I understand that.
Was wondering if someone might be able to offer an explanation though, to help us understand this issue better.
Perhaps it is an incompatibility issue between the kernel and some piece of software or hardware.
Without solving this I will surely move to another kernel. The sound is really creepy, as if there's a shorting in the computer...
The computer works great otherwise, with this kernel.

The sound is (luckily) coming from the speakers.

I played around audio settings a lot and disabled audio altogether and now when I log in, there is no longer that screeching sound coming from the computer.

Plot thickens. It's Pulseaudio.
When I type 'pulseaudio' into the terminal, I get error and screeching!
The error:
pulseaudio
W: [pulseaudio] cli-command.c: stat('/etc/pulse/default.pa.d'): No such file or directory
E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.

Any ideas?
xxx
Is it just because I disabled everything related to bluetooth in Garuda Assistant..?

Edit:
After re-enabling bluetooth pulseaudio still gives screeching and this error:
W: [pulseaudio] cli-command.c: stat('/etc/pulse/default.pa.d'): No such file or directory

Not idea what it could mean?

Have you tried to blacklist pcspkr

1 Like

It appears to be the PC speaker. While playing music, I selected the mono built in audio here as in the picture (in pulseaudio system tray) and it started playing that music differently and with heavy screeching.
Any ideas why this PC speaker gets activated on boot and why I even have the ability to select it here and how can I solve it? Just by blacklisting PC speaker?

Maybe the other kernels have it disabled by default?

This is what I would do.

2 Likes

Probably. Launched vanilla Linux 5.13 and it doesn't have that mono audio selection there.
So I guess the cause is found.
Hope this might assist anyone else with similar issue in the future.

Since it doesn't seem to be a serious issue I'll continue using the xanmod-cacule kernel. After all, it works great overall. I probably didn't notice the PC Speaker screeching before because today was the first day in a month that I used the laptop without external speakers attached.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.