Xampp control panel not opening

System:
Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=647e731d-2d7b-4d32-bb3e-73141eaf0bc1 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 81F0 v: 63.21 serial: <superuser required> UEFI: Insyde
v: F.44 date: 08/07/2018
Battery:
ID-1: BAT1 charge: 12.3 Wh (66.1%) condition: 18.6/32.6 Wh (57.0%)
volts: 15.9 min: 14.8 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: discharging
CPU:
Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1898 high: 1900 min/max: 500/1900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1900 2: 1900 3: 1896
4: 1896 bogomips: 15963
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports:
active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
520 Mobile] vendor: Hewlett-Packard driver: radeon v: kernel
alternate: amdgpu arch: GCN-1 code: Southern Islands process: TSMC 28nm
built: 2011-20 pcie: gen: 2 speed: 5 GT/s lanes: 4 link-max: gen: 3
speed: 8 GT/s lanes: 8 bus-ID: 0d:00.0 chip-ID: 1002:6660 class-ID: 0380
temp: 38.0 C
Device-3: Chicony HP TrueVision HD driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-5:4 chip-ID: 04f2:b56c
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,radeon
alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: AU Optronics 0x70ec built: 2015 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1366x768
API: EGL v: 1.5 hw: drv: intel iris drv: amd radeonsi platforms: device: 0
drv: iris device: 1 drv: radeonsi device: 2 drv: swrast surfaceless:
drv: radeonsi x11: drv: iris inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) device-ID: 8086:1616 memory: 7.49 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
HD Graphics 5500 (BDW GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:1616 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:9ca0 class-ID: 0403
API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 5000
bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Broadcom BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl
v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 13:00.0 chip-ID: 14e4:4365 class-ID: 0280
IF: wlp19s0 state: up mac: <filter>
Bluetooth:
Device-1: Broadcom BCM43142A0 Bluetooth 4.0 driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-4:3 chip-ID: 0a5c:216d
class-ID: fe01 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6
status: discoverable: no pairing: no
Drives:
Local Storage: total: 1.14 TiB used: 24.28 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1
size: 232.89 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 045 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010A9E680
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: A7G0 scheme: MBR
Partition:
ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 24.28 GiB (10.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 24.28 GiB (10.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 24.28 GiB (10.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 24.28 GiB (10.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 50.0 C pch: 42.5 C mobo: N/A gpu: radeon
temp: 38.0 C
Fan Speeds (rpm): N/A
Info:
Processes: 223 Uptime: 36m wakeups: 0 Memory: total: 8 GiB
available: 7.67 GiB used: 3.84 GiB (50.0%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1878 libs: 556 tools: octopi,paru,yay Shell: fish v: 3.6.1
default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-10-28
Last full system update: 2023-11-14 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

I have installed xampp but its control panel not opening only xampp manager is opening

means you haven’t restarted since the last update. Would be the first thing to try to see if it fixes your issue.

3 Likes

not opening , it just opens a box for password authentication then there’s nothing afterwards

Please, start the app from terminal, check log and maybe open issue on

when opening through terminal its showing this message

/usr/bin/xdg-open: line 508: test: : integer expression expected

I’ve been having the same issue since installing Xampp some months ago.

Xampp Manager works, but not Xampp Control Panel. This makes it difficult to change application settings.

kfmclient_fix_exit_code()
{
    version=`LC_ALL=C.UTF-8 kde-config --version 2>/dev/null | grep '^KDE'`
    major=`echo $version | sed 's/KDE.*: \([0-9]\).*/\1/'`
    minor=`echo $version | sed 's/KDE.*: [0-9]*\.\([0-9]\).*/\1/'`
    release=`echo $version | sed 's/KDE.*: [0-9]*\.[0-9]*\.\([0-9]\).*/\1/'`
    test "$major" -gt 3 && return $1
    test "$minor" -gt 5 && return $1
    test "$release" -gt 4 && return $1
    return 0
}

It tests the release greater than 4
But

it is not very busy, maybe the wrong place.

Check

kfmclient -v
kfmclient 2.0
Package (3)           New Version  Net Change  Download Size

extra/keditbookmarks  23.08.3-1      1,38 MiB       0,35 MiB
extra/kinit           5.112.0-1      0,48 MiB       0,13 MiB
extra/konqueror       23.08.3-1     27,62 MiB       9,82 MiB

Hey,

Since I’m facing the same issue and @rolex isn’ answering, I figured I’d continue the discussion.

In my case, trying to open the xampp control panel from the terminal (by running xampp panel) doesn’t do anything. I get the xampp usage docs when i run the command.

I also tried running xampp-control-panel & pkexec xampp-control-panel (like the desktop app tries to do), but that just outputs: line 2: python2: command not found.

I saw your kfmclient fix reply, but I’m not really sure what to do with that. Can you please explain a bit more?

Thanks.

I’m not a programmer, but it looks like the check fails, greater than 4, because here the result is 2.
Changing the line to 1 instead of 4 might help.

But I could also be completely wrong about what the queries there are supposed to mean :smiley:

I don’t use the app and can’t test it :slight_smile:

currently I am using sqldb but its not that great any solution is highly appreciated & I am forced to switch to windows (sorry for late reply !) @Shelomoh did xampp (control panel) open ? mine still not opening :expressionless:

No luck here either. I read SGS’ reply but I don’t know what to do with what he’s said.
I’m thinking of using some other software for starting localhost servers…

I am also having hard time to understand what he said,I am going to repair my old desktop & install windows :disappointed:

I am not really familiar with this package but if the AUR version is not working you could try manually installing it instead and see if you have better luck. https://wiki.archlinux.org/title/XAMPP#Manual_installation

What is the output of
LC_ALL=C.UTF-8 kde-config --version 2>/dev/null | grep '^KDE' ?
My guess is that one of the three sed lines is returning empty string.