X86/cpu: SGX disabled by BIOS

Hello everyone,

I wanted to greet you all and share an experience I’m having. Recently, I was installing video drivers following the instructions on the official Kali Linux website. However, upon rebooting my system, I encountered some puzzling error messages.

I’ve tried several solutions, such as updating the motherboard drivers and BIOS, but I haven’t been able to find the “SGX” option or anything similar in the BIOS settings. I’ve also tried changing the boot mode and disabling secure mode, but so far, I haven’t had any success.

I’m a bit lost as to what to do next. I would greatly appreciate any advice or suggestions you can offer.


CPU: i5-10400F


Thanks in advance!

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


Most likely the problem is not in the SGX disabled, but in the fact that you installed drivers (which?) following a Kali Linux guide for an Arch based distro.
Never use random guides and maybe drivers, not even from the nvidia site.
Possibly use the autoinstall button or, if not working, the Arch packages.


Oops, it looks like you wound up on the Garuda Linux forum by mistake. This is the Kali Linux help forum: https://forums.kali.org/