X11 fails to start after latest upgrades

You should not use pamac for updates, even if it's the terminal wrapper. They sometimes hide information you can't get otherwise. garuda-update also often fixes issues related to updates, maybe you should try that first.

1 Like

Why do you post a picture from the termninal?
Also use LANG=C before the "update" so that in an English forum everyone knows what is written there.

LANG=C update
:: Synchronizing package databases...
garuda is up to date
core                                                                                         154,0 KiB   342 KiB/s 00:00 [-------------------------------------------------------------------------] 100%
extra                                                                                       1746,0 KiB  2,99 MiB/s 00:01 [-------------------------------------------------------------------------] 100%
community                                                                                      7,2 MiB  7,52 MiB/s 00:01 [-------------------------------------------------------------------------] 100%
multilib                                                                                     161,2 KiB   378 KiB/s 00:00 [-------------------------------------------------------------------------] 100%
chaotic-aur                                                                                    2,4 MiB  2,57 MiB/s 00:01 [-------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (57)

Thx for your answers, unfortunately i dont seem to see anything relevant information in the upgrade logs.

There is a plymouth.conf.pacnew file created, but it doenst seem to contain much differences except for the dragonized theme name...

╰─ diff plymouthd.conf plymouthd.conf.pacnew
< Theme=dr460nized
> Theme=bgrt
╰─ garuda-update
:: Synchronisation des bases de données de paquets…
garuda est à jour
core                                  154,0 KiB   636 KiB/s 00:00 [------------------------------------] 100%
extra est à jour
community                               7,2 MiB  18,7 MiB/s 00:00 [------------------------------------] 100%
multilib est à jour
chaotic-aur                             2,4 MiB  9,13 MiB/s 00:00 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵
:: Synchronisation des bases de données de paquets…
téléchargement de garuda…
téléchargement de core…
téléchargement de extra…
téléchargement de community…
téléchargement de multilib…
téléchargement de chaotic-aur…
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (9) fzf-0.39.0-1  lib32-systemd-253.3-1  libnghttp2-1.52.0-2  man-pages-6.04-1
plymouth-git-22.02.122.r170.ge8e19371-2  systemd-253.3-1  systemd-libs-253.3-1
systemd-sysvcompat-253.3-1  xf86-input-libinput-1.3.0-1

Total Installed Size:  44.21 MiB
Net Upgrade Size:       0.02 MiB

:: Proceed with installation? [Y/n]
(9/9) checking keys in keyring                                     [------------------------------------] 100%
(9/9) checking package integrity                                   [------------------------------------] 100%
(9/9) loading package files                                        [------------------------------------] 100%
(9/9) checking for file conflicts                                  [------------------------------------] 100%
(9/9) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 119
:: Processing package changes...
(1/9) upgrading fzf                                                [------------------------------------] 100%
(2/9) upgrading systemd-libs                                       [------------------------------------] 100%
(3/9) upgrading lib32-systemd                                      [------------------------------------] 100%
(4/9) upgrading libnghttp2                                         [------------------------------------] 100%
(5/9) upgrading man-pages                                          [------------------------------------] 100%
(6/9) upgrading plymouth-git                                       [------------------------------------] 100%
warning: /etc/plymouth/plymouthd.conf installed as /etc/plymouth/plymouthd.conf.pacnew
New optional dependencies for plymouth-git
gtk3: x11 renderer [installed]
(7/9) upgrading systemd                                            [------------------------------------] 100%
(8/9) upgrading systemd-sysvcompat                                 [------------------------------------] 100%
(9/9) upgrading xf86-input-libinput                                [------------------------------------] 100%
:: Running post-transaction hooks...
( 1/17) Creating system user accounts...
( 2/17) Updating journal message catalog...
( 3/17) Reloading system manager configuration...
( 4/17) Updating udev hardware database...
( 5/17) Applying kernel sysctl settings...
( 6/17) Creating temporary files...
( 7/17) Reloading device manager configuration...
( 8/17) Arming ConditionNeedsUpdate...
( 9/17) Updating initramfs...
:: Building initramfs for linux (6.2.9-arch1-1)
:: Building fallback initramfs for linux (6.2.9-arch1-1)
:: Building initramfs for linux-zen (6.2.9-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.2.9-zen1-1-zen)
(10/17) Updating linux initcpios...
(11/17) Foreign/AUR package notification
kalk 22.09-1
(12/17) Orphaned package notification...
extra-cmake-modules 5.104.0-1
linux-headers 6.2.9.arch1-1
(13/17) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(14/17) Reloading system bus configuration...
(15/17) Updating Vim help tags...
(16/17) Performing snapper post snapshots for the following configurations...
==> root: 120
(17/17) Syncing all file systems...

System updated! 🐧

systemctl restart lightdm for other DMs

systemctl restart sddm (plasma/kde) systemctl restart gdm (gnome)


for me

sudo systemctl enable sddm

was enough since plymouth was already added as a hook in my mkinitcpio.conf.
You can check if the hook is there in mkinitcpio or not and add it if necessary.

systemctl enable sddm

indeed solved to issue, not sure i understand why it got disabled in the first place but i'm not too good with this kind of technical details.

thanks a lot for the help !


Had similar issue this morning. Doing a startx worked. Restored snapshot. Didn't see anything in the update logs when I reran the update that pointed me in the right direction. Final fix was (as I'm running lightdm):

$ sudo systemctl enable lightdm

Rebooted and things look beautiful again.

plymouth renamed sddm-plymouth.service to sddm.serivce that's why it happend

Oh OK, thx for the explanation.

Hey all,

Exactly the same for me with sddm.
No traces at all in the updates logs.
Strange... How can we know how to solve that without any infos ?

You either have a completely different problem or you just didn't look at the solution in a solved thread.

The 'plymouth' hook and sddm/systemctl is standard with a Plasma install nowadays. I had to do the same on a modified archinstall routine recently.

1 Like

Yep, worked for me too

"sudo systemctl enable sddm" in tty fixed all 3 machines it was tested on. Thank you!

After the update to Plymouth, this message was printed to the terminal:

warning: /etc/plymouth/plymouthd.conf installed as /etc/plymouth/plymouthd.conf.pacnew
WARNING: The 'plymouth-encrypt' and 'sd-plymouth' hooks are no longer exist in the package. You should replace them with 'encrypt' and 'plymouth' hooks in your 'mkinitcpio.conf'. 
The 'lxdm-plymouth.service', 'lightdm-plymouth.service' and 'sddm-plymouth.service' systemd service files are no longer exist in the package. You should enable 'lxdm.service', 'lightdm.service' or 'sddm.service' instead.
New optional dependencies for plymouth
    gtk3: x11 renderer [installed]

@UltraBlack : no, not a completely different problem, and the solution worked for me too. My question was not about the problem or the solution, but about how to know how to solve the problem.

@BluishHumility : strange, that wasn't the case for me...

This issue is now fixed automatically in garuda-migrations 2.3.0.


I have a similar issue (or maybe the same)?

On boot, Garuda does not go to the login screen, but to the tty login.
Once I log in there and "startx" myself, everything runs normally and fine, though.

I ran garuda-update of course and saw that the migrations package got updated.
However, that didn't fix the problem for me. Even after reboot, I see the terminal and not the login screen.

Here's my inxi (that's after starting the Xserver myself, not sure if you need one from the terminal):

  Kernel: 6.2.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8e419d89-6565-45e5-9500-d55f6c22838b rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=20d060ba-e3d9-4019-93b5-2d7d2f5d24f2 loglevel=3 ibt=off
  Desktop: Cinnamon v: 5.6.8 tk: GTK v: 3.24.37 wm: muffin vt: 1 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82NW v: Legion 5 15ACH6A
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ACH6A
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
    serial: <superuser required> UEFI: LENOVO v: G9CN28WW date: 01/19/2022
  ID-1: BAT0 charge: 83.5 Wh (100.0%) condition: 83.5/80.0 Wh (104.4%)
    volts: 17.0 min: 15.4 model: SMP L20M4PC1 type: Li-poly serial: <filter>
    status: full cycles: 2
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1449 high: 3200 min/max: 1200/4462 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1467 2: 3200
    3: 1200 4: 2486 5: 1198 6: 1200 7: 1544 8: 1198 9: 1200 10: 1200 11: 1200
    12: 1200 13: 1200 14: 1200 15: 1200 16: 1301 bogomips: 102213
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Lenovo
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1, DP-2, HDMI-A-1, eDP-1 bus-ID: 03:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: eDP-2 empty: none
    bus-ID: 07:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 31.0 C
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 13d3:56ff class-ID: 0e02
  Display: server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-2 mapped: eDP-1 model: AU Optronics 0xb69b built: 2021
    res: 1920x1080 hz: 165 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.2.9-zen1-1-zen) direct-render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.2.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw89_8852ae v: N/A modules: rtw_8852ae pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 06:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Local Storage: total: 476.94 GiB used: 91.9 GiB (19.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDHBA512QFD
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 0013P6LN temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 461.79 GiB size: 461.79 GiB (100.00%)
    used: 79.56 GiB (17.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 461.79 GiB size: 461.79 GiB (100.00%)
    used: 79.56 GiB (17.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 461.79 GiB size: 461.79 GiB (100.00%)
    used: 79.56 GiB (17.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 461.79 GiB size: 461.79 GiB (100.00%)
    used: 79.56 GiB (17.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 13.5 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 14.86 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 36.1 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 33.0 C mem: 30.0 C fan: 0 watts: 7.00
    device: amdgpu temp: 32.0 C
  Processes: 408 Uptime: 8m wakeups: 1 Memory: 13.51 GiB
  used: 3.72 GiB (27.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1474
  libs: 466 tools: pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-03-17
  Last full system update: 2023-04-06
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

yeah it's the same issue. plymouth renamed it's modules that's why it happened.

WARNING: The 'plymouth-encrypt' and 'sd-plymouth' hooks are no longer exist in the package. You should replace them with 'encrypt' and 'plymouth' hooks in your 'mkinitcpio.conf'. The 'lxdm-plymouth.service', 'lightdm-plymouth.service' and 'sddm-plymouth.service' systemd service files are no longer exist in the package. You should enable 'lxdm.service', 'lightdm.service' or 'sddm.service' instead.

This is the warning that plymouth gave follow it to fix your system.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.