WPS Office Spellcheck Not Working

I've installed WPS Office from Chaotic. It works great except... spellcheck isn't working. It appears enabled, I can select English (United States) language and set it to default. But it isn't actually working.

It's hard to blame the company for the problem, because they only officially support Debian and Red Hat packages, and it appears to be working for others. Somewhere with the AUR release, spellcheck got broken. Any idea how to fix it or where to look? And how could I install more spellcheck languages?

Then set your language by selecting Review->Spell Check->Set Language to choose your language and restart WPS.

According to this, you may have to restart the program after you choose the language. Have you tried that yet?

3 Likes

Was it wps-office or wps-office-cn?

1 Like

Quickly checking the comments in AUR at least another user reported the same:
https://aur.archlinux.org/packages/wps-office
Though one stated to have solved just

dropping the dict into /home/$USER/.local/share/Kingsoft/office6/dicts/

4 Likes

I have added wps-office-all-dicts-win-languages to Chaotic-AUR, it should solve your problem! :slight_smile:

5 Likes

Great, I installed wps-office-all-dicts-win-languages and rebooted the system.

In WPS Writer, I can now see the list of languages, but it still doesn't do any spell-check. The only language that seems to work is French (France). For all other languages, I click Spell Check and it says "Spell Check Completed" without detecting anything at all.

These are the only ones provided. If they don't work I assume it's likely an upstream issue; especially since so many people reported the same over issue over a long period of time. Can you try to run it from a command line and see if there is any error message produced when spellcheck is attempted?

Consider trying libreoffice-fresh

5 Likes

OnlyOffice is also really good I think, although I've had problems with it on all-Wayland systems like Sway or Wayfire. Other than that it works very well. It is very "familiar" in its features and presentation, and is meant to be highly compatible with the M$ formats if that is useful.

2 Likes

It works well but nothing beats WPS office when it comes to office compatibility

1 Like

No error shows up in the console. I found LibreOffice and OpenOffice to be a bit lackbuster compared to MS Office; but WPS stands to it.

1 Like

I've found OnlyOffice Desktop Editors to be effective in Linux or Windows.

Just my two :notes:

They're effective but when you need to rely on compatibility between office suites on Windows and Linux then WPS office is the best solution without a doubt. I don't know how they do it but nothing comes close to their compatibility which really annoys me.

I had tried Open Office and Libre Office in the past and although the text editor was fine, the Spreadsheet and Powerpoint were lackbuster. Especially if trying to do a graph or something. Like -- no Powerpoint animation whatsoever.

I can give Only Office a try. Visually looks very similar to MS Office but with less features! WPS' compatibility is great; but the lack of spellchecking is kind of an important deal.

Only Office has an annoying lack of attention for details.

"doesn't" doesn't pass spellcheck.

I cannot double-click and drag to quickly select 2 words.

It honestly looks like a cheap rip-off of MS Office.

What else is missing?

Just use grammarly. It's better anyway

Does Grammarly work on Linux and in WPS?

Best to report upstream and hope it's fixed.

They have a website. Just copy paste text back and forth

Spellcheck was reported 1.5 years ago... it's unlikely it will get fixed anything soon so I shouldn't rely on it. Best I can do is report it again and look for an alternative.

*Posted a comment on the AUR

The problem is that the one maintaining the AUR is just a package manager and software problems should be reported upstream; whereas upstream WPS works on their target platforms so unsupported platforms aren't their problem. So who would solve this issue?

Sounds like how things work in China: everybody does only their job and solving problems is nobody's responsibility.

The AUR is not the problem, they have made the package correctly. Kingsoft says that they support Linux, so this is in fact Kingsoft's problem as a 'target platform'.

Well it is a Chinese company selling their software (with paid versions). That definitely is their responsibility. They do not provide source code. Nobody outside of them would be able to patch it. Kingsoft - Wikipedia

2 Likes