WPS Office not opening in Garuda Gnome

Hello everyone

WPS Office suite in not opening in my Garuda Gnome. I have searched for a solution and tries something writen in Arch wiki, but it is not working. Please help.

Below is the WPS Office topic content from Arch wiki.

Use GTK+ UI

The default UI of WPS is Qt. In fact, the bundled Qt is 4.7.4, so the themes such as qtcurve cannot be loaded normally because the versions do not match. But we can change it to GTK+ and add the parameter -style gtk+ directly.

You can modify the et, wpp, and wps files in the /usr/bin/ directory and delete it (if any):

gOpt=

Then, add:

gOpt="-style=gtk+" export GTK2_RC_FILES=/usr/share/themes/Breeze/gtk-2.0/gtkrc

Below is inxi -Faz result

inxi -Faz
System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=623451ca-0518-4a25-b81f-110186eefb5f 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 81W1 v: IdeaPad 3 15ADA05 serial: <filter> Chassis: 
           type: 10 v: IdeaPad 3 15ADA05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0Q55724WIN serial: <filter> UEFI: LENOVO v: E8CN28WW 
           date: 05/14/2021 
Battery:   ID-1: BAT0 charge: 13.8 Wh (45.8%) condition: 30.1/35.0 Wh (86.1%) volts: 7.5 min: 7.5 
           model: SMP L16M2PB2 type: Li-poly serial: <filter> status: Discharging cycles: 513 
CPU:       Info: Dual Core model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 type: MT MCP arch: Zen 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 20761 
           Speed: 1229 MHz min/max: 1400/2600 MHz boost: enabled Core speeds (MHz): 1: 1229 2: 1299 
           3: 1224 4: 1223 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel bus-ID: 02:00.0 
           chip-ID: 1002:15d8 class-ID: 0300 
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-5.1:6 
           chip-ID: 174f:118d class-ID: 0e02 serial: <filter> 
           Display: wayland server: X.Org 1.21.1.2 compositor: gnome-shell driver: loaded: amdgpu,ati 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") s-diag: 583mm (23") 
           Monitor-1: XWAYLAND0 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
           diag: 389mm (15.3") 
           OpenGL: renderer: AMD Radeon Vega 3 Graphics (RAVEN2 DRM 3.42.0 5.14.8-zen1-1-zen LLVM 12.0.1) 
           v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
           driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 02:00.5 chip-ID: 1022:15e2 
           class-ID: 0480 
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.37 running: yes 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:c822 
           class-ID: 0280 
           IF: wlp1s0 state: up mac: <filter> 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-6:5 
           chip-ID: 0bda:c123 class-ID: e001 serial: <filter> 
           Report: bt-adapter ID: hci0 rfk-id: 8 state: down bt-service: enabled,running rfk-block: 
           hardware: no software: yes address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 142.49 GiB (15.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 
           serial: <filter> rev: LFM1 scheme: GPT 
Partition: ID-1: / raw-size: 146.76 GiB size: 146.76 GiB (100.00%) used: 11.72 GiB (8.0%) fs: btrfs 
           dev: /dev/sda9 maj-min: 8:9 
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 41 MiB (42.7%) fs: vfat 
           dev: /dev/sda2 maj-min: 8:2 
           ID-3: /home raw-size: 146.76 GiB size: 146.76 GiB (100.00%) used: 11.72 GiB (8.0%) fs: btrfs 
           dev: /dev/sda9 maj-min: 8:9 
           ID-4: /var/log raw-size: 146.76 GiB size: 146.76 GiB (100.00%) used: 11.72 GiB (8.0%) fs: btrfs 
           dev: /dev/sda9 maj-min: 8:9 
           ID-5: /var/tmp raw-size: 146.76 GiB size: 146.76 GiB (100.00%) used: 11.72 GiB (8.0%) fs: btrfs 
           dev: /dev/sda9 maj-min: 8:9 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 9.6 GiB used: 29.3 MiB (0.3%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A gpu: amdgpu temp: 40.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 262 Uptime: 1d 1h 10m wakeups: 7 Memory: 9.6 GiB used: 3.1 GiB (32.3%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1210 lib: 334 
           Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06 

what theme are you currently using?

I am using Adwaita theme.

I have already tried changing the Breeze theme to Adwaita theme

/themes/Breeze/gtk-2.0/gtkrc
to 
/themes/Adwaita/gtk-2.0/gtkrc

Try opening from terminal and post output?

The output for WPS Spreadsheet in terminal shows like below

[email protected] in ~ 
 ╰─λ et

 ╭─[email protected] in ~ took 830ms
 ╰─λ 

And WPS spreadsheet does not open.

Just guessing (I've no knowledge of WPS Office and Gnome)...
If you changed /themes/Breeze/gtk-2.0/gtkrc to /themes/Adwaita/gtk-2.0/gtkrc I think you should adjust gOpt="-style=gtk+" export GTK2_RC_FILES=/usr/share/themes/Breeze/gtk-2.0/gtkrc accordingly.
Have you already tried that?

I use WPS on gnome nothing needs changing here it defaults to its own light theme
Where did you get WPS from did you install this
yay -S wps-office ttf-wps-fonts ttf-ms-fonts

1 Like

Installed WPS Office from Setup-Assistant.

Let me try by installing through terminal.

I have already tried this.

I have removed WPS office and reinstalled through terminal. But I am getting the same problem.

WPS Office in not opening.

how did you change the files ?

did you go into each file listed in

/usr/bin/et
/usr/bin/wpp
/usr/bin/wps

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.