Wireless interface issue

Wifi networks show but can’t connect. The issue began at the end of trying to update Garuda. The terminal showed this error “Can’t update: signature from *** is marginal trust” or “invalid or corrupted package” and I pressed Y in all of them, then the Wifi stopped working. I’m wondering if reinstalling Garuda will fix this problem.


Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc available: acpi_pm

parameters: BOOT_IMAGE=/a/boot/vmlinuz-linux-zen root=UUID=9ad899ae-3ae8-43ec-a5b6-24e4270ff3e4 rw rootflags=subvol=@

quiet loglevel=3 ibt=off

Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin x11 vt: 2

dm: SDDM Distro: Garuda Linux base: Arch Linux


Type: Laptop System: Apple product: MacBookAir6, 1 v: 1.0

serial: <superuser required> Chassis: type: 10 v: Mac-35C1E88140C3E6CF

serial: <superuser required>

Mobo: Apple model: Mac-35C1E88140C3E6CF v: MacBookAir6,1

serial: <superuser required> UEFI: Apple v: 429. date: 12/02/2020


ID-1: BATO charge: 7.7 Wh (21.9%) condition: 35.1/35.1 Wh (100.0%)

volts: 6.9 min: 7.5 model: SMP bq20z451 type: Li-ion serial: N/A

status: discharging cycles: 12


Info: model: Intel Core i5-4250U bits: 64 type: MT MCP arch: Haswell

gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm

family: 6 model-id: 0×45 (69) stepping: 1 microcode: 0x26

Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:

L1: 128 KiB desc: d-2x32 KiB; 1-2x32 KiB L2: 512 KiB desc: 2x256 KiB

L3: 3 MiB desc: 1x3 MiB

Speed (MHz): avg: 800 min/max: 800/2600 scaling: driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 15201 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4 1 sse4_2 ssse3 vmx

Vulnerabilities: <filter>


Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: 1915

v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:0a26

class-ID: 0300

Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2

compositor: kwin_x11 driver: X: loaded: modesetting

alternate: fbdev, intel, vesa dri: crocus gpu: 1915 display-ID: :0

screens: 1

Screen-1: 0 s-res: 1366×768 s-dpi: 96 s-size: 361×203mm (14.21×7.99")

s-diag: 414mm (16.31")

Monitor-1: eDP-1 model: Apple Color LCD built: 2011 res: 1366×768 hz: 60

dpi: 136 gamma: 1.2 size: 256×144mm (10.08×5.67") diag: 294mm (11.6")

ratio: 16:9 modes: 1366×768

API: EGL v: 1.5 hw: drv: intel crocus platforms: device : 0 drv: crocus device: 1 drv: swrast surfaceless: drv: crocus x11: drv: crocus

inactive: gbm,wayland

: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2


glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 5000 (HSW GT3) device-ID: 8086:0a26 memory: 1.46 GiB unified: yes


Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: Intel

HD Graphics 5000 (HSW GT3) driver: mesa intel v: 23.2.1-arch1.2 device-ID: 8086:0a26 surfaces: xcb, xlib device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib


| Device-1: Intel Haswell-ULT HD Audio vendor: Apple driver: snd_hda_intel

Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel

bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403

Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480

API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A

Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse

status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin

4: Network:

pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1

bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280

IF: wlp3s0 state: dormant mac: <filter>


Device-1: Apple [] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s

lanes: 1 mode: 1.1 bus-ID: 1-3.3:6 chip-ID: 05ac:828f class-ID: fe01

Report: btmgmt ID: hcio rfk-id: 1 state: down bt-service: enabled, running rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6

status: discoverable: no pairing: no


Local Storage: total: 113 GiB used: 4.75 GiB (4.2%)

SMART Message: Unable to run smartctl. Root privileges required.

ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD TS0128F size: 113 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0704 scheme: GPT


ID-1:/raw-size: 112.7 GiB size: 112.7 GiB (100.00%) used: 4.75 GiB (4.2%)

fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) dev/sda1 maj-min: 8:1

used: 576 KiB (0.2%) fs: vfat dev: / ID-3: /home raw-size: 112.7 GiB size: 112.7 GiB (100.00%)

used: 4.75 GiB (4.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-4: /var/log raw-size: 112.7 GiB size: 112.7 GiB (100.00%) used: 4.75 GiB (4.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2

ID-5: /var/tmp raw-size: 112.7 GiB size: 112.7 GiB (100.00%) used: 4.75 GiB (4.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2


Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no

ID-1: swap-1 type: zram size: 3.77 GiB used: 0 KiB (0.0%) priority: 100

comp: zstd avail: lzo, lzo-rle, lz4, lz4hc, 842 max-streams: 4 dev: /dev/zramo


System Temperatures: cpu: 70.0 C mobo: N/A

Fan Speeds (rpm): N/A


Processes: 190 Uptime: Om wakeups: 2 Memory: total: 4 GiB available: 3.77 GiB used: 1.41 GiB (37.3%) Init: systemd v: 254

default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: pm: pacman pkgs: 1186 libs: 350 tools: octopi, paru Shell: fish v: 3.6.1

running-in: konsole inxi: 3.3.30

Garuda (2.6.17-1):

System install date: 2023-09-27

Last full system update: 2023-09-27

Is partially upgraded:

Relevant software:

Windows dual boot:

Failed units:



snapper NetworkManager dracut

Welcome :slight_smile:

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

Did you search in forum?
Did you use garuda-update in terminal?
Did you use the last working snapshot?

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


Reinstalling Garuda and updating it worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.