Wired connection can only connect with Google website (YouTube, Google, etc), but can't connect with anything else

I installed Garuda (lovin it by the way, way better than ubuntu) and since then only Google websites can be reached, I’m using mozila, brave, chromium, all browsers have the same issue.
I tried to change the DNS with Garuda assistant with the “choose DNS service” to other than default, but when I do it, nothing connects, not even YouTube.
Tried to change the configurations of the Ethernet, nothing works.

Made a factory reset of the config on my modem, no success.

I can ping “www.google.com”, but can’t ping 8.8.8.8, I’m two days trying to solve this, but nothing works

Garuda-inxi bellow:


System:
Kernel: 6.8.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c7c7886b-0a07-4748-bfd1-8c67125c53a0 rw rootflags=subvol=@
quiet resume=UUID=f4de0268-1acb-48aa-b95a-075c5b447eb4 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B450M Steel Legend
serial: <superuser required> uuid: <superuser required>
UEFI: American Megatrends v: P4.60 date: 10/20/2022
CPU:
Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3800 min/max: 2200/4409 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800 3: 3800
4: 3800 5: 3800 6: 3800 7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800
bogomips: 91197
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate]
vendor: Micro-Star MSI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: none off: DP-3,HDMI-A-1 empty: DP-1,DP-2
bus-ID: 07:00.0 chip-ID: 10de:2488 class-ID: 0300
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia d-rect: 3286x1848
display-ID: 0
Monitor-1: DP-3 pos: primary,top-left res: 1920x1080 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: bottom-r res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
x11: drv: zink inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
memory: 7.81 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 7 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3070 driver: nvidia v: 550.78 device-ID: 10de:2488
surfaces: xcb,xlib,wayland
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 10de:228b
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.8.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8168 v: 8.053.00-NAPI modules: r8169 pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Info: services: NetworkManager,systemd-timesyncd
Drives:
Local Storage: total: 931.52 GiB used: 16.49 GiB (1.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SBI02102 temp: 39.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3500418AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: CC46 scheme: MBR
Partition:
ID-1: / raw-size: 448.37 GiB size: 448.37 GiB (100.00%)
used: 16.49 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 448.37 GiB size: 448.37 GiB (100.00%)
used: 16.49 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 448.37 GiB size: 448.37 GiB (100.00%)
used: 16.49 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 448.37 GiB size: 448.37 GiB (100.00%)
used: 16.49 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 55.2 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB available: 15.54 GiB used: 1.78 GiB (11.5%)
Processes: 341 Power: uptime: 0m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.17 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1934 libs: 570 tools: gnome-software, octopi,
pamac, paru Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-03
Last full system update: 2024-05-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

There are other devices connected to your modem? if yes, do they navigate normally?
Did you try to set other DNS services directly on the router? (such as open dns: 208.67.222.222 . 208.67.220.220 .)

All cellphones and devices are working normally. I tried some things that I saw online, the first was trying to use the OpenDNS to solve it, but didn’t worked, maybe I did it wrong, I don’t know, I’m not a experienced Linux user

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Just edit your first post :slight_smile:

3 Likes

Welcome to the forum. :wave:

Are you using a static IP address?

If so, set “method” to “automatic” in Network Manager’s IPv4 connection properties.

Set IPV6 to ignore in Network Manager.

3 Likes

I’m using automatic for both ipv4 and ipv6, when I set ipv6 to ignore, the wired connection it’s recognized, but without internet (can’t ping even Google.com)

Any suggestions?

Have you tried the r8168 driver instead of the r8169 driver?

2 Likes

How can I do this downgrade? I was using Tor browser in Ubuntu, before changing to Garuda, can the Tor connection affected all this?

No downgrade, blacklist 8169, search in forum.

1 Like

Use either pacman or your package manager (Octopi?) to search for that driver.

1 Like

Did it, nothing changed, tried all 3 options avaliable on Octopi.

So I downloaded via Octopi the Tor browser, and with the Tor connection, all websites work again.

It’s weird because Octopi and terminal commands can make downloads, but my Discord and Lutris applications for example, can’t update or download anything when I open them.

Can you load up a live instance of garuda and test internet connectivity and access to sites?
If you can connect it is settings in garuda if not it is your router settings

4 Likes

I loaded a live instance of Garuda, couldn’t connect using the FireDragon browser, not even the terminal ping worked

Then please check your router and your cables, ie reboot your router with your pc off , then restart your pc

2 Likes

Plugged and unplugged all cables from the router to the pc. Restarted the modem and checked all cables, all devices connected to modem working properly (Can only write here by cellphone btw). Rebooted the PC. Same status for everything.

Can other devices in your home connect to the internet through the router?

2 Likes

Computer firewall off?

Do you have customized rules in your router?

Reset your router back to the factory default.

Test a new Ethernet cable, and switch ports on your router.

Test an Ubuntu live disk to see if things are working correctly in that live environment.

2 Likes

Yes, all working normally

Firewall off, I reset the router yesterday, will do it again

The last thing that i can suggest is you download another live usb of another distro to check your internet on your pc? btw check if you have an update for your bios

1 Like