Wine crashing due to missing plugins

Hi there. i've recently made a switch from windows 11 and I am new to how things work here.
I wanted to play warcraft 3, but when opening it with wine, it crashes.

  • The game opens
  • Screen goes black
  • Game minimizes
  • Wine crashes
  • The color of the whole screen turns grey-ish.

In the wine output it says this.

(wine:4547): GStreamer-CRITICAL **: 07:47:05.096: gst_object_unref: assertion'object != NULL' failed
winegstreamer error: decodebin1: Your GStreamer installation is missing a plug-in.
winegstreamer error: decodebin1: ../gstreamer/subprojects/gst-plugins-base/gst/playback/gstdecodebin2.c(4701): gst_decode_bin_expose (): /GstBin:bin2/GstDecodeBin:decodebin1:
no suitable plugins found:
Missing decoder: Audio Video Interleave (AVI) (video/x-msvideo)

How do I go about installing these plugins? How do I fix this error?

It may help if we have your

garuda-inxi

as stated in the forum template

4 Likes

Probably try installing from aur

lib32-gst-plugins-bad
lib32-gst-plugins-ugly
lib32-gst-libav
4 Likes

Hi there, welcome to the forum!
Instead of launching directly from wine, maybe you'd better leverage on a frontend app like Lutris.
In general, give a look here:

3 Likes

Speaking of frontend apps, bottles just got updated with a new default runner that uses Proton, GE, and TKG patches called "Soda" Release Day 2022.7.14 β‹… Bottles
Blizzard's Battle net is listed as Gold in its app list, btw AppStore β‹… Bottles

1 Like

HI, thanks for the fast replies! Much appreciated.
Here is my inxi file log

System:
Kernel: 5.18.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ea07dd1f-2cbd-470f-81c7-8fa5c58d3792 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Vostro 15 3510 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0V799W v: A00 serial: <superuser required> UEFI: Dell
v: 1.12.1 date: 04/27/2022
Battery:
ID-1: BAT0 charge: 39.9 Wh (99.0%) condition: 40.3/40.0 Wh (100.7%)
volts: 13.2 min: 11.2 model: SWD DELL FH3K216 type: Li-poly
serial: <filter> status: charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
arch: Tiger Lake built: 2020 process: Intel 10nm family: 6
model-id: 0x8C (140) stepping: 1 microcode: 0xA4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 863 high: 1073 min/max: 400/4200 scaling:
driver: intel_pstate governor: powersave cores: 1: 729 2: 741 3: 843
4: 1006 5: 862 6: 1073 7: 712 8: 941 bogomips: 38707
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a49
class-ID: 0300
Device-2: NVIDIA GP107M [GeForce MX350] vendor: Dell driver: nouveau
v: kernel non-free: 515.xx+ status: current (as of 2022-06) arch: Pascal
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1c94 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-6:3 chip-ID: 0c45:6d1a class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x097d built: 2020 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.3
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
Sound Server-1: ALSA v: k5.18.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 26.92 GiB (11.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 NVMe WDC 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 21113012 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 26.92 GiB (11.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 26.92 GiB (11.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 26.92 GiB (11.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 26.92 GiB (11.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.37 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 44.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 242 Uptime: 1h 22m wakeups: 4294 Memory: 15.37 GiB
used: 2.83 GiB (18.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages:
note: see --pkg apt: 0 pacman: 2921 lib: 461 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19
error: could not register 'chaotic-aur' database (database already registered)
Garuda (2.6.5-1):
System install date:     2022-07-12
Last full system update: 2022-07-14
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Oh yes, I wanted to do that, but I didn't know how to. This doesn't find the package.

sudo pacman -S lib32-gst-plugins-bad 

It is an AUR package, so you need an AUR helper (paru is the default):

paru lib32-gst-plugins-bad 

You'll be presented with a PKGBUILD preview: check it, and quit with 'q', then confirm that you want to install the package(s)

3 Likes

I am greeted with this error when trying to run that command.

[email protected] in /homeπŸ”’ as πŸ§™ took 2ms
╰─λ paru lib32-gst-plugins-bad
error: failed to initialize alpm: root=/ dbpath=/var/lib/pacman/: database already registered

Sorry for being a total newby

Also, I am constantly getting this error when running any pacman command

error: could not register 'chaotic-aur' database (database already registered)

No need to be sorry, this is all strange.
Do you happen to have other terminal sessions open with pacman? Or have you tried after a reboot?
If this persists, I think you should try resetting your pacman configuration with:

garuda-update remote fix
4 Likes

The pacman and paru issues seem to have been fixed after running that command and rebooting the PC. I will try to install the missing packaged now as instructed.

1 Like

Oh my God fellas. I really felt like I wouldn't be able to fix this, ever, since I've been tinkering on my own for the past 2 days.
Everything works now
Thanks a lot! I really hope to stick with garuda for the coming days.
<3

2 Likes

Also, one question. Where can i learn more about using linux, how it works, etc..?
Or do I learn like this, by resolving the encountered issues. Do you have any good channels to recommend / guides?

You mean years, right :slight_smile:

Start with reading the Garuda Wiki.
Learn to search, start in whoogle questions with, Arch Linux.

BTW, do not post like in a chat, you can edit your last post until somebody answers. :slight_smile:

4 Likes

Start familiarizing with:
https://wiki.garudalinux.org/en/home
and (especially) with:
https://forum.garudalinux.org/t/faq-and-tutorials-table-of-contents/2962
Then, step-by-step, depending on the topics you want to better understand (or learn from scratch):
https://wiki.archlinux.org/
Warning: the latter is addictive :wink:

5 Likes

Alright, gotcha. Thanks :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.