Windoze interfering with Wifi

Hey @tbg I too have a wifi issue. I made a dual boot with windows and kde lite but when ever I open windows and back to linux the wifi is not recognised. I have to wait or restart a no. of times to get my wifi back on linux. I do not find any toggle button for wifi as no wifi icon there.
I don't have this issue on windows and I have updated the system.

Can you please help me here.

❯ inxi -Fxxxza                                ⇣0 B/s ⇡0 B/s 192.168.42.4   223.230.149.177   65%  ─╯
System:    Kernel: 5.8.14-zen1-1-zen x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=4adb250b-7c24-48b8-a1c6-5dc57c849ede rw [email protected] quiet splash loglevel=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Laptop System: ASUSTeK product: VivoBook 15_ASUS Laptop X507UF v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X507UF v: 1.0 serial: <filter> UEFI: American Megatrends v: X507UF.305 
           date: 07/17/2019 
Battery:   ID-1: BAT0 charge: 13.8 Wh condition: 21.3/33.3 Wh (64%) volts: 11.1/11.1 
           model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging cycles: 681 
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: A (10) microcode: D6 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
           Speed: 1596 MHz min/max: 400/1600 MHz Core speeds (MHz): 1: 1596 2: 1577 3: 1586 4: 1577 
           5: 1593 6: 1543 7: 1580 8: 1575 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GM108M [GeForce MX130] vendor: ASUSTeK driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:174d 
           Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus ID: 1-6:3 
           chip ID: 13d3:5a11 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting 
           alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.8.14-zen1-1-zen 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: N/A modules: iwlwifi port: e000 bus ID: 02:00.0 
           chip ID: 8086:24fd 
           IF-ID-1: enp0s20f0u1 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 16.92 GiB (1.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Samsung model: ST1000LM035-1RK172 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM4 
           scheme: GPT 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 
           bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition: ID-1: / raw size: 230.00 GiB size: 230.00 GiB (100.00%) used: 16.92 GiB (7.4%) fs: btrfs 
           dev: /dev/sda7 
           ID-2: /home raw size: 230.00 GiB size: 230.00 GiB (100.00%) used: 16.92 GiB (7.4%) fs: btrfs 
           dev: /dev/sda7 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4 
           ID-2: swap-2 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-6: swap-6 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-7: swap-7 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-8: swap-8 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-9: swap-9 type: zram size: 244.9 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3000 
Info:      Processes: 302 Uptime: 3m Memory: 7.65 GiB used: 1.76 GiB (23.0%) Init: systemd v: 246 
           Compilers: gcc: 10.2.0 Packages: pacman: 1210 lib: 296 flatpak: 0 Shell: Zsh v: 5.8 
           running in: konsole inxi: 3.1.06

@kunalgaurav4 Please use ~~~ in first and last raw of terminal output if </> not work correct.

This isn't really a solution but I'm curious. If you don't reboot..but actually shut the machine down, does it make your wifi reliably work?
I once had an issue that was the reverse, something (I think was my sound card?) only worked if I rebooted after booting Windows (so long ago I don't remember particulars). I understand the logic of why my issue was (not properly initialized device)..yours being the opposite kinda mystifies me.

1 Like

Hi there @kunalgaurav4.

I split this post off from the WiFi help request where you initially posted, as the issues are unrelated. Please don't post dissimilar issues on a thread someone else has opened for assistance. This only muddies the waters and leads to confusion when multiple people are dealing with completely different issues on the same thread.

Generally this occurs because Windoze disables the Wifi adapter as a power saving measure. This often persists after a reboot into Linux, where you then find a disabled WiFi adapter. Windoze used to allow you to easily turn this power saving feature off. Unfortunately, this is no longer possible as Windoze has decided that they should rightly rule the roost.

There are some possibilities you could try:

Reboot into your bios, and try to turn your wifi on via the bios.

It's possible this could be the result of the WiFi driver being loaded in the wrong order (drivers conflicting at boot). Try unloading and reloading your wifi driver module after booting to Linux.

It's also possible this problem could be fixed by updating your bios.

Testing alternate firmware versions might be another avenue worth investigating.

Try some of those suggestions and let me know how you make out.

4 Likes

Yup sorry that I posted my issue on other's.I felt it to be similar wifi issue,my bad.

Previously i had updated my firmware and bios but perhaps they were not the solution in my case.
As you said that the window disables the wifi adapter after turning it off.

So i turned off the setting under Device Manager Power Management tab to not allow the computer to turn of this device to save power.
I rebooted my system a couple of time from window to linux and vice versa and till now the adapters are working fine.

Hope it works perfectly from now.

3 Likes

Well that's good news. I don't run Windoze, so I thought that there was still no option to disable wifi power saving within Windoze.

Thanks for letting me know it is possible to disable, because my fingers rarely ever touch a Win10 computer.

4 Likes