Windows buttons and aplication launcher keyboard shortcut

I'm using kde garuda without latte.
How to enable minimize, maximize and close buttons in all windows.
How to change the shortcut so when i click "meta"(windows key) the application launcher opens, it did it with the latte but now i can't find where is the setting.
Thanks in advance.

Summary

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

System:
  Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=494c3292-05c2-4453-b3d6-32ea426b1eef rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING Z490-PLUS v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2210
    date: 01/15/2021
CPU:
  Info: model: Intel Core i7-10700KF bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xEC
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 5114 high: 5168 min/max: 800/5100 scaling:
    driver: intel_pstate governor: performance cores: 1: 5099 2: 5148 3: 5096
    4: 5066 5: 5121 6: 5096 7: 5155 8: 5091 9: 5153 10: 5100 11: 5168
    12: 5100 13: 5078 14: 5104 15: 5120 16: 5137 bogomips: 121596
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: Micro-Star MSI
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:2484 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1080 s-dpi: 81 s-size: 803x343mm (31.6x13.5")
    s-diag: 873mm (34.4")
  Monitor-1: DP-0 res: 2560x1080 hz: 144 dpi: 81
    size: 798x334mm (31.4x13.1") diag: 865mm (34.1")
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:228b
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4d class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-9:9 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 216.36 GiB (9.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: EXCERIA PLUS SSD
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFA10.4
    temp: 22.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 61.89 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 61.89 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 61.89 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 61.89 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.51 GiB used: 2.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 42 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 368 Uptime: 1h 17m wakeups: 0 Memory: 15.52 GiB
  used: 4.54 GiB (29.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1476 lib: 443 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.12
Garuda:
  System install date:     2022-01-21
  Last full system update: 2022-01-30
  Is partially upgraded:   No
  Using TLP:               No
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.
I just fix it.
thanks i didn't know that.

System Settings -> Windows Decorations -> Titlebar Buttons tab.

First you should make sure Latte isn't in the auto start at all, and then reboot. If the issue persists, check your System Settings -> Shortcuts for conflicts.

2 Likes

Sorry I mean the buttons when it's maximazed.

I don't find where to do it, I don't know how to make a shortcut for the application. I search for conflicts but its doesn't appear. Also i can't put meta alone.

right click on application launcher > configure application launcher > keyboard shortcut > you know the rest

Thanks, but i can't just put 1 key (meta) :frowning:

Right click on Latte> Configure Latte > Preferences > tik on 'press meta to activate application launcher'

I don't have latte

Run in terminal

kwriteconfig --file kwinrc --group Windows --key BorderlessMaximizedWindows false

Re-login to see effect.

Explanation

This command changes the relevant setting in $HOME/.config/kwinrc

Search in Settings > Keyboard shortcuts for the Alt + F1 combination. It maybe set to Latte (old config). Unset it and try Super key. Or set the Menu shortcut to Alt + F1.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.