Window buttons disappear in maximize

I know this question has been asked many times, but it seems like something has changed.

Latedock is not installed on my system, when I maximize my window my winow buttons disappear.
I want the to be always visible in the topbar of the application, every solution I can find says that it’s a setting in latedock, but this is not installed on my clean install.

Hi there, welcome to the forum.
Please always provide your garuda-inxi, as requested in the template.

I don’t exactly know what that is, but I found this and it seems like something usefull :smile:

System:
  Kernel: 6.6.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e84bfb02-d2f1-4dd9-ab98-c951bfd4fab3 rw rootflags=subvol=@ quiet
    resume=UUID=973a9382-636a-495b-88ed-cf80f88e9793 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: MEDION product: MD34190/2589 v: N/A serial: <superuser required> Chassis:
    type: 3 serial: <superuser required>
  Mobo: MEDION model: B550A4-EM v: 1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: 550A4W0X.101 date: 07/09/2019
CPU:
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2 level: v3 note: check
    built: 2018-21 process: GF 12nm family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 576 KiB
    desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 2015 high: 3892 min/max: 1550/3400 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 3361 2: 1550 3: 1550 4: 1550 5: 1550 6: 1550
    7: 3088 8: 1478 9: 1509 10: 3892 11: 1552 12: 1551 bogomips: 81437
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Micro-Star MSI driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of 2023-10; EOL~2026-12-xx)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s
    lanes: 8 link-max: lanes: 16 ports: active: none off: HDMI-A-1 empty: DVI-D-1 bus-ID: 0c:00.0
    chip-ID: 10de:1f82 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.10 with: Xwayland v: 23.2.3 compositor: kwin_wayland
    driver: X: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia
    display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia gbm: drv: nvidia surfaceless:
    drv: nvidia wayland: drv: nvidia x11: drv: zink
  API: OpenGL v: 4.6.0 compat-v: 4.6 vendor: nvidia v: 545.29.06 glx-v: 1.4 direct-render: yes
    renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 memory: 3.91 GiB display-ID: :1.0
  API: Vulkan v: 1.3.274 layers: 3 device: 0 type: discrete-gpu name: NVIDIA GeForce GTX 1650
    driver: nvidia v: 545.29.06 device-ID: 10de:1f82 surfaces: xcb,xlib,wayland
Audio:
  Device-1: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 0c:00.1 chip-ID: 10de:10fa class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: MEDION AG driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0e:00.3 chip-ID: 1022:1457 class-ID: 0403
  API: ALSA v: k6.6.8-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: MEDION AG
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 0b:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp11s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-11:7 chip-ID: 8087:0029 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2 lmp-v: 11 status:
    discoverable: no p
airing: no class-ID: 7c0104
Drives:
  Local Storage: total: 1.14 TiB used: 20.42 GiB (1.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Phison model: E12-256G-SSD-B3-BB1 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: ECFM12.3 temp: 25.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q
    scheme: MBR
Partition:
  ID-1: / raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 20.42 GiB (8.9%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /home raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 20.42 GiB (8.9%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /var/log raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 20.42 GiB (8.9%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-4: /var/tmp raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 20.42 GiB (8.9%) fs: btrfs
    dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: swap-2 type: zram size: 7.68 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 40.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 390 Uptime: 29m wakeups: 0 Memory: total: 8 GiB available: 7.68 GiB
  used: 3.54 GiB (46.1%) Init: systemd v: 255 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: 1474 pm: pacman pkgs: 1466 libs: 418 tools: octopi,paru pm: flatpak pkgs: 8
  Client: shell wrapper v: 5.2.21-release inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-01
  Last full system update: 2024-01-01
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       <superuser required>
  Failed units:            

Try this please

I’m on the mobile phone and don’t remember if this is valid also for wayland sessions, but I guess so.
If not, please try selecting an x11 session at login.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.