Wifi speed unusably slow

I’m getting painfully slow wifi speeds on this Garuda installation. For the details,

  1. I haven’t changed any settings, installed any apps or packages that might hamper with the wifi.
  2. I had updated it twice by now from the Garuda Assistant. The issue appeared much before that.
  3. I only have Garuda installed on this machine.
  4. This issue occurs only on the wifi and not on ethernet/USB tethering from my phone.
  5. The speeds I could get before wire within the range of 6.5MiB/s to 7.3 MiB/s. Now it is maximum at 280KiB/s
  6. I have been searching about the issue for 6 days now, but none of them worked.
  7. I can ping google.com,,, etc. I can open only several websites. Also, Youtube doesn’t actually open but other websites that I can open and that contain Youtube videos playing in them can be played.
  8. Connection strength is full.

Now the inxi

Kernel: 6.9.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dcbe7884-5cef-4a80-a184-d5b621600b37 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
Distro: Garuda base: Arch Linux
Type: Desktop Mobo: N/A model: ZRD1105 v: REV V52.9 serial: N/A
uuid: 03000200-0400-0500-0006-000700080009
UEFI-[Legacy]: American Megatrends v: 5.12 date: 02/15/2023
Info: model: Intel Core i3-7100 socket: LGA1151 (U3E1) note: check bits: 64
type: MT MCP arch: Kaby Lake gen: core 7 level: v3 note: check built: 2018
process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 9
microcode: 0xF8
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 3899 high: 3901 min/max: 800/3900 base/boost: 3900/8300
scaling: driver: intel_pstate governor: powersave volts: 1.0 V
ext-clock: 100 MHz cores: 1: 3899 2: 3901 3: 3898 4: 3900 bogomips: 31199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 630 driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: HDMI-A-1
empty: DP-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5912 class-ID: 0300
Display: server: X.Org v: 24.1 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
s-diag: 583mm (22.95")
Monitor-1: HDMI-A-1 model-id: GVE 0x2513 serial: <filter> built: 2023
res: 1920x1080 hz: 75 dpi: 83 gamma: 1.2 size: 590x330mm (23.23x12.99")
diag: 676mm (26.6") ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 630 (KBL GT2)
device-ID: 8086:5912 memory: 7.5 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: Intel
HD Graphics 630 (KBL GT2) driver: mesa intel v: 24.0.7-arch1.3
device-ID: 8086:5912 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel
v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a170
class-ID: 0403
API: ALSA v: k6.9.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.6 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
IF-ID-1: wlan1 state: up mac: <filter>
Info: services: iwd, NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter driver: btusb,rtl8xxxu
type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1:7
chip-ID: 0bda:b720 class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 762.83 GiB used: 211.22 GiB (27.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 11004101 temp: 41.9 C
scheme: GPT
SMART: yes health: PASSED on: 56d 7h cycles: 2,121
read-units: 68,877,639 [35.2 TB] written-units: 56,301,830 [28.8 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD5000LPVX-22V0TT0 family: Blue Mobile size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: HDD
rpm: 5400 serial: <filter> fw-rev: 1A01 temp: 34 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 300d 22h cycles: 7461
Old-Age: g-sense error rate: 110
ID-3: /dev/sdb maj-min: 8:16 model: USB Disk 2.0 size: 58.59 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 2.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 160 GiB size: 160 GiB (100.00%) used: 69.53 GiB (43.5%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /home raw-size: 160 GiB size: 160 GiB (100.00%)
used: 69.53 GiB (43.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-3: /var/log raw-size: 160 GiB size: 160 GiB (100.00%)
used: 69.53 GiB (43.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/tmp raw-size: 160 GiB size: 160 GiB (100.00%)
used: 69.53 GiB (43.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.68 GiB used: 208.8 MiB (2.7%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 44.0 C pch: 52.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 8 GiB available: 7.68 GiB used: 3.92 GiB (51.1%) igpu: 32 MiB
Processes: 259 Power: uptime: 1h 8m states: freeze,mem,disk
suspend: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 3.06 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1758 libs: 519 tools: octopi,pamac,paru,yay
Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi (sudo) default: Bash
v: 5.2.26 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-24
Last full system update: 2024-05-23
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Please inform if any information is missing.

Not necessarily the cause of your issue, but I think you should start fixing this. With a:


it have some issues with bluetooth is activated in win10 i know but i dont know on Garuda.What happens if you turn Bluetooth off?

Try installing the linux-lts kernel and headers and select it on the GRUB menu under advanced options.

1 Like

Done. Still no luck

Before that, I need some answers.

  1. Will it change any of my customisations?
  2. What effect does it have on gaming performance?
  3. What are the overall changes?

Also, I just now hooked up a spare SSD with windows in it and booted it. Tried the Wi-Fi on that one and after some tests, it didn’t work on that either. So I think I can safely conclude that it is indeed the Wi-Fi adapter which is faulty.

And @Duke187, I will run those tests with BT off on windows later as on Garuda it didn’t work.

No. Of course, “customisation” is a bit general, but I don’t see any risk there.

It could decrease, since the zen kernel (see below) is aimed to performance optimization, but on “normal” machines I never really noticed the difference.

I can only answer with their official list :slight_smile:

Don’t ask me anything about it :wink:

1 Like

Have you installed/tested the rtl8723bu-git-dkms driver package?

If not, you should definitely test it out.

Reboot after the driver installation is complete.

Be sure to test this driver with alternate kernels such as the LTS, hardened, and the mainline kernels.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.