Wifi password repeatedly requested

I got garuda for a while now rather new to linux, and first time I used a wlan connection. And this is really annoying so far. You setup some Wallet pick the default that does not require further config and so and then on each login the passwords is required again. Why not have a preferred usability, no device ever asks each time for the wlan password… That wallet thing so far been time consuming, had to disable it on my other pc for now.
My mistake was using a different password for wallet, guess I got some reading to do.

It now also works with encrypted for user.

1 Like

Try this:

Select your WiFi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.


Storing your password unencrypted is a slight security risk if others have physical access to your computer.

There is a possibility others who use your computer may be able to find your WiFi login credentials if it is not encrypted.

Also if you do not already have it installed, it might be advisable to install “nm-connection-editor” and enter your password for your connection directly from within that utility. After installation start NMCE with the command “nm-connection-editor” via the terminal.


Also, be sure to Disable MAC Address Randomization


I had to create a separate thread for your issue as it is our forums policy to not simply tack your own issue onto another year old thread.

Please post the output of the garuda-inxi command if you require further assistance.

Welcome to the Garuda forum @SolidBrave.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.