WiFi not working properly

Hello everyone.

I hope my effort to search for an answer on the already existing threads was thorough enough, in case it wasn't, I am ready to take the blame!

So I installed Garuda a few days ago, and everything was going pretty well. I didn't do anything weird that would cause any crashes, but when I rebooted into windows to check something and the booted back into Garuda, my WiFi is not able to find any networks. The network manager shows my wifi as enabled, airplane mode off but there are no networks to connect to.

At the moment I am unfortunately not able to connect to a network with an ethernet cable and I dont have an android phone to use and connect to the internet this way.

What I have tried so far, is resetting the wifi adapter via the network manager gui, with no success. Also, the drivers in the network manager gui are the correct ones, the ones that worked before the issue arose.

I also used snapper to revert back to an older snapshot, that also didnt work.

Below you can find my system info.

  Kernel: 6.1.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=84822e74-7f88-40b3-a85d-503a00163e07
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=6024eb51-e351-4074-a7e4-a70dd0e499be loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81UJ v: Lenovo Legion Y740-17IRHg
    serial: <superuser required> Chassis: type: 10 v: Lenovo Legion Y740-17IRHg
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <superuser required> UEFI: LENOVO
    v: BVCN16WW(V1.12) date: 06/21/2021
  ID-1: BAT1 charge: 69.4 Wh (100.0%) condition: 69.4/76.0 Wh (91.3%) volts: 17.4 min: 15.4
    model: SMP L17M4PG2 type: Li-ion serial: <filter> status: full cycles: 99
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4080 high: 4102 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4053 2: 4100 3: 4101 4: 4095 5: 4044 6: 4095 7: 4045 8: 4099
    9: 4099 10: 4102 11: 4097 12: 4035 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU106BM [GeForce RTX 2070 Mobile / Max-Q] vendor: Lenovo driver: nvidia
    v: 525.85.05 alternate: nouveau,nvidia_drm non-free: 525.xx+ status: current (as of 2022-12)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f50 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 1-7:7
    chip-ID: 13d3:56a6 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7 compositor: kwin_x11 driver: N/A
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 128 s-size: 889x281mm (35.00x11.06") s-diag: 932mm (36.71")
  Monitor-1: DP-4 pos: bottom-l res: 1920x1080 hz: 144 dpi: 128 size: 382x214mm (15.04x8.43")
    diag: 438mm (17.24") modes: N/A
  Monitor-2: DP-5 pos: primary,top-right res: 2560x1440 dpi: 65024 size: 1x1mm (0.04x0.04")
    diag: 1mm (0.06") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX 2070 with Max-Q
    Design/PCIe/SSE2 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Sound API: ALSA v: k6.1.9-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 3f:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp63s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 40:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp64s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:9 chip-ID: 8087:0029
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
  Local Storage: total: 2.33 TiB used: 16.57 GiB (0.7%)
  SMART Message: Unable to run smartctl. Root p
rivileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN720 SDAPNTW-512G-1101
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 10130001 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: A-Data model: SU800 size: 1.86 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 7A scheme: GPT
  ID-1: / raw-size: 131.71 GiB size: 131.71 GiB (100.00%) used: 16.57 GiB (12.6%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 512.9 MiB size: 511.9 MiB (99.80%) used: 612 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-3: /home raw-size: 131.71 GiB size: 131.71 GiB (100.00%) used: 16.57 GiB (12.6%) fs: btrfs
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 131.71 GiB size: 131.71 GiB (100.00%) used: 16.57 GiB (12.6%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 131.71 GiB size: 131.71 GiB (100.00%) used: 16.57 GiB (12.6%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p4
    maj-min: 259:4
  System Temperatures: cpu: 70.0 C pch: 64.0 C mobo: N/A gpu: nvidia temp: 63 C
  Fan Speeds (RPM): N/A
  Processes: 295 Uptime: 7m wakeups: 1 Memory: 15.54 GiB used: 2.29 GiB (14.7%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1554
  libs: 472 tools: octopi,pamac,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2023-02-02
  Last full system update: 2023-02-05
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            nmb.service

Any help would be greatly appreciated. I want Garuda to work, I dont want to use a different distro.

Thanks in advance!

Hi there, welcome to the forum!

Did you reboot or shutdown and then power on again?
Warm boots are often causing this when dual booting. See e.g. here.

Try also with the forum searching features, e.g.
Here filtered by AX200, but you could also use the driver (iwlwifi).


Hello and thanks for the quick reply.

I did stumble upon this topic but I didn't see any solution, other than the fact that it magically fixed itself!

I have tried reboots, shutdowns, both quick and waited for a few minutes, without success. Even tried rebooting into windows and back to Garuda again. Also, the network assistant, as mentioned earlier, it looks like I am able to restart the wifi adapter, also it looks like I can enable and disable airplane mode, but none of it fixes the issue.

Thank you though for the tip to filter my searches only for my wifi adapter, would have saved me a lot of time!

EDIT: I am now going to try and re install the driver in windows (you never know) and reboot (shutdown and power on) into Garuda. Will come back with the result

1 Like

Remember to make sure you disable the wifi power saving options in Windows (and fast startup or how that's called).
Sometimes even just a boot from a live ISO could help "decoupling" from windows.


Reinstalled the driver, disabled power saving option, booted to Garuda… but it’s still not working.

Wi-Fi adapter is on, “No available connections” is displayed.

I will now boot from the live usb and see if that fixes anything.


Booted from the live usb. Everything is working.

Rebooted into Garuda and the issue is still there.

Also, fast boot is not enabled in my BIOS, never was. Secure boot was enabled, I disabled that as well, but that didn’t do anything, as expected.

EDIT: I will use my neighbors Ethernet connection and run a sys update. At this point I don’t think there’s anything I can do other than that… let’s see if this changes anything.

Take a chance to install also the linux-lts kernel and try using it, just to rule out possible recent kernel regressions (unlikely, in my opinion).
Maybe give a look also at this one and maybe this workaround.
Last but not least, try disabling MAC address randomization.

1 Like

Alright... Updated my system, restarted and in the network manager, after toggling both the airplane mode on and off, as well as the WiFi adapter, it now works.

I don't know what was the fix, why and how... But all I know is that it now works.

Looking at some of the links you provided @filo , in one of his replies, tgb suggests

Of course the best solution is to wipe Windows off your system and send it straight to hell (where it rightly belongs)

It seems like this is the way to go. At this point in time I am still early in my windows-rehab, but eventually I'll get there :smiley:

1 Like

Yes, that's why I called it "workaround" above, but luckily I found it, removing the "solved" flag in the search. :wink:



This may or maynot have any bearing on your situation, but I thought I'd throw it out here anyway...

Windows likes to "capture" hardware. I had that happen after I had initially wiped Windows and installed Arch on this 9th Gen. desktop machine. I realized I had no Bluetooth available in Arch. Yet I knew and my BIOS knew that BT was there and had worked under Windows.

I perused the Dell forums and saw that this had happened to a few others, yet Dell had no fix for it. The Arch forms and others yielded nothing either.

It wasn't until I more closely examined my BIOS settings that I saw that hardware discovery had been set to "Auto." (IIRC, it was part of fastboot.) When I changed that setting to make it always scan, suddenly my BT adapter was discovered by Linux. Even though Windows was no longer resident, the BIOS settings from Dell had affected what was discoverable.

Also, having multiple kernels kernels available, as noted by others, is always a good troubleshooting suggestion. :slight_smile:


If you are using Windows this can be very important, as some routers will block access from random MAC addresses. Be sure you reboot both your router and computer after this step.


If this happens again, I will definitely do it @tbg . I hope though that it wont.

Thanks a lot for the input as well @Bro , good thing to know.

For now it just feels super freaking awesome that everything is working again. Just some minor things I need to fix with peripherals now (G512 Keyboard, Razer mouse etc) and then the windows-rehab continues!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.