Wifi not working after update

Hello! Since this is my first post on this forum I think it's worth mentioning that I've been using Garuda for months now and I absolutely love it. Switched over from Kali and it's night and day. However, if I update I am no longer able to connect to wifi or my phone's hotspot. I just reverted to a previous snapshot and hoped it fixes itself...few weeks later and the issue persists. Should have made a note of the packages that were to be installed when there were only a few :slight_smile:
Here's what I tried & some info:

╭─[email protected] in ~ 
╰─λ sudo systemctl stop NetworkManager; sudo modprobe -r wl; sudo modprobe -r brcmfmac; sleep 3; sudo modprobe brcmfmac; sudo systemctl start NetworkManager
[sudo] password for f00d4w0rm5:           
modprobe: FATAL: Module wl not found.

modprobe: FATAL: Module wI not found.

modprobe: FATAL: Module w1 not found.

╭─[email protected] in ~ took 3s
╰─λ hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"
Model: "Intel Dual Band Wireless AC 3165"
Driver: "iwlwifi"
Device File: wlo1
Link detected: yes
Driver Status: iwlwifi is active
Driver Activation Cmd: "modprobe iwlwifi"
Model: "Realtek RTL810xE PCI Express Fast Ethernet controller"
Driver: "r8169"
Device File: enp1s0
Link detected: no
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Model: "Intel Bluetooth wireless interface"
Hotplug: USB
Driver: "btusb"
Speed: 12 Mbps
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"

╭─[email protected] in ~ took 3s
╰─λ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

### NetworkManager is enabled
╭─[email protected] in ~ took 13ms
[πŸ”΄] Γ— systemctl status NetworkManager
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
└─NetworkManager-ovs.conf
Active: active (running) since Wed 2021-06-16 07:38:58 EDT; 51s ago

### Tried starting anyway
╭─[email protected] in ~ took 3ms
╰─λ systemctl start NetworkManager

╭─[email protected] in ~ took 31ms
╰─λ ping google.com
ping: google.com: Name or service not known

### Tried restarting wifi module in network assistant and rebooting.

╭─[email protected] in ~ took 9s
╰─λ inxi -Fxxxza
System:    Kernel: 5.12.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f28c84f5-112c-41e6-b89a-7ecbf6eeff5e 
rw [email protected] quiet rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=7b66d236-4d06-4834-be53-b97df569c4e9 loglevel=3 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: <filter> Chassis: 
type: 10 serial: <filter> 
Mobo: HP model: 81F9 v: 67.40 serial: <filter> UEFI: Insyde v: F.24 date: 06/07/2017 
Battery:   ID-1: BAT1 charge: 26.7 Wh (100.0%) condition: 26.7/38.5 Wh (69.5%) volts: 16.6 min: 14.8 
model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Full 
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 serial: <filter> 
charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Quad Core model: AMD A10-9600P RADEON R5 10 COMPUTE CORES 4C+6G bits: 64 type: MCP 
arch: Excavator family: 15 (21) model-id: 65 (101) stepping: 1 microcode: 6006118 cache: 
L2: 1024 KiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19163 
Speed: 2566 MHz min/max: 1200/2000 MHz boost: enabled Core speeds (MHz): 1: 2566 2: 2178 
3: 2581 4: 2801 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] vendor: Hewlett-Packard driver: amdgpu v: kernel 
bus-ID: 00:01.0 chip-ID: 1002:9874 class-ID: 0300 
Device-2: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD type: USB driver: uvcvideo 
bus-ID: 2-1:2 chip-ID: 05c8:038f class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
OpenGL: renderer: AMD CARRIZO (DRM 3.40.0 5.12.10-zen1-1-zen LLVM 12.0.0) v: 4.6 Mesa 21.1.2 
direct render: Yes 
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403 
Device-2: AMD Family 15h Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403 
Sound Server-1: ALSA v: k5.12.10-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200 
IF: enp1s0 state: down mac: <filter> 
Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: 3000 bus-ID: 02:00.0 
chip-ID: 8086:3165 class-ID: 0280 
IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-1.4:4 
chip-ID: 8087:0a2a class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: 
hardware: no software: no address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 649.67 GiB (69.7%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q 
scheme: GPT 
Partition: ID-1: / raw-size: 914.57 GiB size: 914.57 GiB (100.00%) used: 649.67 GiB (71.0%) fs: btrfs 
dev: /dev/sda2 maj-min: 8:2 
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 546 KiB (0.2%) fs: vfat 
dev: /dev/sda1 maj-min: 8:1 
ID-3: /home raw-size: 914.57 GiB size: 914.57 GiB (100.00%) used: 649.67 GiB (71.0%) fs: btrfs 
dev: /dev/sda2 maj-min: 8:2 
ID-4: /var/log raw-size: 914.57 GiB size: 914.57 GiB (100.00%) used: 649.67 GiB (71.0%) 
fs: btrfs dev: /dev/sda2 maj-min: 8:2 
ID-5: /var/tmp raw-size: 914.57 GiB size: 914.57 GiB (100.00%) used: 649.67 GiB (71.0%) 
fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
ID-1: swap-1 type: partition size: 16.69 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
maj-min: 8:3 
ID-2: swap-2 type: zram size: 3.79 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 3.79 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 3.79 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 3.79 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 71.0 C mobo: 20.0 C gpu: amdgpu temp: 69.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 211 Uptime: 13m wakeups: 3 Memory: 15.17 GiB used: 3.31 GiB (21.8%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1723 lib: 372
Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

Welcome to Garuda.

The first thing to do whenever you experience an issue at update is to see if your kernel was updated. If the kernel was updated then it's possible a kernel change could have broken your wifi (as your iwlwifi driver is included in the kernel).

If the kernel was upgraded on the day your wifi broke then I would suggest testing alternate kernels. If required, I would suggest testing these kernels:

linux
linux-mainline
linux-next-git
linux-lts
linux-hardened

Your pacman log will include details on which packages were updated (and the dates). You should check this list to see which packages were upgraded on the day the breakage occurred.

The most likely culprits are NetworkManager, nm-applet, and the linux-firmware packages. These packages should be selectively downgraded one by one to test which may have been responsible. Be sure to reboot after any downgrade operation.

Start by downgrading NetworkManager
and then nm-applet (if required). I would suggest disabling timeshift auto snapshots until you have this issue resolved so that you do not overwrite your working backup timeshift snapshot.

Search the Garuda forum or the Arch Wiki for any information on downgrading (etc) you may be unsure about.

Good luck.

3 Likes

Thanks for your quick response! I ignored the following packages from being upgraded in /etc/pacman.conf, but after upgrading and rebooting the problem persists.

IgnorePkg = linux-headers linux-zen linux-zen-headers networkmanager-qt

I coudn't find nm-applet or any linux-firmware packages that needed to be upgraded. I'm not exactly sure what linux-firmware packages might look like but the only other package with the word linux in it was util-linux. I also searched for iwlwifi, r8169, btusb but none of them showed up in the packages to be upgraded either.

This means it has to be a problem with a different package right? Do you have any idea what package that might be?

I don't really expect anyone to read though all of this but here it is:

╭─[email protected] in ~ took 19ms
╰─λ sudo pacman -Syu
warning: config file /etc/pacman.conf, line 34: directive 'TotalDownload' in section 'options' not recognized.
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                                                            1106.9 KiB   912 KiB/s 00:01 [------------------------------------------------------------] 100%
blackarch is up to date
:: Starting full system upgrade...
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
warning: linux-headers: ignoring package upgrade (5.12.9.arch1-1 => 5.12.10.arch1-1)
warning: linux-zen: ignoring package upgrade (5.12.9.zen1-1 => 5.12.10.zen1-1)
warning: linux-zen-headers: ignoring package upgrade (5.12.9.zen1-1 => 5.12.10.zen1-1)
warning: networkmanager-qt: ignoring package upgrade (5.82.0-1 => 5.83.0-1)
resolving dependencies...
looking for conflicting packages...
warning: removing 'archlinux-appstream-data' from target list because it conflicts with 'archlinux-appstream-data-pamac'
:: archlinux-appstream-data-pamac and archlinux-appstream-data are in conflict. Remove archlinux-appstream-data? [y/N] y

Packages (382) accounts-qml-module-0.7-4  alacritty-git-0.9.0.1838.g6f135d71-1  alsa-card-profiles-1:0.3.30-2  alsa-lib-1.2.5.1-3  alsa-plugins-1:1.2.5-2
alsa-topology-conf-1.2.5.1-1  alsa-ucm-conf-1.2.5.1-1  aom-3.1.1-1  archlinux-appstream-data-20210423-1 [removal]
archlinux-appstream-data-pamac-20210612-1  archlinux-keyring-20210616-1  ark-21.04.2-1  at-spi2-core-2.40.2-1  attica-5.83.0-1  baloo-5.83.0-1
baloo-widgets-21.04.2-1  bluedevil-1:5.22.1-1  bluez-5.59-2  bluez-cups-5.59-2  bluez-hid2hci-5.59-2  bluez-libs-5.59-2  bluez-plugins-5.59-2
bluez-qt-5.83.0-1  bluez-utils-5.59-2  boost-libs-1.76.0-1  breeze-5.22.1-1  breeze-gtk-5.22.1-1  breeze-icons-5.83.0-1  burpsuite-1:2021.5.3-1
ca-certificates-20210603-1  ca-certificates-mozilla-3.67-1  ca-certificates-utils-20210603-1  ceph-libs-15.2.12-2  cewl-122.935c961-1
chaotic-keyring-20210615-1  chromium-91.0.4472.106-1  clang-12.0.0-1  clazy-1.9-3  colord-1.4.5-4  colord-sane-1.4.5-4  compiler-rt-12.0.0-1
cups-filters-1.28.9-1  dolphin-21.04.2-1  dolphin-plugins-21.04.2-1  drkonqi-5.22.1-1  encfs-1.9.5-5  enchant-2.2.15-4  ffmpeg-2:4.4-4
ffmpegthumbs-21.04.2-1  filelight-21.04.2-1  firedragon-89.0-1  firefox-89.0.1-1  flameshot-git-r1355.35a6d430-1  frameworkintegration-5.83.0-1
fuse-common-3.10.4-1  fuse3-3.10.4-1  fzf-0.27.2-1  garuda-assistant-git-r44.63496ea-1  garuda-boot-options-git-r24.e7d5838-1
garuda-common-settings-1.2.9-1  garuda-dr460nized-1.4.5-1  garuda-gamer-git-r21.c58fa71-1  garuda-hooks-1.0.5-2  garuda-setup-assistant-1.0.8-1
garuda-welcome-git-r108.007a45d-1  gd-2.3.2-3  git-2.32.0-1  glib2-2.68.3-1  gnutls-3.7.2-2  gptfdisk-1.0.8-1  grub-2:2.06-1  gupnp-1.2.7-1
gwenview-21.04.2-1  hdparm-9.62-1  hwids-20210613-1  hypnotix-1.8-1  imagemagick-7.1.0.0-1  imath-3.0.4-2  inetutils-2.0-1
intel-compute-runtime-21.21.19914-1  intel-gmmlib-21.1.3-1  intel-graphics-compiler-1:1.0.7423-2  intel-media-driver-21.2.1-1
intel-opencl-clang-12.0.0-1  jasper-2.0.32-1  jdk-openjdk-15.0.3.u3-1  joplin-desktop-1.8.5-1  jre-openjdk-15.0.3.u3-1  jre-openjdk-headless-15.0.3.u3-1
kaccounts-integration-21.04.2-1  kaccounts-providers-21.04.2-1  kactivities-5.83.0-1  kactivities-stats-5.83.0-1  kactivitymanagerd-5.22.1-1
kamera-21.04.2-1  kamoso-21.04.2-1  karchive-5.83.0-1  kate-21.04.2-1  kauth-5.83.0-1  kbookmarks-5.83.0-1  kcalc-21.04.2-1  kcalendarcore-5.83.0-1
kcmutils-5.83.0-1  kcodecs-5.83.0-1  kcompletion-5.83.0-1  kconfig-5.83.0-1  kconfigwidgets-5.83.0-1  kcontacts-1:5.83.0-1  kcoreaddons-5.83.0-1
kcrash-5.83.0-1  kcron-21.04.2-1  kdbusaddons-5.83.0-1  kde-cli-tools-5.22.1-1  kde-gtk-config-5.22.1-1  kdeclarative-5.83.0-1  kdeconnect-21.04.2-1
kdecoration-5.22.1-1  kded-5.83.0-1  kdegraphics-thumbnailers-21.04.2-1  kdelibs4support-5.83.0-1  kdenetwork-filesharing-21.04.2-1  kdenlive-21.04.2-1
kdeplasma-addons-5.22.1-1  kdesu-5.83.0-1  kdf-21.04.2-1  kdialog-21.04.2-1  kdnssd-5.83.0-1  kdoctools-5.83.0-1  keditbookmarks-21.04.2-1
kemoticons-5.83.0-1  kfilemetadata-5.83.0-1  kfind-21.04.2-1  kfiredragonhelper-5.0.6-1  kgamma5-5.22.1-1  kget-21.04.2-1  kglobalaccel-5.83.0-1
kguiaddons-5.83.0-1  khelpcenter-21.04.2-1  kholidays-1:5.83.0-1  khotkeys-5.22.1-1  khtml-5.83.0-1  ki18n-5.83.0-1  kiconthemes-5.83.0-1
kidletime-5.83.0-1  kimageformats-5.83.0-2  kinfocenter-5.22.1-1  kinit-5.83.0-1  kio-5.83.0-1  kio-extras-21.04.2-1  kio-gdrive-21.04.2-1
kipi-plugins-21.04.2-1  kirigami2-5.83.0-1  kitemmodels-5.83.0-1  kitemviews-5.83.0-1  kjobwidgets-5.83.0-1  kjs-5.83.0-1  kleopatra-21.04.2-1
kmenuedit-5.22.1-1  kmime-21.04.2-1  knewstuff-5.83.0-1  knotifications-5.83.0-1  knotifyconfig-5.83.0-1  kompare-21.04.2-1  konsole-21.04.2-1
kpackage-5.83.0-1  kparts-5.83.0-1  kpeople-5.83.0-1  kpimtextedit-21.04.2-1  kpmcore-21.04.2-1  kpty-5.83.0-1  kquickcharts-5.83.0-1  krdc-21.04.2-1
krfb-21.04.2-1  krita-4.4.5-1  kross-5.83.0-1  krunner-5.83.0-1  kscreen-5.22.1-1  kscreenlocker-5.22.1-1  kservice-5.83.0-1  ksshaskpass-5.22.1-1
ksysguard-5.22.0-1  ksystemlog-21.04.2-1  ksystemstats-5.22.1-1  ktexteditor-5.83.0-1  ktextwidgets-5.83.0-1  ktorrent-21.04.2-1
kunitconversion-5.83.0-1  kwallet-5.83.0-1  kwallet-pam-5.22.1-1  kwalletmanager-21.04.2-1  kwayland-5.83.0-1  kwayland-integration-5.22.1-1
kwayland-server-5.22.1-1  kwidgetsaddons-5.83.0-1  kwin-5.22.1-1  kwindowsystem-5.83.0-1  kwrited-5.22.1-1  kxmlgui-5.83.0-1
latte-dock-git-0.9.91.r124.g686d04f1-1  layer-shell-qt-5.22.1-1  lib32-clang-12.0.0-1  lib32-libva-mesa-driver-21.1.2-1  lib32-libx11-1.7.2-1
lib32-libxcrypt-4.4.22-2  lib32-llvm-libs-12.0.0-2  lib32-mesa-21.1.2-1  lib32-mesa-vdpau-21.1.2-1  lib32-ocl-icd-2.3.0-1  lib32-opencl-mesa-21.1.2-1
lib32-vulkan-intel-21.1.2-1  lib32-vulkan-mesa-layers-21.1.2-1  lib32-vulkan-radeon-21.1.2-1  lib32-zstd-1.5.0-2  libaccounts-glib-1.25-4
libaccounts-qt-1.16-3  libadwaita-1.0.0alpha.1-1  libappimage-1.0.3-4  libavif-0.9.1-1  libcanberra-0.30+2+gc0620e4-4
libcanberra-pulse-0.30+2+gc0620e4-3 [removal]  libcap-2.50-2  libclc-12.0.0-1  libcmis-0.5.2-8  libcolord-1.4.5-4  libedit-20210522_3.1-1
libgusb-0.3.7-1  libixion-0.16.1-6  libkdcraw-21.04.2-1  libkexiv2-21.04.2-1  libkgapi-21.04.2-1  libkipi-21.04.2-1  libkleo-21.04.2-1
libkomparediff2-21.04.2-1  libksane-21.04.2-1  libkscreen-5.22.1-1  libksysguard-5.22.1-1  libktorrent-21.04.2-1  liblouis-3.18.0-1  libmm-glib-1.16.6-1
libnice-0.1.18-2  libogg-1.3.5-1  liborcus-0.16.1-7  libp11-kit-0.24.0-1  libpamac-aur-11.0.0-1  libpcap-1.10.1-1  libqmi-1.28.6-1
libreoffice-fresh-7.1.4-1  librewolf-89.0-1  libtorrent-rasterbar-1:1.2.14-1  libva-mesa-driver-21.1.2-1  libvips-8.11.0-1  libwpe-1.10.1-1
libx11-1.7.2-1  libxcrypt-4.4.22-4  libxnvctrl-465.31-1  linux-smart-enumeration-169.c795112-1  llvm-libs-12.0.0-2  m4-1.4.19-1  memtest86+-5.31b-1
mesa-21.1.2-1  mesa-vdpau-21.1.2-1  metasploit-6.0.48-1  milou-5.22.1-1  modemmanager-1.16.6-1  modemmanager-qt-5.83.0-1  mpg123-1.28.0-1  mujs-1.1.3-1
nbtscan-1.6-1  netpbm-10.73.34-1  nettle-3.7.3-1  node-gyp-8.1.0-2  nodejs-nopt-5.0.0-2  nordvpn-bin-3.10.0_1-1  noto-color-emoji-fontconfig-1.0.0-1
npm-7.17.0-1  nspr-hg-4.32.0r4926.853873739c49-1  nss-hg-3.68.0r15944.194e150b059e-1  ocl-icd-2.3.0-1  okular-21.04.2-1  opencl-mesa-21.1.2-1
opencolorio1-1.1.1-3  openmpi-4.1.1-2  oxygen-5.22.1-1  p11-kit-0.24.0-1  pace-1.4.1.1-2  pacman-6.0.0-3  pamac-aur-10.1.3-1  pambase-20210605-2
partitionmanager-21.04.2-1  paru-1.7.2-1  pipewire-1:0.3.30-2  plasma-browser-integration-5.22.1-1  plasma-desktop-5.22.1-1  plasma-disks-5.22.1-1
plasma-firewall-5.22.1-1  plasma-framework-5.83.0-1  plasma-integration-5.22.1-1  plasma-nm-5.22.1-1  plasma-pa-5.22.1-1  plasma-systemmonitor-5.22.1-1
plasma-thunderbolt-5.22.1-1  plasma-vault-5.22.1-1  plasma-workspace-5.22.1-1  plasma-workspace-wallpapers-5.22.1-1
plasma5-applets-window-appmenu-0.7.0-1  plasma5-applets-window-title-0.7.0-1  polkit-kde-agent-5.22.1-1  postgresql-libs-13.3-3  powerdevil-5.22.1-1
print-manager-21.04.2-1  printer-support-1-4  prison-5.83.0-1  pulseaudio-alsa-1:1.2.5-2  purpose-5.83.0-1  python-idna-3.2-1  python-pip-20.3.1-2
python-resolvelib-0.5.5-1  python2-pip-20.3.1-2  python2-resolvelib-0.5.5-1  qbittorrent-4.3.5-1  qqc2-desktop-style-5.83.0-1
qt5-declarative-5.15.2+kde+r28-1  qt5-quick3d-5.15.2+kde+r19-1  qt5-script-5.15.4-1  qt5-tools-5.15.2+kde+r17-2  qt5-wayland-5.15.2+kde+r28-1
qt6-base-6.1.1-1  qtcreator-4.15.1-1  ripgrep-13.0.0-2  rubberband-1.9.2-1  ruby-bundler-2.2.20-1  rubygems-3.2.19-1  samba-4.14.5-1  sddm-kcm-5.22.1-1
signal-desktop-5.5.0-1  signon-kwallet-extension-21.04.2-1  smbclient-4.14.5-1  solid-5.83.0-1  sonnet-5.83.0-1  source-highlight-3.1.9-5
spectacle-21.04.2-1  spirv-llvm-translator-12.0.0-1  sqlite-3.35.5-2  sslscan-2.0.10-1  sstp-client-1:1.0.15-1  sudo-1.9.7.p1-1  syndication-5.83.0-1
syntax-highlighting-5.83.0-1  systemsettings-5.22.1-1  tcpdump-4.99.1-1  threadweaver-5.83.0-1  timeshift-20.11.1+4+gd437358-1  tinyxml2-9.0.0-1
tor-0.4.5.9-1  tracker3-3.1.2-1  unarj-2.65-1  unrar-1:6.0.7-1  uresourced-0.4.0-1  util-linux-2.37-3  util-linux-libs-2.37-3  vlc-3.0.15-2
vte-common-0.64.2-2  vte3-0.64.2-2  vulkan-headers-1:1.2.180-1  vulkan-icd-loader-1.2.178-1  vulkan-intel-21.1.2-1  vulkan-mesa-layers-21.1.2-1
vulkan-radeon-21.1.2-1  vulkan-swrast-21.1.2-1  whatweb-4909.ae899862-1  whois-5.5.10-1  whoogle-git-0.5.4_r339.gbcb1d8e-1  wireless-regdb-2021.04.21-1
wireshark-cli-3.4.6-1  wireshark-qt-3.4.6-1  wpebackend-fdo-1.10.0-1  xapp-2.2.1-1  xdg-desktop-portal-kde-5.22.1-1  xfsprogs-5.12.0-1
xkeyboard-config-2.33-1  yakuake-21.04.2-1  zoom-5.6.7-1

This is not the suggestion given.
Ignoring is totally different from downgrading. Have you studied Archwiki about it?
Ignoring random packages from upgrade leads to a partial upgrade and is not supported.
After full upgrade, downgrade suggested packages as described in previous post.

This is one package linux-firmware.

I thought BlackArch users would know plenty about networking packages.
Try looking for related packages here.

That's correct (for me, at least :stuck_out_tongue_winking_eye: )!

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.