WiFi MAC Address for Router MAC Whitelist

I am new to Garuda Linux...I ran the command "inxi -Faz" but it populated so much information. For fear of being ignored, which is STUPID, because I am not only a newb here, I have developed a real liking for Garuda and therefore have taken on a LOT to learn but again, VERY newb...I can navigate Ubuntu with ease but it's completely different with this OS. I'm going to paste the output that is requested, and I want to apologize, in advance, if I was only supposed to provide a certain section as this is long! (Please see below for that info)

I just need to find my WiFi MAC (and ensure it isn't random for my home WiFi) because I use a Whitelist MAC within my router instead of just letting anyone connect...I was hoping to find this section easily on Garuda but cannot. I would appreciate the help but if I'm too "newb" or didn't follow your rules correctly, I apologize-I'll go back to other Linux distros and discontinue my monthly donation.
Thank you, in advance, for your assistance.

Clinton

Output from command:
╭─[email protected] in ~ took 2s
╰─λ inxi -Faz

System:
Kernel: 5.15.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1a8a5a14-98bc-494f-916f-0bcff4ccc635 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude 7420 v: N/A
serial: Chassis: type: 10 serial:
Mobo: Dell model: 07MHG4 v: A00 serial: UEFI: Dell
v: 1.13.0 date: 11/23/2021
Battery:
ID-1: BAT0 charge: 31.6 Wh (51.1%) condition: 61.9/61.9 Wh (100.0%)
volts: 15.3 min: 15.2 model: SMP DELL TN2GY19 type: Li-poly
serial: status: Discharging
CPU:
Info: model: 11th Gen Intel Core i7-1185G7 bits: 64 type: MT MCP
arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0x9C
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 963 high: 1858 min/max: 400/4800 scaling:
driver: intel_pstate governor: performance cores: 1: 894 2: 432 3: 420
4: 778 5: 1858 6: 1324 7: 491 8: 1508 bogomips: 28876
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
driver: uvcvideo bus-ID: 3-6:3 chip-ID: 1bcf:2bab class-ID: 0e02
serial:
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157
size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.3.1
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
Sound Server-1: ALSA v: k5.15.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac:
IF-ID-1: vboxnet0 state: down mac:
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Drives:
Local Storage: total: 238.47 GiB used: 21.32 GiB (8.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: BC711 NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: 41002131 temp: 36.9 C scheme: GPT
Partition:
ID-1: / raw-size: 83.65 GiB size: 83.65 GiB (100.00%)
used: 21.29 GiB (25.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 27.5 MiB (28.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 83.65 GiB size: 83.65 GiB (100.00%)
used: 21.29 GiB (25.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 83.65 GiB size: 83.65 GiB (100.00%)
used: 21.29 GiB (25.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 83.65 GiB size: 83.65 GiB (100.00%)
used: 21.29 GiB (25.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.35 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 303 Uptime: 15m wakeups: 506 Memory: 15.35 GiB
used: 2.92 GiB (19.0%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1777 lib: 505 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.10

It is super simple to disable Network Manager's MAC address randomization feature in Garuda. Simply use Garuda's Network Assistant to easily disable MAC address randomization.

Right click on your network connection's icon in the system tray. Select configure network connections. You can set/change your MAC address through your connection's settings in the Network Manager app.

3 Likes

Hi there @clintonsonn, and a Merry Christmas to you.

I just thought I'd add another reply here as you have yet to respond in almost a week. You have opened several help requests on the forum and in both cases you have not seen fit to respond to forum assistants on your own help request threads you've opened.

The forum is a two way street and nothing is accomplished here without feedback from the users that open help requests on our forum. Please do not leave threads dangling after opening a help request.

I attempt to keep the networking sub-forum neat and orderly by trying my best to ensure networking threads are closed out properly with a positive resolution. Most networking help requests usually have a positive outcome on our forum as long as the OP is proactive with providing feedback.

Forum threads are automatically locked after two weeks dormant to prevent necrobumping. So please respond to help requests you've opened in a timely manner to prevent auto-locking of your help requests.

If your issue has been resolved, please ensure you return to your thread and post the solution and mark your thread solved. This not only helps keep the forum organized with regards to solved/unsolved threads, it also helps other users with the same problem to find a solution to similar issues.

Please ensure you give proper feedback on all help requests you open, and also please mark your thread solved if your issue has been resolved.

Your cooperation with regards to help requests you open would be greatly appreciated. All the best of the season to you.

5 Likes

You are in the habit of opening help requests and then going silent and never responding. I consider this the same as calling 911 then disappearing after the response team has been dispatched.

As you like to give forum helpers the silent treatment, I will respond in kind. Your posting privilliges have been revoked for a good long while.

3 Likes