Wifi is disabled by hardware switch

hi, i am new to linux and garuda
i have installed garuda xfce
my issue is that the wifi network is showing wifi disabled by hardware switch and ethernet network (realtex rtl810xe) is showing disconnected
garuda-inxi is as follows

  Kernel: 5.15.81-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=b09296ae-d31e-4e23-a6e0-b09537c012c5 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=92fc0b6c-65e1-4032-8332-c6be73cf20a6 loglevel=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
    v: 0884110000385910000610100 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 183F v: 56.2B serial: <superuser required>
    UEFI: Insyde v: F.10 date: 08/10/2012
  ID-1: BAT0 charge: 29.7 Wh (92.5%) condition: 32.1/32.1 Wh (100.0%)
    volts: 12.5 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: charging
  Info: model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1542 high: 2060 min/max: 1200/2400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1365 2: 1236 3: 2060
    4: 1507 bogomips: 19157
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: Realtek HP Truevision HD type: USB driver: uvcvideo
    bus-ID: 2-1.5:3 chip-ID: 0bda:58de class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: LG Display 0x02f1 built: 2011 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  Sound API: ALSA v: k5.15.81-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
    driver: rt2800pci v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 01:00.0 chip-ID: 1814:3290 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  IF-ID-1: enp0s26u1u2 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.1 chip-ID: 1814:3298
    class-ID: 0d11
  Device-2: OPPO RMX3241 type: USB driver: rndis_host v: kernel
    bus-ID: 1-1.2:4 chip-ID: 22d9:276a class-ID: 0a00 serial: <filter>
  Report: bt-service: enabled,stopped note: tool can't run
  Local Storage: total: 704.24 GiB used: 11.51 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 model: 256GB EVM SSD size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 4A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS545050A7E380
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: A7A0 scheme: GPT
  ID-1: / raw-size: 229.99 GiB size: 229.99 GiB (100.00%)
    used: 11.51 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 229.99 GiB size: 229.99 GiB (100.00%)
    used: 11.51 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 229.99 GiB size: 229.99 GiB (100.00%)
    used: 11.51 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 229.99 GiB size: 229.99 GiB (100.00%)
    used: 11.51 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.72 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.18 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 63.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 221 Uptime: 7m wakeups: 1 Memory: 3.72 GiB used: 1.72 GiB (46.3%)
  Init: systemd v: 252 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 Packages: pm: pacman pkgs: 1182 libs: 334 tools: paru
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.23
Garuda (2.6.10-1):
  System install date:     2022-12-07
  Last full system update: 2022-12-08
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

Post terminal input and output as text formatted between three ~ in first and last line.
my terminal text

my terminal text

You need to update your BIOS. This thread may be useful:


For your Ethernet try installing this driver:


If you haven't already updated your bios, you can try resetting your bios to the factory default. This can be done through your bios itself, or the more sure fire method is to remove your cmos battery from the mobo as follows:

  1. Remove the laptops battery, external charger, as well as any peripherals.

  2. Remove your cmos battery from the mobo.

  3. Press and hold the power button for 30 - 60 secs.

  4. Reinsert the cmos battery in the mobo.

  5. Reconnect the power sources to the laptop.

  6. Restart the laptop.

Hopefully a full reset of the bios will activate your wifi.

Welcome to the forum.

1 Like

Ok will try and revert back thank u

Ok will try and revert back thanks

Hi, i have tried but nothing worked

also pls help me to install this : AUR (en) - r8101-dkms

Hi, there seems no bios update for my machine

I find that difficult to believe. What was your method for checking?

i went to hp solution entered my laptop serial number and checked, and even i tried their linux archive but it did not connect to the site.
maybe u r right, pls help me.

When it pulled up your device, it said the most recent BIOS version is from 2012?

If you cannot update the BIOS, try resetting it instead and see if it helps with the WiFi issue.

i did resetting also but nothing
can you send me the link where it said the most recent BIOS version is from 2012

That is not a link, that is from your garuda-inxi. The version you are running is from 2012. My guess is there is a more recent version available.

oh ok, maybe i am not able to see the BIOS update on their site

hi finally i got the file from this link HP Consumer Notebook PCs - Basic Input Output System (BIOS) Updates (EDK2 UEFI firmware) | HP® Customer Support
and my file is SP66805 file , i have downloaded the same, my problem is i am not able to go any further, pls help me with it

First, you need to back up any important data to another device in case something goes wrong.

Then you need to get a USB flash drive and format it with FAT32.

mkfs -t vfat /dev/[usb device]

Then, just follow along in the document as carefully as you can:


Ok thank you, will try and revert back

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.