Wifi interface not showing

hello garuda guys,
I am having an issue with wifi, I was using it normally then update the system and installed gparted. then i switch to windows (dual boot) after that again come back to garuda but this time the wifi is not working no option to enable or disable.

I tried ifconfig,

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
inet  netmask
inet6 ::1  prefixlen 128  scopeid 0x10<host>
loop  txqueuelen 1000  (Local Loopback)
RX packets 16  bytes 3017 (2.9 KiB)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 16  bytes 3017 (2.9 KiB)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and this is

sudo dmesg | grep iwlwifi

[    7.226400] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    7.394012] iwlwifi: probe of 0000:01:00.0 failed with error -110

This is one of the reasons why we strongly recommend avoiding dual boot…
Windows loves to hold a grip on HW resources.
What I think you could try is:

  • Logon to Windows and disable fast startup. See e.g. here.
  • Open your device manager, go through each driver option and disable any option that relates to wifi power saving
  • Shutdown your computer, unplug the AC power cord and leave the PC unplugged for a few minutes, then restart the computer and try booting to Linux

Filo covered the essential steps that resolve most issues like yours. Having said that, if his suggestions do not resolve your problem then resetting your bios to the factory default may be required. You will of course need to alter a few bios settings to make it compatible with Linux again just like when you installed Garuda.

If none of your efforts resolve your issue, be sure to post your garuda-inxi output if you desire further assistance, as we will need to know far more details about your system.

If you are using iwd (check to see if that package is installed) then you should read the Arch Linux forum thread I’ve linked below:



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.