Wifi hard blocked In my hp laptop

Wifi hard blocked in hp laptop I tried everything like rfkil
Nmcli or nmtui or FN+F12 /meta+F12 but still my wifi is hard blocked my bios is up to date also setup boot start-up did fresh install of driver too but still not works

This is because your horoscope predicted these issues with the unknown wifi card yesterday.

Jokes aside, please post your garuda-inxi as requested by the template.
We don’t know your hardware, nor do we know if you have Windows dual boot, etc.

If you have Windows dual boot, it is possible that your WiFi card has been hijacked by Windows. If so, boot Windows and disable Fast Start in the power options. Then shut down Windows properly → right click on the Windows button → Shutdown. Turn the laptop back on and disable Fastboot in the BIOS → boot Garuda and check again.

And welcome to the community :slight_smile:


I did already this yesterday but it’s doesn’t works for me I also freshly installed drivers

Everything you have already tried to solve the problem belongs in the start post. It is also in the topic template if you read it before you posted :wink:


A small mechanical switch in an inconspicuous (hidden) place?

1 Like

We will need to know your exact laptop model, your bios version, your WiFi chip, the driver you installed, and the kernel you are using.

Please post your garuda-inxi so we can find the exact info we need to solve your problem.

Most likely causes/fixes:

You installed the wrong WiFi driver.

Your kernel you are running has problems with your WiFi chip, (test other kernels).

You are running an outdated bios version, (update bios).

Your WiFi isn’t being identified properly in your bios, (reset bios to factory settings).

Completely power off your computer then remove all power sources for 5 minutes, (including laptop battery and cmos battery).

Good luck, and again, include your garuda-inxi with your next post as your thread will likely be locked if it is not included soon. These kind of problems require knowing exactly which hardware and firmware components are in use.

Welcome to the Garuda community.


Yes I updated my bios to already

Please, no pictures from terminal output.

They are not searchable if they are pictures, and can be hard to see across different devices.
Please select the text in the terminal, copy the text and paste the text into the post.
Select the newly pasted text in the post.
Click the </> icon in the post toolbar.

This creates nicely formatted text that we can use by forum search.
You can also use the garuda-assistant - System Infos.

Thank you :slight_smile:


Hi @Rahul-alt.

Perhaps you are unsure how to properly post the information we require to solve your problem. Follow these directions if you are unsure:

First open a terminal window with this key combination:


Next, paste the command below into the newly opened terminal window and press the ENTER key:


Next, copy the output of the garuda-inxi command into your help request on the forum. It is usually best to edit your opening post (by tapping the pencil icon) and add your inxi information to your original post.

To format your terminal output so that it is properly readabe/searchable and more legible on portable devices place three “tildes” before and after your terminal output, as so:

copy terminal output here

Once you have done this you are far more likely to receive assistance. If your laptop does not currantly have an Internet connection, you can either temporarily use an Ethernet connection or use “USB Android phone tethering” to connect your laptop to the internet. The other option is to boot from the Garuda live disk that you used for your installation and open a terminal there, run the garuda-inxi command and paste the output to the forum here. Performing a live boot is a good step to take regardless, as sometimes merely connecting to the internet from a live session is enough to fix the connection on a laptop. It would also be very useful information for us to know if your WiFi is working correctly in the live environment.

Please post the information requested by forum moderators if you wish to receive further assistance with this issue on the Garuda forum.

I am relocating this thread to Networking sub-section of the forum, as that is where it will be most helpful for others that are experiencing similar WiFi hard block issues.


I’m afraid your RT3290 WiFi chipset (what a pain to find it in pictures!) seems to be quite a buggy one in Linux.
There are a few old and still open kernel bugs, e.g.
And some Arch topics about it, e.g.
At a quick search, I haven’t been able to find a solution, maybe a driver in the AUR…


You have more patience than me @filo. One look at the pics and my eyes glazed over. :face_with_spiral_eyes:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.