WiFi drops out after trying to pull a webpage

Greetings,

I've recently updated my system and now WiFi won't stay connected.

Upon reboot/restarting wifi I can ping in and outside of my network but seconds after I try to access a website via browser or perform an update it completely drops out and I'm unable to ping anywhere to include within my own network via wifi. Everything is ok when using a wired connection. I've tried to re-install the driver and performed a few updates but to no avail.

I'm using a TP-Link AC1300 which isn't officially supported so I used these forums to learn how to get the driver installed - It has been great until now.

Any help would be greatly appreciated!!

Here is my networking info:

10: PCI 200.0: 0200 Ethernet controller                         
[Created at pci.386]
Unique ID: c3qJ.5rbhBgx50x4
Parent ID: QSNP.xpwxxKVOE11
SysFS ID: /devices/pci0000:00/0000:00:1c.4/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: "Gigabyte Onboard Ethernet"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
SubDevice: pci 0xe000 "Onboard Ethernet"
Revision: 0x06
Driver: "r8169"
Driver Modules: "r8169"
Device File: enp2s0
I/O Ports: 0xd000-0xd0ff (rw)
Memory Range: 0xf0904000-0xf0904fff (ro,non-prefetchable)
Memory Range: 0xf0900000-0xf0903fff (ro,non-prefetchable)
IRQ: 16 (125593 events)
HW Address: 94:de:80:c3:6d:39
Permanent HW Address: 94:de:80:c3:6d:39
Link detected: yes
Module Alias: "pci:v000010ECd00008168sv00001458sd0000E000bc02sc00i00"
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #21 (PCI bridge)

25: USB 00.0: 0282 WLAN controller
[Created at usb.122]
Unique ID: XEU_.lZ_Y4IrY7j6
Parent ID: dwDZ.cR3kNpdgj73
SysFS ID: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3.3/1-1.3.3:1.0
SysFS BusID: 1-1.3.3:1.0
Hardware Class: network
Model: "TP-Link Archer T3U [Realtek RTL8812BU]"
Hotplug: USB
Vendor: usb 0x2357 "TP-Link"
Device: usb 0x012d "Archer T3U [Realtek RTL8812BU]"
Revision: "2.10"
Serial ID: "123456"
Driver: "rtw_8822bu"
Driver Modules: "rtw88_8822bu"
Device File: wlp0s26u1u3u3
Features: WLAN
Speed: 480 Mbps
HW Address: 42:d4:99:99:8b:1b
Permanent HW Address: c0:06:c3:5f:fb:24
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "usb:v2357p012Dd0210dc00dsc00dp00icFFiscFFipFFin00"
Driver Info #0:
Driver Status: rtw88_8822bu is active
Driver Activation Cmd: "modprobe rtw88_8822bu"
Driver Info #1:
Driver Status: 88x2bu is active
Driver Activation Cmd: "modprobe 88x2bu"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #39 (Hub)

26: USB 00.0: 11500 Bluetooth Device
[Created at usb.122]
Unique ID: GrY4.nQKjiuCfL84
Parent ID: CiZ2.ugLqxniY9o7
SysFS ID: /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.1/3-3.1:1.0
SysFS BusID: 3-3.1:1.0
Hardware Class: bluetooth
Model: "Cambridge Silicon Radio Bluetooth Dongle (HCI mode)"
Hotplug: USB
Vendor: usb 0x0a12 "Cambridge Silicon Radio, Ltd"
Device: usb 0x0001 "Bluetooth Dongle (HCI mode)"
Revision: "88.91"
Driver: "btusb"
Driver Modules: "btusb"
Speed: 12 Mbps
Module Alias: "usb:v0A12p0001d8891dcE0dsc01dp01icE0isc01ip01in00"
Driver Info #0:
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #24 (Hub)

Here is my inxi:

λ garuda-inxi
System:
Kernel: 5.18.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4e3c2a30-eb1c-4688-91a4-70a209ad6f81 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: N/A v: N/A
serial: <superuser required> Chassis: type: 3 serial: <superuser required>
Mobo: Gigabyte model: B75M-D3H v: x.x serial: <superuser required>
BIOS: American Megatrends v: F15 date: 10/23/2013
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech MX Keys Wireless Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3001 high: 3893 min/max: 1600/3900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3891 2: 2652 3: 1790
4: 3892 5: 2070 6: 1977 7: 3893 8: 3848 bogomips: 54273
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Bonaire XT [Radeon HD 7790/8770 / R7 360 R9 260/360 OEM]
vendor: ASUSTeK driver: radeon v: kernel alternate: amdgpu arch: GCN 2
process: GF/TSMC 16-28nm built: 2013-17 pcie: gen: 2 speed: 5 GT/s
lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: DVI-D-1,HDMI-A-1 empty: DP-1,DVI-I-1 bus-ID: 01:00.0
chip-ID: 1002:665c class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 3640x1920 s-dpi: 96 s-size: 963x508mm (37.91x20.00")
s-diag: 1089mm (42.87")
Monitor-1: DVI-D-1 mapped: DVI-0 pos: primary,top-left model: HP V27i
serial: <filter> built: 2021 res: 1080x1920 hz: 60 dpi: 82 gamma: 1.2
size: 336x598mm (13.23x23.54") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-0 pos: primary,bottom-r
model: LG (GoldStar) 32GK850G serial: <filter> built: 2014 res: 2560x1440
hz: 60 dpi: 109 gamma: 1.2 size: 598x336mm (23.54x13.23")
diag: 801mm (31.5") ratio: 16:9 modes: max: 2560x1440 min: 640x480
OpenGL: renderer: AMD BONAIRE (LLVM 13.0.1 DRM 2.50 5.18.6-zen1-1-zen)
v: 4.5 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: AMD Tobago HDMI Audio [Radeon R7 360 / R9 OEM]
vendor: ASUSTeK R7260X-DC2OC-2GD5 driver: snd_hda_intel v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 1002:aac0 class-ID: 0403
Sound Server-1: ALSA v: k5.18.6-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: TP-Link Archer T3U [Realtek RTL8812BU] type: USB
driver: rtw_8822bu bus-ID: 1-1.3.3:5 chip-ID: 2357:012d class-ID: 0000
serial: <filter>
IF: wlp0s26u1u3u3 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 3-3.1:3 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 161.17 GiB (17.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: MBR
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 161.17 GiB (17.3%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 161.17 GiB (17.3%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 161.17 GiB (17.3%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 161.17 GiB (17.3%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A gpu: radeon temp: 55.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 284 Uptime: 19m wakeups: 4 Memory: 15.57 GiB
used: 3.2 GiB (20.5%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1491
lib: 364 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: yakuake
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-03-04
Last full system update: 2022-06-25 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

If this started after a recent update, the first thing I would try would be some other kernels like LTS, mainline, or hardened in case a kernel bug is to blame (especially with a less-supported network card).

2 Likes

I don't think it will help here, but with KDE you should reboot after updates.

3 Likes

@BluishHumility, Thanks! I've been meaning to teach myself how to use other kernels anyway so I'll give that a shot. It is weird that it has worked with no problems since I started using garuda and now has the issue.

@SGS, Thanks for your reply; I've reset a few times since and only updated today because I saw that you can update with 'sudo update' instead of 'sudo garuda-update' and wanted to try it out lol.

1 Like

No need of sudo for update and garuda-update :wink:

2 Likes

If you are using a proprietary Realtek driver from the AUR or Chaotic AUR the driver sometimes requires rebuilding after a kernel update.

3 Likes