Wifi doesn't connect. rtl8852be

Hello Garuda users.

I am having an issue with wifi to work for my laptop. My PC is lenovo ipeapad 5.
CPU: Amd ryzen 7 5825U.
GPU Amd Radeon.
Wifi: Realtek 8852be.

I am new to garuda linux and came here looking for some help.

I have referred to all the help forum and discussions that was previously posted and tried all the solutions but it was all in vein. I looked up:

but I don't have the same driver and even if I looked up my driver in associated Linux driver in Garuda network manager, I do not see any drivers there so, I can't blacklist any of them. So, I thought that I need to install new ones.

I also tried to install driver from Chaotic aur AUR (en) - rtl8852be-dkms-git and then I restarted my PC but there was no success. I used the code:

git clone https://aur.archlinux.org/packages/rtl8852be-dkms-git

and restarted my PC but in vein.

After that I tried

paru -Syu aur/rtl8852be-dkms-git

and restarted the PC but in vein.

My bluetooth works but no WiFi.

Some help would be appreciated.

Welcome to the forum
Can you provide your

garuda-inxi

as per the forum template

2 Likes

Hello!

My apologies, I have included my system info below.

System:
Kernel: 6.1.4-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=40512647-2999-447c-944b-0956993f4f0d rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82SG v: IdeaPad 5 15ABA7
serial: <superuser required> Chassis: type: 10 v: IdeaPad 5 15ABA7
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0T76463WIN
serial: <superuser required> UEFI: LENOVO v: KACN17WW date: 08/05/2022
Battery:
ID-1: BAT0 charge: 11.6 Wh (19.8%) condition: 58.5/57.0 Wh (102.6%)
volts: 11.1 min: 11.5 model: Celxpert L19C3PF5 type: Li-poly
serial: <filter> status: discharging cycles: 22
CPU:
Info: model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1695 high: 2531 min/max: 1600/4547 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2000 2: 1600
3: 2531 4: 1600 5: 1397 6: 2000 7: 1600 8: 1600 9: 1600 10: 1600 11: 1600
12: 1600 13: 1600 14: 1600 15: 1600 16: 1600 bogomips: 63883
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Barcelo vendor: Lenovo driver: amdgpu v: kernel arch: RDNA-2
code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:15e7
class-ID: 0300 temp: 40.0 C
Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:2
chip-ID: 5986:214d class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x08c2 built: 2019
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: AMD Radeon Graphics (renoir LLVM
14.0.6 DRM 3.49 6.1.4-zen2-1-zen) direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound API: ALSA v: k6.1.4-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek vendor: Lenovo driver: N/A pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:b852 class-ID: 0280
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 0bda:4853 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 10.24 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDKCD512TFK
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 1003V5LN temp: 24.9 C scheme: GPT
Partition:
ID-1: / raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
used: 10.21 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 38.6 MiB (15.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
used: 10.21 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
used: 10.21 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 146.48 GiB size: 146.48 GiB (100.00%)
used: 10.21 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.1 C mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 337 Uptime: 4m wakeups: 9147 Memory: 13.5 GiB
used: 2.16 GiB (16.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1326
libs: 337 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-10
Last full system update: 2023-01-11
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Additionally, I am not sure if the wifi driver is rtl8852be or rtw89 for archlinux as I came across this:

this says that I need to do something with my kernel.

If you know how to do it can you please add it in here as this is the new driver and may help someone who needs it later.

If you still have this, I'd try switching to the linux-lts kernel (or reinstall that driver after the lts kernel).
Otherwise, you could also go for:

Ops, I see you have already found this.
Use the dkms one:

git clone https://aur.archlinux.org/rtw89-dkms-git.git
cd rtw89-dkms-git
makepkg -sri
3 Likes

Hello, Thanks I was able to get my driver installed.

I did the dkms code that was provided here and restarted the PC and it started working.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.