Wifi connection randomly cuts off and after clicking WiFi icon it just comes back

Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
DeviceName: WLAN
Subsystem: Hewlett-Packard Company Device 831a
Kernel driver in use: rtl8821ce
Kernel modules: rtw88_8821ce, 8821ce

btw mine looks like this rtw88_8821ce being the fauly one and 8821ce(which I installed through pamac) being in use

Do i have to delete my default driver before I try to install the other one?

I'll wait for your reply so I don't mess things up

Update: Saw your thread. so if the above solutions won't work reinstalling garuda might help right?

So, yesterday I tried to log in my router, but it wouldn't let me to. After some struggle I called to company whose internet and router I am using. Company told me that they don't allow their users to configure settings on their own and they could do it for me. So I made them do hard reset and told them if there are any new firmware install it. According to them they did all of that.

So I'll see how it will play out. If this method won't work then I'll try to install different driver as
Odin5133 suggested below

So i did what u have told me to do. I did
sudo pacman -Syu rtl88x2ce-dkms
Checked lspci -k
Nothing was changed. Then I restarted my laptop and there was no connection at all.
I checke lscpi -k
and this wass the output:

Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 3750
Kernel modules: rtw88_8822ce

I couldn't see kernel driver in use: section

Followed solution on your thread and this is how lspci-k looks right now

Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 3750
Kernel driver in use: rtw_8822ce
Kernel modules: rtw88_8822ce, rtw_8822ce

didn't I install the same driver though?

quick recap of what I did.

Disabled Mac address randomization.
Disabled IPv6
Follow the solution of this thread step-by-step:RTL8821CE - When idle, wifi drops and works only after reconnecting - #14 by tbg

contacted internet provider and they fully restarted my router settings.

UPDATE: connection cut still happened. This time I detected it with steam while playing online game for testing reasons. I got disconnected and after clicking WiFi icon magic happened and I got reconnected.

UPDATE:So after connection cut my device was not even detecting internet connection so I had to Snap back.

  1. You had Windows installed just prior to installing Garuda?
  2. Did you turn off any Fast Boot or related settings in your BIOS that interfere with full hardware detection?

Here's the deal; Windows likes to "capture" hardware. And sometimes BIOS have hardware detection turned to minimal in order to accomplish faster boot times. Those BIOS settings sometimes need to be adjusted when coming from Windows to Linux.

1 Like

1.Yes I was running windows for 1 year before switching to Garuda.
2.Haven't messed with BIOS settings during installation

How can I adjust BIOS settings exactly.
Thank you for your response.

You can enter the BIOS at boot time, usually by pressing a key such as F2 or F12. Every BIOS manufacturer has a slightly different method. Same goes for Fast Boot. It has a couple of different names, but they all do the same thing; speed up boot by skipping full hardware detection for what the operating system--presumably Windows--already thinks it knows is there. That can interfere with it being detected and fully utilized in Linux. To avoid that, ensure your BIOS does not skip that important step.

But it could also be some bastardized power-saving feature, who knows. And I would also try different kernels. But first, I would undo whatever harm I've already done by installing packages willy-nilly.

1 Like

so now the new driver is installed but it is not being used by the kernel, so copy paste this code in the terminal

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8822ce" | sudo tee /etc/modprobe.d/rtl8822ce.conf

This will make a file to blacklist the original one.and restart.

1 Like

Btw it is a problem with many/all realtek cards and tbh reinstalling garuda didnt fixed the problem, installing the new driver and blacklisting the old one did.But at that point the thread was closed so I didnt knew how to change the solution.

Ok so I'll go now enter BIOS settings and enable hardware detection setting. Did I get it right?

I believe this command was last command in your threads solution so i had it enabled, but didn't work for some reason.
edit: now that I think about it maybe I needed to download different driver than the one mentioned in your threads solution

did you change the rtw88_8821ce(which is my wifi driver) to rtw88_8822ce(which is your wifi driver) in that command?
Maybe once type this command and check the result, I have modified it for your use case

This is my lpci-k right now

Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 3750
Kernel driver in use: rtw_8822ce
Kernel modules: rtw88_8822ce

and after I did solution mentiioined in your thread lspci-k was like that:

Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 3750
Kernel driver in use: rtw_8822ce
Kernel modules: rtw88_8822ce, rtw_8822ce

I think i didn't

Ok just do this once and restart
so now the new driver is installed but it is not being used by the kernel, so copy paste this code in the terminal

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8822ce" | sudo tee /etc/modprobe.d/rtl8822ce.conf

This will make a file to blacklist the original one.and restart.

so I have to redo all the process and basically change last command with this right?
because as I said I had to snap back.

edit: or as i guess i need to change rtl8821ce with rtl8822 everywhere

No. Just type this command in the terminal and restart your laptop

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8822ce" | sudo tee /etc/modprobe.d/rtl8822ce.conf

Also it maybe that the wifi is not shown, in that case dont panic and just delete the .conf file named rtl8822ce.conf in root/etc/modprobe.d/rtl8822ce.conf

1 Like

K i'll do that rn