WiFi card being detected but can't connect to any WiFi networks

Hello Arch and Garuda community. I have made the jump to Linux after using many distros on VM on my main machine running WIndows.

While everything seems to be working, I do not see any WiFi networks. I have updated the system and kernel through my USB-C -to-Ethernet adapter.
My laptop uses the Intel WiFi 6 AX200 card. As you can see below, it's being detected. It's a WiFI+Bluetooth card and surprisingly the Bluetooth functionality is working totally fine.

λ inxi -Faz
System:    Kernel: 5.14.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c17ffca9-34d6-43dd-9b73-ac4692ca4f5a  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=ced70520-06e5-4dfc-b8ba-50009bab20ee loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II v: 1.0 serial: <filter>  
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <filter> UEFI: American Megatrends v: GA401II.219  
date: 12/30/2020  
Battery:   ID-1: BAT0 charge: 72.0 Wh (97.8%) condition: 73.6/76.0 Wh (96.9%) volts: 15.8 min: 15.8  
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging  
Device-1: hidpp_battery_0 model: Logitech G304 Lightspeed Wireless Gaming Mouse  
serial: <filter> charge: 100% (should be ignored) rechargeable: yes status: Discharging  
CPU:       Info: 6-Core model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2  
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104 cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71859  
Speed: 3486 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 3486 2: 2222  
3: 2932 4: 1582 5: 1417 6: 1596 7: 1402 8: 1396 9: 2241 10: 2339 11: 1394 12: 1396  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 470.74  
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2192 class-ID: 0300  
Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 04:00.0  
chip-ID: 1002:1636 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia  
display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14")  
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.6-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.2  
direct render: Yes  
Audio:     Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel  
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403  
Device-2: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403  
Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A  
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480  
Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel  
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403  
Sound Server-1: ALSA v: k5.14.6-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.35 running: yes  
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 bus-ID: 02:00.0  
chip-ID: 8086:2723 class-ID: 0280  
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 6-1.4:4  
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>  
IF: enp4s0f4u1u4 state: up speed: 100 Mbps duplex: full mac: <filter>  
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-4:4 chip-ID: 8087:0029  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 13.58 GiB (1.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 004C temp: 46.9 C scheme: GPT
Partition: ID-1: / raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 13.57 GiB (1.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 13.57 GiB (1.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 13.57 GiB (1.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 13.57 GiB (1.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.56 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.05 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 52.4 C mobo: 51.0 C gpu: amdgpu temp: 47.0 C
Fan Speeds (RPM): cpu: 2600
Info:      Processes: 342 Uptime: 1h 3m wakeups: 5 Memory: 15.05 GiB used: 6.27 GiB (41.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1191 lib: 295
Shell: fish v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.06

I found some solutions on the forum related to this particular card like

  • Restart wifi module through Garuda Network Assistant
  • Disable MAC address randomization
  • Disable Fast Boot (which I did even before installing Garuda)
  • Tried booting with linux kernel as well as linux-g14 kernel (supposedly patched kernel for my device)

I am using Garuda Linux as the only OS - erased disk while installing - so no dual-boot problems. Also secure boot was disabled before installing.

Please help me out with this issue. The distro is almost perfect just need to get WiFi working.

Hi there, welcome!
Please check if this workaround I found some time ago works for you (actually it was found to be working for AX210 instead of AX200)

Basically you only have to remove (rename!) the /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file

1 Like

Welcome to the Garuda forum.

The most likely fix for your adapter would be kernel or firmware related.

I would test the following kernels:

linux
linux-lts
linux-mainline
linux-next-git
linux-hardened

I would also test different firmware versions. You could test the linux-firmware-git package. As well, Intel will have newer and older versions of their firmware available on the website that you can test.

Those are the first steps to take IMO.

Good luck to you.

4 Likes

Just found this one.
Maybe trying with linux-lts could help
https://bbs.archlinux.org/viewtopic.php?id=269823

Also, if no love from suggestions please post:

rfkill list
sudo dmesg | grep -Ei 'wl|firm'
nmcli networking
nmcli networking connectivity check
nmcli dev wifi
modprobe --showconfig | grep -Ei "^install|blacklist"  
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"
lsmod | grep iwlwifi
journalctl -b -1 | grep NetworkManager| grep 'error\|seg\|fail\|broke\|warn\|dump'
ping -c5 8.8.8.8                                                                                
ping -c5 google.com 
ping -c5 127.0.0.1
ping -c5 localhost
2 Likes

Hey everyone. Thank you for your replies and solutions.

It seems for some reason the problem got resolved itself magically. Not really sure what was the issue, but yesterday it wouldn't show any networks, and today everything worked.

Still I would look into your solutions if I face the problem again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.