Wierd issue regarding Kmail(now it is broken)

i am currently using kmail with imap when i configured my gmail account, but for some reason when delete mails it just gets deleted from my local machine, the emails still stay on gmail.
I have tried searching for an answer this should not really be happening on using imap right?

3 Likes

i did try with different keywords but to no avail have i found a working solution for me.

2 Likes

I mean there should a setting on kmail i must change right?

IDK, I use thunderbird without your problem,
Check settings and read the manual if nothing help.

Maybe it is a KDE feature not a bug :wink:

2 Likes

i checked every single kmail configuration setting actually, idk if i am doing anything wrong.

Did you check, bug.kde.org (IIRC)?

1 Like

The site does not work for me.

Check if this helps.
Also the FAQ in general, of course.
https://userbase.kde.org/KMail/FAQs_Hints_and_Tips#Configure_GMail_without_OAuth

The KDE bug tracker is here. An s was missing :blush:
https://bugs.kde.org/

1 Like

Thanks but now i happen to have it broken entirely :frowning:

Welp on accident i removed the "akonadi resources" access to my google account and i can't seem to add it back, any suggestions?

Screenshot_11
Screenshot_12

Welp

SUMMARY
So in summary I have a situation where there there is some state on my KDE
installation with either Kmail or Akonadi whereby I am unable to add my gmail
account and by add my gmail account I mean going through the gmail wizard which
when detecting IMAP should bring up the Google account web popup to sign into
your gmail account.

I know that this is due to my system specifically and not with my Gmail
permissions/accounts due to the fact that I have another PC where I managed to
successfully add the Gmail account without any problems.

But it has no effect

STEPS TO REPRODUCE

  1. Open KMail
  2. Go to Settings -> Add Account
  3. Put in details for a Gmail account (should detect as IMAP)

OBSERVED RESULT
The "Find settings provider on internet" just instantly bugs out and no google
login page is observed. If you ignore this and continue through the wizard when
you try and refresh the account afterwards you get a

Resource Google Mail ([email protected]) is broken.
Could not read the password: user rejected wallet access

EXPECTED RESULT
"Find settings provider on internet" should not bug out instantly but instead
take a few seconds (since this is meant to be doing something) and then at this
point a Google login page should appear asking for your Gmail settings which does not happen anymore.

Is this system up now, or was this at some point in the past?

I'm not sure when they started doing it, but now you have to go to Gmail settings and allow "less secure apps" to get certain mail clients to work. Less secure apps & your Google Account - Google Account Help

Additionally, if you have MFA enabled I do not know how that will work.

5 Likes

Well actually was able to fix my issue somehow, the solution for getting a new auth for akonadi services to connect can only be generated (in case you have removed it from google services) by actually using a separate kmail install and logging in.(as removing local data for kmail did nothing)
EDIT : Well if you are reading this after 1st May 2022, kmail login is now consider under "less secure login" by gmail, your long time access may be unvaiable or completely blocked.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.