Why there are only snapshot boot options available?

Hi, I am new to linux.

Just installed garuda and am having trouble with boot settings.After starting the computer for the second time I can only boot snapshots.

I have tried following this guide, but it only solved my problem partially. I could boot the system normally after the last step, but when restarting it goes back to only snapshots available.

Is it supposed to be like this and I'm trying to use linux the 'wrong' way?

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5847533e-5f90-4837-adfc-ce6b86495090 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: HUANANZHI model: X99-TF v: V2.0
serial: <superuser required> UEFI: American Megatrends v: 5.11
date: 05/11/2021
CPU:
Info: model: Intel Xeon E5-2670 v3 bits: 64 type: MT MCP arch: Haswell
level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3F (63) stepping: 2 microcode: 0x49
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 3 MiB desc: 12x256 KiB
L3: 30 MiB desc: 1x30 MiB
Speed (MHz): avg: 1418 high: 3100 min/max: 1200/3100 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1925 2: 1200 3: 1199
4: 1200 5: 1200 6: 1200 7: 2100 8: 1200 9: 1200 10: 1700 11: 1200
12: 1200 13: 1200 14: 1200 15: 1200 16: 1200 17: 1323 18: 1200 19: 1200
20: 3100 21: 1200 22: 1200 23: 1200 24: 2300 bogomips: 110404
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
(as of 2022-10) arch: Turing code: TUxxx process: TSMC 12nm
built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.0
chip-ID: 10de:1f08 class-ID: 0300
Device-2: Logitech HD Pro Webcam C920 type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-3:3 chip-ID: 046d:082d
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x333mm (23.70x13.11")
s-diag: 688mm (27.09")
Monitor-1: HDMI-0 res: 2560x1440 dpi: 93 size: 700x390mm (27.56x15.35")
diag: 801mm (31.55") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: Intel C610/X99 series HD Audio driver: snd_hda_intel v: kernel
bus-ID: 3-3:3 chip-ID: 046d:082d class-ID: 0102 serial: <filter>
Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.1
chip-ID: 10de:10f9 class-ID: 0403
Device-3: Logitech HD Pro Webcam C920 type: USB
driver: snd-usb-audio,uvcvideo
Device-4: Kingston HyperX QuadCast S type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4.1:6 chip-ID: 0951:171d
class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 3-8:7 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 15.08 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate model: XPG GAMMIX S11L
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s65
temp: 38.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 15.08 GiB
(1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 15.08
GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 15.08
GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 15.08
GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 37 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 37%
Info:
Processes: 394 Uptime: 20m wakeups: 0 Memory: 31.25 GiB used: 3.44 GiB
(11.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1158 libs: 293
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-11-09
Last full system update: 2022-11-09
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Can you, take a picture with your phone or something and upload that and show what you're seeing? Cancel any timers in the boot process, especially with grub (purple-colored theme during boot by default).

This can help at least show us what's going on and be more possibly able to figure out what's going on.

Sure, but something different is happening now. I can only boot.. tests!?

New users can't upload photost so heres an imgur link: Garuda help - Album on Imgur

Check garuda-boot-options

3 Likes

Thanks for replying!

I reinstalled Garuda and now it's back to the snapshot problem.

This is what is available on boot now:



And this is how Garuda Boot Options ins set up:

Inb4: I tried following the first step image of your, but it led me to a test sequence which would take longer than reinstalling the OS.

Can you provide the output of:

ls -l /usr/share/libalpm/scripts/

@psi-jack sure:

╰─λ ls
.rwxr-xr-x  207 root 21 out 14:15  40-fontconfig-config
.rwxr-xr-x  103 root 12 mar  2021  dconf-update
.rwxr-xr-x  350 root  1 nov 09:46  depmod
.rwxr-xr-x 1,3k root 29 mai 05:49  detect-old-perl-modules.sh
.rwxr-xr-x 8,7k root  6 nov 06:23  dkms
.rwxr-xr-x 6,3k root  9 nov 21:18  garuda-hooks-runner
.rwxr-xr-x 4,2k root  4 set 17:16  garuda-migrations-runner
.rwxr-xr-x  128 root 25 out 10:19  gio-querymodules
.rwxr-xr-x  131 root 25 out 10:22  gio-querymodules-32
.rwxr-xr-x  233 root 15 abr 11:56  grub-initrd-generation-fix
.rwxr-xr-x  213 root 25 out 10:59  gtk-update-icon-cache
.rwxr-xr-x 1,1k root 26 out 05:35  mkinitcpio-install
.rwxr-xr-x 1,7k root 26 out 05:35  mkinitcpio-remove
.rwxr-xr-x 7,4k root  3 jun  2021  snap-pac
.rwxr-xr-x 1,1k root  3 nov 13:18  systemd-hook

I found something else though.. While updating Garuda, an error occurs with grub.
Here is the output on the console:

(16/31) GRUB update after transactions...
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2022-11-10 12:28:26 | @/.snapshots/19/snapshot   | pre    | pacman -Su                                                 |
Found snapshot: 2022-11-10 12:16:43 | @/.snapshots/17/snapshot   | pre    | pacman -Su                                                 |
Found snapshot: 2022-11-10 12:04:39 | @/.snapshots/16/snapshot   | post   | qt5-charts stacer                                          |
Found snapshot: 2022-11-10 12:04:37 | @/.snapshots/15/snapshot   | pre    | pacman -S --noconfirm stacer                               |
Found snapshot: 2022-11-10 11:24:28 | @/.snapshots/13/snapshot   | pre    | pacman -Su                                                 |
Found snapshot: 2022-11-10 11:01:58 | @/.snapshots/12/snapshot   | single | boot                                                       |
Found snapshot: 2022-11-10 10:54:07 | @/.snapshots/8/snapshot    | pre    | pacman -Su                                                 |
Found 7 snapshot(s)
Unmount /tmp/grub-btrfs.JPaFvaGidl .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

It looks like grub can't find the partition where Garuda is installed!?

After that, setting Boot to: Garuda Linux sugested by @SGS is not available anymore.
Only options available then are:

  • UEFI Firmware Settings
  • Garuda Linux snapshots
  • Memory Tester (memtest86+)
  • Shutdown
  • Restart

Same thing happening to me. There's something wrong with the latest update.
Restored image before the update and waiting for this to get fixed...

2 Likes

This may be related to Mkinitcpio-Install hook not running when updating:

Which is now being fast-tracked into being fixed.

6 Likes

Updated Garuda now and it is fixed!!

Thank you all for your time.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.