Why doesn't my computer see my Wi-Fi network?

$ inxi -Faz
System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=179b848a-d752-453c-8e55-0fb01cf9d4e7 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Laptop System: Hewlett-Packard product: HP Compaq 6720s v: F.0A serial: <filter> Chassis: type: 10
           serial: <filter>
           Mobo: Hewlett-Packard model: 30D8 v: KBC Version 83.0E serial: <filter> BIOS: Hewlett-Packard
           v: 68MDU Ver. F.0A date: 04/14/2008
Battery:   ID-1: C23B charge: 39.1 Wh (85.7%) condition: 45.6/45.6 Wh (100.0%) volts: 11.6 min: 10.8
           model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Discharging
CPU:       Info: Dual Core model: Intel Core2 Duo T5670 bits: 64 type: MCP arch: Core Merom family: 6 model-id: F (15)
           stepping: D (13) microcode: A4 cache: L2: 2 MiB
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7182
           Speed: 1329 MHz min/max: 800/1801 MHz boost: enabled Core speeds (MHz): 1: 1329 2: 1574
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
           Type: l1tf mitigation: PTE Inversion
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass status: Vulnerable
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Mobile GME965/GLE960 Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:2a12 class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") s-diag: 398mm (15.7")
           Monitor-1: LVDS1 res: 1280x800 hz: 60 dpi: 99 size: 330x210mm (13.0x8.3") diag: 391mm (15.4")
           OpenGL: renderer: Mesa DRI Intel 965GME/GLE (CL) v: 2.1 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
           chip-ID: 8086:284b class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel 82562GT 10/100 Network vendor: Hewlett-Packard driver: e1000e v: kernel port: 4020
           bus-ID: 00:19.0 chip-ID: 8086:10c4 class-ID: 0200
           IF: enp0s25 state: down mac: <filter>
           Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB driver: r8188eu bus-ID: 2-2:2
           chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
           IF: wlp0s29f7u2 state: up mac: <filter>
Bluetooth: Device-1: HP Bluetooth 2.0 Interface [Broadcom BCM2045] type: USB driver: btusb v: 0.8 bus-ID: 3-1:8
           chip-ID: 03f0:171d class-ID: fe01
           Report: bt-adapter ID: hci1 rfk-id: 14 state: up address: <filter>
           Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 bus-ID: 7-1:2
           chip-ID: 0a12:0001 class-ID: e001
           Report: ID: hci0 rfk-id: 13 state: up address: N/A
Drives:    Local Storage: total: 111.79 GiB used: 107.18 GiB (95.9%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: SSD2SC120G1CS1754D117-551 size: 111.79 GiB block-size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 1101 scheme: MBR
Partition: ID-1: / raw-size: 111.79 GiB size: 111.79 GiB (100.00%) used: 107.18 GiB (95.9%) fs: btrfs dev: /dev/sda1
           maj-min: 8:1
           ID-2: /home raw-size: 111.79 GiB size: 111.79 GiB (100.00%) used: 107.18 GiB (95.9%) fs: btrfs dev: /dev/sda1
           maj-min: 8:1
           ID-3: /var/log raw-size: 111.79 GiB size: 111.79 GiB (100.00%) used: 107.18 GiB (95.9%) fs: btrfs
           dev: /dev/sda1 maj-min: 8:1
           ID-4: /var/tmp raw-size: 111.79 GiB size: 111.79 GiB (100.00%) used: 107.18 GiB (95.9%) fs: btrfs
           dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 3.82 GiB used: 526.6 MiB (13.5%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 47.0 C mobo: 27.6 C
           Fan Speeds (RPM): N/A
Info:      Processes: 189 Uptime: 2d 18h 48m wakeups: 12 Memory: 3.82 GiB used: 2.54 GiB (66.5%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1346 lib: 341 Shell: fish v: 3.3.1
           default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.08

I have two WiFi networks in my house. One of them is showing up, the other is not. It used to work on my laptop, but now it's not in the list of available networks. I've tried

  • rebooting
  • updateing
  • unplugging the dongle and plugging it back in
  • soft and hard reset of the router
  • deleting the network from settings

Any cache files I can nuke, packages to reinstall, logs to read to try to figure this out? Seem so bizarre it shouldn't be possible, and yet...

This post, with your same driver and I think a similar issue, was solved disabling MAC address randomization (but with a config file, not simply the flag, I think).

4 Likes

Because of your 2008 BIOS, maybe?

2 Likes

Thanks, that fixed it.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.