Why are the titles bars different in GNOME?

I just booted into the live USB of the gnome edition and for some reason librewolf has the adwaita title bar and the file manager has the normal sweet title bar. (Same issue with time shift as well)

Is this a bug?

Does this also happen while full screen :thinking:

Also, I noticed same on telegram.

Let me boot Gnome (I am currently on kde)

3 Likes

Yes, it happens while in full screen as well. (It might be because it was off the live usb but im not sure)

I am also experiencing this problem, just after installing the latest Garuda Gnome (February).
Imgur

Alacritty, Librewolf, Garuda Gamer (and probably other apps) have the light colored top bar. The stock Gnome Apps (at least the 4 I checked) have the proper themed topbar. This is a totally fresh install zero customizations or configuration beyond what is done through the setup assistant.

1 Like

Did you install librefox from a snap? Back when i used ubuntu that used to happen for snap apps.

1 Like

Did you install librefox from a snap

not me (not sure about OP), this is a 100% fresh install (apart from running pacman -Syu and setup assistant), librewolf was installed by default I believe (and also its not the only affected app).

Edit:
okay following:
*sudo pacman -Syu
*sudo pacman -S nvidia-dkms
*system reboot
...seems to have solved the problem

3 Likes

Well, I booted GNOME and in live session too, it showed proper titlebar, as expected.

Maybe graphics driver issue, as mentioned by @Xeon in above post

4 Likes

It's maybe because I booted off the live usb using the open source drivers. I'll try it with the nvidia drivers and see what happens.

Just for the record, Garuda Linux does not support and nor do we recommend the use of snaps/flatpaks.

4 Likes

Nope :frowning: got the same issue when booting from the NVIDIA drivers .

Did you follow instruction by Xeon?

2 Likes

There was one additional step I left out of my previous post (I left it out because I thought it was not relevant and I did it to solve a separate graphics issue).

After the reboot, I went into gnome settings and changed the screen resolution, to a low resolution and then back to 1920x1080. I did this to fix another problem not the titlebar issue, and I can't see how it could be related, but its maybe worth a try...

I just tried it out in the Live USB. Xeon's instructions can only be applied after installing it and I don't plan on installing it. I just wanted to see how the gnome edition looked and saw that tiny error. Thanks for helping!

Its something to do w/ qt I know that, but IDK how to fix it.
Edit switching to tkg-bmq solved it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.