Whoogle stopped running: libffi.so.7

Hey all,

After a recent update whoogle stopped working. So, I ran a

systemctl status whoogle

And got this:

ā— whoogle.service - Whoogle
     Loaded: loaded (/usr/lib/systemd/system/whoogle.service; enabled; vendor preset: disabled)
     Active: activating (auto-restart) (Result: exit-code) since Wed 2021-10-20 12:32:08 EDT; 738ms ago
    Process: 91929 ExecStart=/opt/whoogle-search/venv/bin/python3 -um app --host --port 5000 (code=exited, status=1/FAILURE)
   Main PID: 91929 (code=exited, status=1/FAILURE)
        CPU: 433ms

So, I manually ran the script (both with and without sudo) and this was the Traceback:

Traceback (most recent call last):
  File "/usr/lib/python3.9/runpy.py", line 188, in _run_module_as_main
    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
  File "/usr/lib/python3.9/runpy.py", line 147, in _get_module_details
    return _get_module_details(pkg_main_name, error)
  File "/usr/lib/python3.9/runpy.py", line 111, in _get_module_details
  File "/opt/whoogle-search/app/__init__.py", line 1, in <module>
    from app.filter import clean_query
  File "/opt/whoogle-search/app/filter.py", line 5, in <module>
    from cryptography.fernet import Fernet
  File "/opt/whoogle-search/venv/lib/python3.9/site-packages/cryptography/fernet.py", line 18, in <module>
    from cryptography.hazmat.primitives import hashes, padding
  File "/opt/whoogle-search/venv/lib/python3.9/site-packages/cryptography/hazmat/primitives/padding.py", line 13, in <module>
    from cryptography.hazmat.bindings._padding import lib
ImportError: libffi.so.7: cannot open shared object file: No such file or directory

Seems similar to this issue, which has since been resolved by FireDragon devs:

This has been posted as an issue on their repo as well....

The issue isn't resolved. I thought it had to do with Plasma updates, but looks like from this it's something else.

What I meant was, the FireDragon issue was resolved by the devs/pkg mgrs with a rebuild.

There is a Whoogle update that just got pushed, so good here.


Hi, @shayaknyc .
I hope your issue has been fixed with the latest Whoogle update. If so, kindly mark it solved.
Otherwise, report here again.

1 Like

Just had a chance to update to latest package, and this issue was resolved! Thanks for the heads up!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.