Where to install packages

Hello

I switched to garuda linux and it's amazing but I have problems with installing packages, because I have an 128gb ssd(for root and swap) and 1tb hdd(for two partitions made using gnome disks) and no matter if it was pacman,paru or nix every package I install get stored on the ssd and the hdd remains empty I really want to use (pacman,paru,nix..etc) without filling my ssd,here is a view of my fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=5EAA-C031                            /boot/efi      vfat    umask=0077 0 2
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /              btrfs   subvol=/@,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=923ceba2-d4fd-407b-8890-734d2a76767d /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=7a9e1238-1c9c-444c-9fe6-45b64f9604d0 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-uuid/174921f5-4de2-4537-96d3-c7c04889b757 /mnt/174921f5-4de2-4537-96d3-c7c04889b757 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/fa811833-a75f-43c8-ae03-521e41341b87 /mnt/fa811833-a75f-43c8-ae03-521e41341b87 auto nosuid,nodev,nofail,x-gvfs-show 0 0
# Binderfs Anbox
none /dev/binderfs binder nofail 0 0






Welcome :slight_smile:

Please post your garuda-inxi.

This is not M$, I think 120GB is more than enough storage, if need be you can swap /home to the slow HDD.

8 Likes

here

System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
Console: pty pts/0 Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 80WK v: Lenovo Y520-15IKBN
serial: <filter>
Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO
v: 4KCN40WW date: 10/17/2017
Battery:
ID-1: BAT0 charge: 34.5 Wh (87.8%) condition: 39.3/45.0 Wh (87.2%)
volts: 11.1 min: 11.1 model: SMP L14M3P24 status: discharging
CPU:
Info: quad core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
arch: Kaby Lake rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 2550 high: 2800 min/max: 800/3800 cores: 1: 2800 2: 800
3: 2800 4: 2800 5: 2800 6: 2800 7: 2800 8: 2800 bogomips: 44798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: Intel HD Graphics 630 vendor: Lenovo driver: i915 v: kernel
arch: Gen-9.5 bus-ID: 00:02.0
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo
driver: nouveau v: kernel arch: Pascal bus-ID: 01:00.0
Device-3: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-6:3
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
loaded: modesetting gpu: i915 resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.1.6
direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtl8821ae v: kernel port: 4000 bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0
IF: enp4s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek RTL8821A Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-11:4
Report: bt-adapter ID: hci0 rfk-id: 4 state: up address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 9.6 GiB (0.9%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW128HEGR-000L2
size: 119.24 GiB temp: 27.9 C
ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
Partition:
ID-1: / size: 101.88 GiB used: 9.52 GiB (9.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 608 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 101.88 GiB used: 9.52 GiB (9.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-4: /var/log size: 101.88 GiB used: 9.52 GiB (9.3%) fs: btrfs
dev: /dev/nvme0n1p2
ID-5: /var/tmp size: 101.88 GiB used: 9.52 GiB (9.3%) fs: btrfs
dev: /dev/nvme0n1p2
Swap:
ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.07 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p3
Sensors:
System Temperatures: cpu: 36.0 C pch: 43.5 C mobo: N/A gpu: nouveau
temp: 33.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 316 Uptime: 2h 58m Memory: 15.52 GiB used: 2.75 GiB (17.7%)
Init: systemd Compilers: gcc: 12.1.1 Packages: 1165 Shell: fish v: 3.5.1
inxi: 3.3.20

You can also move your pacman cache to an alternate location.

I agree, I use 120 GB drives with all my Garuda installs and I've never had space issues.

Store your space gobbling files (such as videos) on the HDD and simply symlink these files into your home directory.

5 Likes

Packages are stored on

/var/cache/pacman/pkg

Symlink the directory on somewhere on your HDD. /var/cache stores other large files among pacman cache, you can remove its entry from /etc/fstab and symlink it to your HDD if you wish.

1 Like

You can also edit your pacman conf to change the pacman cache path, (rather than symlinking)

1 Like

Well I tried that and installed kamoso but the hard drive is still empty

Relocating the pacman package cache does not move the location of installed packages. That is not easily possible with Linux. Changing the cache location simply saves space because the cache can grow to many GB if not cleaned regularly.

I think you are misunderstanding here, the location the program/package is installed to is not easily changeable by the user. This is not Windows, you don't get to choose a custom install location for every program.

You should perhaps do a little reading about how Pacman works on the Arch Wiki.

2 Likes

I swiched to linux on the promise of controlling my own system, but apparently I can control everything but the essentials
I'am gonna let pacman install packages where it wants and install everything else by the AUR manually

I think it is likely you will revise this strategy after you learn a little more about how your new Linux system works.

What on earth are you planning on doing with a 120GB drive if you don't want to store software or user files on it? You'll be hard pressed to get the system files up over a few gigs.

2 Likes

https://wiki.archlinux.org/index.php/arch_filesystem_hierarchy

4 Likes

Use AppImages from websites like this:

1 Like

So my 120gb are enough to install applications in using pacman ? (with installing steam games,symlinking videos and installing large applications with AUR on the hard drive)

Yes, 120GB is plenty of space for as many applications as you like. Especially if you symlink your home folder to the HDD, you will probably find that 120GB is a ton of space.

Games, movies, photos, and other user files will be stored in your user's home folder somewhere, unless you change that on purpose. So Steam itself is a software that will get stored in the system files (on your SSD), and the Steam games are user files (that will be stored on your home folder, which you can symlink to the HDD).

Won't symlinking cause issues with steam games ?

I can't imagine a scenario where symlinking your home folder would cause an issue with a game, or anything else. Personally for me it has always worked just great.

Another very common configuration is to mount /home on a drive or partition separate from the one / is mounted on. If setting up symlinks makes you uneasy, that is another simple way to set up the same thing (in your case, mount the HDD on /home and set it up permanently in your /etc/fstab).

1 Like

I will use symlinks and if a problem showed up I will consider the other options,thanks for the help, and also how can you show your country's flag ?

on the bottom.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.