Whenever I am changing any setting or when I woke my PC from sleep mode than the keyboard and mouse are not working properly

When I opened application launcher and type "r" to search something it directly goes to Restart the computer option. And in open office, when I am trying to write something it opens tools and anything else but not typing a thing. But when I reboot my PC it start normally and keyboard is also working fine. Please help

Becuase you may not have any "apps" which begin with "r". Not exactly a problem. Which DE?

Do you mean that when you open LibreOffice it dosen't respond to typing?
Does any application even detect typing?
It could be a problem with the LibreOffice program. Try updating your computer, and re-installing LibreOffice.
Post the output of

inxi -Faz

so that you can get help from more knowledgeable people.

1 Like

The typing problem seems to occur with every application when it starts to happen. When it woke from sleep mode than it is misbehaving. Recently I am filling a form for competitive exam in brave than suddenly it starts to open tools before that it working fine.

I tried "inix -Faz" but no result.

Now I am typing Brave in krunner and it opens widgets.

Welcome in Garuda forum :slight_smile:

Don't go in sleep mode, open konsole, type

inxi -Faz

post in and output as text.

Keyboard and mouse are wired or wireless?

Wired keyboard and mouse

╭─[email protected] in ~  
╰─λ inxi -Faz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LANG = "en_IN"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=837744ba-4cbd-4056-9b6d-004274fc2001  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=d0c9195b-9f72-4e0e-b5e4-288ce1e8176b loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Portable System: Dell product: Vostro 1550 v: N/A serial: <filter> Chassis: type: 8  
serial: <filter>  
Mobo: Dell model: 061W4M v: A06 serial: <filter> BIOS: Dell v: A06 date: 04/08/2014  
Battery:   ID-1: BAT0 charge: 31.1 Wh (84.3%) condition: 36.9/48.8 Wh (75.6%) volts: 11.7 min: 11.1  
model: Samsung SDI DELL 7XFJJA2 type: Li-ion serial: <filter> status: Discharging  
CPU:       Info: Dual Core model: Intel Core i3-2310M bits: 64 type: MT MCP arch: Sandy Bridge family: 6  
model-id: 2A (42) stepping: 7 microcode: 2F cache: L2: 3 MiB  
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16761  
Speed: 882 MHz min/max: 800/2100 MHz Core speeds (MHz): 1: 882 2: 2095 3: 1686 4: 2095  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell  
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0116 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")  
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")  
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.2.1 compat-v: 3.0  
direct render: Yes  
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell  
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.34 running: yes  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169  
v: kernel port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp5s0 state: down mac: <filter>  
Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Dell driver: wl v: kernel  
modules: bcma port: e000 bus-ID: 09:00.0 chip-ID: 14e4:4727 class-ID: 0280  
IF: wlp9s0 state: up mac: <filter>  
Bluetooth: Device-1: Broadcom BCM2070 Bluetooth 2.1 + EDR type: USB driver: btusb v: 0.8 bus-ID: 1-1.4:3
chip-ID: 0a5c:21bc class-ID: fe01 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 15.85 GiB (3.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS547550A9E384 size: 465.76 GiB
block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: A50A scheme: MBR
Partition: ID-1: / raw-size: 457.52 GiB size: 457.52 GiB (100.00%) used: 15.85 GiB (3.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 457.52 GiB size: 457.52 GiB (100.00%) used: 15.85 GiB (3.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 457.52 GiB size: 457.52 GiB (100.00%) used: 15.85 GiB (3.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 457.52 GiB size: 457.52 GiB (100.00%) used: 15.85 GiB (3.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.74 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.24 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2
maj-min: 8:18
Sensors:   System Temperatures: cpu: 63.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3396
Info:      Processes: 226 Uptime: 3m wakeups: 1 Memory: 3.74 GiB used: 1.86 GiB (49.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1399 lib: 345
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

i input the command.

But just after this it starts to do the same thing. Instantly it opened krunner when I was pressing back space.

Maybe you can check this thread.
The last post seems to have solved, although, if not working, I definitely think you should apply the steps at post #10.

Does your keyboard/mouse even get listed in

lsusb

?
Post that output also.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.