What fuccking idiot would put a time out on a password prompt!

And no really...I thought the arch community people were smart but why is a feature that has not a single good purpose. NOT ONE! The only function it has is to make sure that when there is a long process is running, like compiling a kernel, and you are asked to renew sudo with your password you can't. Because let's face it nobody is going to sit 10 to 15 hours or longer to wait for that to happen. And the password prompt time out has been so ridiculously short that you will ALWAYS miss it.
It has cost me four days trying to install the xanmod-rt150 kernel from the aur.
pacman -U doesn't work. I have tried. putting "Defaults passwd_timeout=0" into sudoers doesn't work. I have tried. AND IT'S COSTING ME ■■■■■■■ DAYS! And a keyboard...I just found out they can't handle being thrown across a room against a wall to well. Who knew?
But no really... what the ■■■■ is wrong with you guys to leave something like that,which only is going to make people frustrated and miserable, and does not do one ■■■■■■■ thing for security in your distro that you want as many people as possible to use. Because even before I destroyed my keyboard today when I became aware of the problem I thought "Oh my god, once I figure out how to kill the time out, this is going to be one of those things I have to do straight away after I do a new install every ■■■■■■■ time." Because lets face it it's a flaw in the system.
And since I'm in Hulk mode now anyway. Didn't want to mention it before because it is a small anoyance. The default grub time out of Garuda is ridiculous, just a few seconds. Not even long enough to read half the options when you come across it for the first time. And again what is the use of the bloody time out? Because let's face it, it will always start up the wrong thing. In my experience that's the whole thing about time outs. It's stressing people to pay attention to them or else it does something that you don't want it to do.. Pretty much like a cat. In this case it will start up Garuda with the zen kernel, I almost always use Muqss or sometimes cacule or what often happens is windows starts doing an update while I'm not watching and thus restarting. Anyways the result is always the same I have to reboot the computer. And the problem is actually the same as with the prompt time out. It should wait for me to tell it what to do, and not go off by itself and do the wrong thing. I shouldn't rush, the computer should wait.
By the way I don't know why. I compiled a real time kernel for my laptop which was built on Garuda KDE bare bones but there pacman -U did restart the process. My PC rums on a base of Garuda KDE Dragonized Gaming edition and pacman -U can't find the cashed process.
I'll figure it out. I'm sorry for the rude rant...But then again really I'm not because there is no good reason for this problem that from what I read has been bugging people for ages still to exist. And as a reaction people tend to go for permanent root which is the last thing you want.

You're doing it wrong.

https://wiki.archlinux.org/title/Makepkg

10 Likes
6 Likes

I probably shouldn't respond to a rant but....

To solve your problem either use makepkg+pacman or both paru & yay support a sudoloop option which prevents being asked for a password at the end.

pacman -U takes a path to the package, not a package name. You need to point it at the package that was built. It doesn't try to find anything.

There is no "right" answer here. Many people complain that the timeout is too long. You can set it to whatever you want on your system though.

8 Likes