Weirdly laggy desktop animations (NVIDIA)

HI,

Recently I dual booted with windows and garuda (Dragonised Plasma).

I really enjoy it so thank you for the team for making a really cool OS, however I seem to get some weirdly laggy animations. I searched everywhere and people with Nvidia cards sometimes have this issue.

Example of animations: Switching between virtual desktops, opening calendar (top right), changing application size from maximised (so Meta+Left sometimes takes a little time).

I have the "video-chaotic-nvidia-dkms-tkg" driver installed, I have tried to remove it but I can't seem to do it as it breaks dependencies

My CPU runs at around 4.2GHz on 12 threads sometimes, and most applications work really well, it is just these animations that lag

Here is the result of “inxi -Fxxxza”
https://bin.garudalinux.org/?90277b5a40c8b421#3U6gvuJzypc1KtiCCb7d4MsvqZWSxPuEPXNHM22r4Dv7

Can anyone help?

Hi Th0ust,

Please try this first: :mag: and search for "NVIDIA" !
Please read: Reporting bugs | Garuda Linux wiki

Cheers and Welcome to the forum! :wink:

2 Likes

My apologies,

I am not sure how to better word the problem but I have added the result of that command.

The problem is that you install the wrong driver for GeForce GTX 1060.
It's Pascal architecture, nvidia-390xx-dkms is the correct driver.
And 390 and lower branches are not supported for the driver you installed.
To fix this:

  1. Garuda Settings Manager -> Hardware Configuration
  2. Untick all the pipes :ballot_box_with_check:
  3. Auto Install Proprietary Driver
  4. Check your kernel headers you have with

pacman -Q | grep headers

  1. After Install the kernel headers:
    sudo pacman - S linux- ... -headers
  2. dkms now will be triggered and install your driver automatically
  3. sudo reboot
1 Like

step 5 and 6 are not necessary.
I just usually want to be sure it's workin correctly or not :slight_smile:

1 Like

IIRC Fermi is the latest for 390. All the newer are for mainline.
https://nouveau.freedesktop.org/CodeNames.html
https://wiki.archlinux.org/index.php/NVIDIA#Installation

@Th0usT you should try changing compositor settings.
First disable compositor to see if there are no problems.
If it solves your problem, then enable again and try available options, like XRender.

But without logs we cannot actually help.

4 Likes

Hello,

Using OpenGL 2.0 seemed to help,

There is some lag here and there but it is a very minor issue I think I might live with it.

Thank you very much for your quick reply, and sorry for being a bit new to all this.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.